8 Replies Latest reply: May 3, 2012 12:52 PM by wordzenpix
Nature1953 Level 1 (10 points)
After some too cavalier abuse of permissions, I managed to software lock up one external drive, one internal drive and wreck my OS on a Mac G5 OS 10.5.8. The Mac is now sorted (and its second internal drive unlocked again, thanks to DiskUtility).

But my problem is a 4Tb external Iomega +UltraMax Plus 4TB eSATA/USB 2.0/FireWire 400/FireWire 800 Desktop Hard Drive+. DiskUtility won't touch its permissions.

If I unpadlock the "Get info" - which I can - the permissions all say "Custom". They won't budge from that. Altering the drive's Filesharing settings in System Preferences has no effect. The icon of the drive itself has a padlock in one corner. I also can't get into it from my MacBookPro. Same thing. Padlocked icon and I can't open the drive.

Reformatting the drive and losing the content is NOT an option.

MacBook Pro (10.5.8) Power Mac G5 (10.5.8/10.4.11) PowerBook G4 (10.4.11), Mac OS X (10.5.8), Classic rules!
  • Nature1953 Level 1 (10 points)
    Phew. Done it. In Terminal:-

    sudo chflags 0 /Volumes/firstname\ secondname
    sudo chown 0:80 /Volumes/firstname\ secondname
    sudo chmod 775 /Volumes/firstname\ secondname
    sudo chmod -N /Volumes/firstname\ secondname
  • yoshison Level 1 (0 points)
    I purchased a new macbook pro and through the network i was unable to open files. error stated io didn’t have permission. so like the genius that i am i went and authorized myself and included all subfolders. well needless to say i’m now locked out of my data drive in my system but also my 3TB external raid that has my backups on it. the permissions are all custom and not changeable and the drives both have a lock logo on them and are completely inaccessible. I would appreciate any help you could provide.

    kindly,
    Josh
  • Nature1953 Level 1 (10 points)
    I can tell you that using Disk Utility and running "repair permissions" on internal boot drives plus where necessary, the above Terminal instructions on external disks, worked for me.
  • Nature1953 Level 1 (10 points)
    You can run both Disk Utility and Terminal from an OS installation DVD.
  • baltwo Level 9 (62,215 points)
    See Niel's guide.


    VK said for locked HDs and volumes at http://discussions.apple.com/thread.jspa?threadID=2329689

    sudo chflags 0 /volumes/*
    sudo chmod a+rx /volumes/*
  • Keith Scheuermann Level 1 (0 points)

    This terminal command list saved my bacon.

    Thank you for posting it.

  • wallyfromtemple Level 1 (0 points)

    Thanks for posting that. I had a similar problem and those terminal commands saved the day for me! I had six drives locked out with locked custom permissions. After running all 4 commands on the first one, I just ran the chflags command on the others and that allowed me to unlock and change the permissions using the finder get info menu commands.

  • wordzenpix Level 1 (0 points)

    I have exactly the same problem, all internal and external drives except one on my Mac Pro are locked, useless. I was having glitchy permission problems so tried the same thing in an effort to stop the problems only to find myself locked out of everything. Why would Apple even make such a vicious routine? That shouldn't be part of any operating system. One-stop castration with apparently no cure.