4 Replies Latest reply: Aug 31, 2013 7:17 PM by Crash-X
Don Ayer Level 1 Level 1 (25 points)
Anybody having problems with this? I sure am. Home Sharing with my iPhone and iPad simply will NOT see Home Shared iTunes libraries on any wired computers.

For example: at work I have an iMac and a MacPro. The iMac connects to an AirPort Extreme wirelessly, while the MacPro is wired to the same Airport Extreme. My iPhone and iPad are also connected wirelessly, of course. The two computers have home sharing enabled and each can see and share with the other. My iPhone and iPad have also been set up, but they can only see the library on the iMac (connected wirelessly, remember). They cannot see the hard-wired MacPro.

Another bit of goofy: I just tried the Remote App on my iPhone and it has no problem talking to either of my Macs. File sharing, Remote Desktop, etc. are all still functioning fine.


Home is a bit different where I've got 4 macs (2 wired and 2 wireless), all connected through a Linksys router. In that setup, NONE of the computers see any of the other Home Shares on the network. But Remote App, Remote Desktop, VNC on my iPad, etc. all function between wireless and wired devices without issues.

The extra goofy there: I've been using the older, limited version of Home Sharing for the last couple years, moving music between my Macs' iTunes libraries flawlessly. That seems to be broken now.

Thoughts?

Mac MIni, Mac Pro, iMac, G5, MacBook, MacBook Pro..., Mac OS X (10.6.6), All software up to date, but a mix of 10.5 and 10.6 machines
  • Don Ayer Level 1 Level 1 (25 points)
    Well, I fixed the home setup. I use a Linksys E3000 and had "Wi-Fi Protected Setup™ " enabled. This is supposed to just simplify adding new devices to the network but it must also affect the traffic that passes through the router. I had no need for the feature, so I turned it off and went to "Manual" and everything magically worked. Go figure.

    Guess I'll attack the office network again on Monday. :/
  • Kev.Belisle Level 1 Level 1 (0 points)

    Haven't tried this yet but I have a feeling you just solved my problems...

     

    I just hate it when they put in these SuperAwesome(TM) "security" features and enable them by default...

    A good router should be just that, a router, it shouldn't get in my way and I don't want any "value-added" features; all I want is reliability... Keep it simple, stupid!

  • pdbianco Level 1 Level 1 (0 points)

    I have been fighting this for several days and finally found the answer. My problem was that my wired PC was not visible to my wireless devices. I have 3 apple tv's and several ipads running the remote app. I tried reinstalling   itunes and all its services several times, rebooting all my devices and then deauthorizing and authorizing my pc until i was blue in the face. None of this had any effect. I  then tried wireing one  of my apple tv's into the router instead  of connecting it wireless and my pc became visable only to that apple tv. I researched a little more and then found a little note about turning off IGMP Proxy on my router. I tried this and then restarted itunes. Problem solved! Now my wired PC is now visable to all my wireless devices. I hope this helps

  • Crash-X Level 1 Level 1 (0 points)

    Nice catch!

     

    Disabling IGMP Proxy on my Verizon FIOS router fixed the issue for me too. I had the same oddball symptoms where a mix of wireless and wired connections couldn't see each other. I dug a bit into my router's config and found IGMP Proxy settings under the Advanced section of the config. Shortly after setting it to Disabled my home sharing files showed right up on my AppleTV.

     

    Good stuff.

     

    Regards.