Previous 1 2 3 4 5 Next 60 Replies Latest reply: Jan 28, 2013 6:36 AM by shajahanc Go to original post
  • Fubar_UK Level 1 (0 points)
    Nice one TallBear - enabling WMM fixes the issue for me too. Why the he'll don't Apple Support know about this and inform us when we call!

    This still isn't acceptable as a solution though - what if you want to connect to a public WiFi setup that's N only and they don't have WMM enabled? Say "excuse me, can you change the config on your router please?" Not good Apple - why have you done this?

    Message was edited by: Fubar_UK
  • thanxal Level 1 (0 points)
    Anyone know how to do this on an Apple Airport Extreme?
  • wilsons66604 Level 1 (0 points)
    setting the WME option was no help for me
  • rutiger77 Level 1 (0 points)
    wmm is mandatory for 802.11n. why don't tech support people know? because they are monkeys sitting in a call center with little to no knowledge of anything more than suggesting rebooting or reinstalling software.
  • iFrodo Level 1 (40 points)
    Great for you, but my router doesn't have any WMM or WME option, so I simply can't fix this issue myself.

    That is not normal that you can't use 802.11n without WMM, Apple should fix that ASAP on iOS itself.
  • tgibbs Level 1 (70 points)
    iFrodo wrote:
    Great for you, but my router doesn't have any WMM or WME option, so I simply can't fix this issue myself.

    That is not normal that you can't use 802.11n without WMM, Apple should fix that ASAP on iOS itself.


    As others have pointed out, WMM is required by the 802.11n spec, and 802.11n will not function properly without it. So if your router does not support it, it is a router problem; a fix from Apple is unlikely. If you can't get an update from your router manufacturer, you might want to check whether your router will support the open source router firmware that is available on the net
  • AlAntlitz Level 1 (0 points)
    I have a similar problem. There are two iPhone 4s on my Netgear WND3700 router. The problem started when I upgraded one of the phones to 4.3.

    My phone would keep dropping wireless connection and would sometimes could not log on to my network.

    I have a temporary fix - I set the router option form upto to 300 mbs to 130. I assume this makes not run in N mode.

    Apple needs to fix this problem.
  • BG-Pete Level 1 (0 points)
    I have not yet upgraded to 4.3 and quite frankly, am a little afraid to. My wife's iPad2 is on order and I want to make sure hers works properly or I will never hear the end of it...lol. I have a Linksys E3000 router. I looked everywhere. Does anyone know where in the router configuration I need to go in order to enable WMM. Thanks for the help.
  • rutiger77 Level 1 (0 points)
    it's right in the user guide on the linksys site: http://homesupport.cisco.com/en-us/wireless/linksys/E3000. it's enabled by default. enabled should be the default on any 802.11n certified access point.
  • Naulak Level 1 (0 points)
    really hate this ... my ipod touch 4g couldnt connect to my ad-hoc post the ios 4.3 installation .... could you please help me on how you downgraded the ios? ive been to the service center and called the customer care ... they just told me there is no way of downgrading after the upgrade .. thanks !
  • JKtheMac Level 1 (0 points)
    After a bit of settings wrangling I have finally managed to get a consistent connection on my Linksys E3000, as mentioned WMM was part of the problem, but turning it on made my connection intermittently drop out. CTS Protection Mode has proved to be the cause of this, as setting this to disabled has meant that I only very occasionally see a split-second drop of network, and streaming video has not been a problem since.

    BG-Pete: WMM can be found under Applications and Gaming / QoS
    This setting is indeed on by default but so many people across the Internet seem to think that WMM is a problem with multiple equipment, you may have turned it off.
    Also, CTS Protection Mode is found in Wireless / Advanced Wireless Settings and can be individually configured for each frequency.
  • BG-Pete Level 1 (0 points)
    Thanks JK. I found those settings and WMM was enabled and CTS is set to auto. Still have not upgraded to 4.3 since I am waiting for my iPad2 to arrive and I have my iPad "classic" sold. Hopefully, thing will go flawlessly...yeah right.
  • JKtheMac Level 1 (0 points)
    Just to clarify I had to switch CTS from auto to OFF in order to get a solid connection. However CTS is designed for heavy traffic from multiple devices so it shouldn't be an issue in most homes. However, CTS issues may explain the problems some have had in public wifi locations.

    My ideal solution (based on my devices and local noise) was to have different SSIDs for 5GHz and 2.4GHz and set 5GHz to N only and 40MHz width. I then use 5GHz purely for my iPad and everything else on 2.4GHz (mixed mode).
  • mike.mn Level 1 (0 points)
    This fixed my problem too. I just downloaded OS 4.3, and my home WIFI would no longer connect. I changed my router settings to enable WMM, and problem solved. Thanks for the tip. Curses to Apple for changing this without notifying us. Seems more like something MS would do!
  • tgibbs Level 1 (70 points)
    Some people seem to have some remarkably unrealistic ideas about what Apple can be expected to test for before releasing a new OS update. Is it really reasonable to expect that Apple should have checked for whether the update will work properly under 802.11n if the user has mistakenly disabled a service that is required for the 802.11n specification? There are a lot of routers, and a lot of possible ways to misconfigure one. Apple is not going to be able to check the consequences of every possible user error.