Previous 1 2 Next 22 Replies Latest reply: May 24, 2011 3:09 PM by fender542
RobinoFree Level 1 Level 1 (0 points)
I have an iPod Touch 4G 8GB and every time I try to upgrade to iOS 4.3 it gives me the error message: "The iPod "Rob's iPod" could not be updated. This device isn't eligible for the requested build."

Anyone know how to fix this? Thanks

iPod Touch 4, iOS 4
Previous 1 2 Next