Previous 1 2 3 4 Next 92 Replies Latest reply: Mar 12, 2012 3:23 PM by glenw1 Go to original post
  • M Gnu Level 1 (0 points)
    My iPhone 4 had the wrong time this morning - in Phoenix. We don't do DST, but iPhone apparently thinks otherwise. Woke up an hour earlier because alarms were ahead. This is not that hard of a defect to fix.....
  • iSRS Level 1 (40 points)
    Add me to the list of Verizon not working unless I turn off automatic
  • Lawrence Finch Level 7 (33,995 points)
    Is time set to Automatic (meaning it's a Verizon problem) or is Automatic off (meaning it's an Apple problem)? And if it's off does the phone "know" you are in Phoenix (did you set your location in the time/date setup?)
  • Ranger06 Level 1 (0 points)
    Hi There I have the Iphone 4 and 4.2.1 os. I'm in Iraq and my time changed on time.
  • HauntedTank Level 1 (0 points)
    I also am in this same boat. But in a different country.
    I have to turn off "set automatically" for the time to stay correct.

  • spiritflare Level 1 (0 points)
    Initially mine (bell Canada) rolled forward 2 hrs. It has since corrected itself and synched to the carriers clock.

    When i manually tried to select 2AM it doesn't allow it.

    Can anyone try to choose 2am? Mine immediately sets to 3AM when choosing 2AM.

  • dr187 Level 1 (0 points)
    I'm experiencing the same symptoms several others have described above. Daylight savings time not updating to correct time unless I disable "Set Automatic" under Date and Time settings.

    Technical specs: Problem first appeared on my AT&T iPhone 3Gs running under iOS 4.2.1. After I noticed the problem, I updated to iOS 4.3, this did not resolve the problem. Neither did several hard reboots. I am located near the border between CST and EST in Farragut, Tennessee (suburb of Knoxville, TN).
  • Skeeterhdi Level 1 (0 points)
    I tend to agree with L. Finch that it is provider based. Have IPhone 3GS with OS 4.3. Phone left on all night and did not change time correctly. Time on phone was 1 hour behind. Tried syncing several times but no correction. Tried turning phone on/off several times, no correction. Turned off automatic time and manually set to correct time/place. Turned on automatic, phone went back to being hour behind. While phone was on and behind 1 hour, took out sim card, phone went to correct time (jumping ahead 1 hour). Did it several times to validate findings. I think I'll have to wait for ATT to update or head to their store for final solution.
  • Lawrence Finch Level 7 (33,995 points)
    You have a special situation. If Automatic is on the phone gets its time from whatever tower it is connected to. As you are on the border it could be syncing to a tower in the "wrong" time zone. You would probably be better off turning off Automatic. But in this case you should have noticed in the past that the time was sometimes an hour off.
  • dr187 Level 1 (0 points)
    I'm sufficiently far from the border, 40+ miles away. It has never been an issue in the Knoxville metropolitan area. Just adding regional info. Seems like the problem is widespread over the AT&T network.
  • Lawrence Finch Level 7 (33,995 points)
    Yes, I agree. It's localized though, because phones in my area updated correctly. I've noticed that AT&T's time is not all that accurate at any time, but it's pretty embarrassing if they can't get the DST switch right across the network. In a way its worse that it right in some areas and wrong in others, than if it had been wrong network wide. At least a network wide error would be easy to fix.
  • L Scott Level 1 (0 points)
    Same here, have an iPhone 3G and an iPad on AT&T network. Both have the latest software and both set to automatically update the date and time. The iPad correctly adjusted for daylight savings but the iPhone did not. Powering off then back on corrected the time on the iPhone.

    Message was edited by: L Scott
  • dr187 Level 1 (0 points)
    Yep, it seems to be a localized issue, sparsely distributed over random towers. Interesting to note that some Verizon customers are experiencing same problem. I wonder if these flaky towers share some kind of firmware or GPS satellite frequency. Maybe a bug in GPS earthquake correction code exposed by the earthquake in Japan, resulting in an ephemeris error (LOL - just a wild guess)??
  • beejayryan Level 1 (0 points)
    I came across this forum when I had the same prob with my ATT iPhone3G. At first the time displayed correctly, then a few minutes later it reverted back to Daylight Time. I looked at all the Settings, and Time was set to Automatic On. When I turned Automatic Off, I found that my Time Location was Anchorage, Alaska (which is not my location and which I'd never set). I changed it to Los Angeles (correct) and the time went to correct Daylight Savings. However, this did not FIX the problem, since I want the time to Automatically change for me. Next, I saw a forum post that suggested turning the phone off, then turning it on again. BEFORE I did this, I turned the Time Setting back to Automatic "On". Then I rebooted: powered phone off, waited a couple minutes, powered it back on. When it came on, I heard a distince "click", looked, and the time displayed correctly as Daylight Savings Time. (My Settings BEFORE rebooting were: Settings>General>Date&Time>Set Automatically-On.) Hope this helps some of you.
  • Pittwm Level 1 (5 points)
    I have same setup as yours and same problem his morning... I did the same thing hoping to resolve this. I bet if you open your setting again, the clock setting is on manual, not auto....
Previous 1 2 3 4 Next