Skip navigation

iPhoto pictures not syncing via iTunes to my iPod touch

8322 Views 11 Replies Latest reply: Apr 30, 2012 5:24 AM by dplin RSS
Jiri Krecek Level 4 Level 4 (1,080 points)
Currently Being Moderated
Mar 13, 2011 7:42 PM
I've got the latest iPhoto 11, iTunes 10, Snow Leopard and iOS 4.3.

1/ I connect the iPod touch to my Mac mini
2/ in iTunes I go to the iPod then to Photos tab
3/ Sync Photos has "iPhoto" chosen as a source in the drop-down menu
4/ All events, faces, etc.... are properly listed below
5/ I check the first bullet: "sync all photos, albums, and faces

6/ Only one photo (1!!!!!!) out of 1800 pictures is actually selected
The rest are completely ignored
When I try to manually check the Events or Faces, the same result is there - only 1 photo syncs!
7/ So, iTunes can see all my events and faces, but doesn't pull any of the photos
Anyone having the same issue?

iMovie, iWeb can see all my photos via the media browser just fine, but iTunes can see them only listed.

Is this an iTunes issue or iOS issue?
I've also tried my old iPod classic and hit the same problem, so I assume that iOS bug can be ruled out.

Steve Jobs, where are the good old days where your famous " It just works" was not a lie but actual truth? I, a Mac user for past 10 years, am very disappointed.

Message was edited by: Jiri Krecek
Mac mini 2 GHz, 1GB RAM, Mac OS X (10.6.6), Airport Xtreme, Soundsticks, 2TB FW800, Apple TV 2G
  • b noir Level 9 Level 9 (71,990 points)
    That could be caused by a damaged photo cache. If you delete your existing photo cache as per the following document, does your sync start working properly again?

    [iTunes: Photo sync creates iPod Photo Cache folder|http://support.apple.com/kb/TS1314]
    Lenovo t61 laptop, Windows XP Pro, various ipod models
  • masaccio Level 1 Level 1 (0 points)
    It's more complicated that that, I think. I've disabled photo syncing, deleted the cache and then re-enabled photo syncing and iTunes still only syncs a fraction of my library (in my case around 20% of it). I think iOS 4.3 has broken something.
    MacBook Pro, Mac OS X (10.6)
  • masaccio Level 1 Level 1 (0 points)
    I managed to get this working by disabling photo syncing (deletes all photos on the iDevice), re-enabling and manually selecting the albums/projects I wanted to sync (all of them!) and then syncing. I've now re-enabled the default all photos option and it still has all my photos synced. Whether it will automatically update them when I add new ones, only time will tell.
    MacBook Pro, Mac OS X (10.6)
  • b noir Level 9 Level 9 (71,990 points)
    No pictures coume out of iPhoto, not even to Facebook! Iphoto shows that everything is being published, but none of the pictures ever get uploaded to MobileMe, Facebook or sent to iPod.


    Okay ... since it's looking to be a general problem with iPhoto 11 now, I'd check in at the iPhoto 11 forums prior to doing anything drastic. Here's a link to there:

    http://discussions.apple.com/category.jspa?categoryID=282
    Lenovo t61 laptop, Windows XP Pro, various ipod models
  • b noir Level 9 Level 9 (71,990 points)
    iPhoto library was imported form iPhoto 09 and during conversion to the new 11 version, the photose were all ommitted and only thumbnails were converted. So I saw all pictures, but they were only thumbnails of non-existent pictures.


    Ouch! That's nasty.

    Glad you managed to get things fixed, and many thanks for reporting back with your resolution.
    Lenovo t61 laptop, Windows XP Pro, various ipod models
  • Baritech Calculating status...

    Jiri: so I couldn´t undestand how you realy solved the problem, I do have the same problem and I need a solution.

    Please tell me how.

    Thanx

  • dplin Calculating status...

    I had similar problems with the additional symptom of whenever iPhoto launched or I attached an iOS device, a window would pop up saying "The iPhoto library needs to be upgraded to work with this version of iPhoto".

    Screen Shot 2012-04-28 at 10.16.02 AM.png

    I would hit upgrade and iPhoto seemed to work fine, but the problem was that the window would still come up after relaunching iPhoto or attaching any iOS device (iPod Touch, iPad or iPhone).

    This may have started after I upgraded to Lion and migrated all my user accounts from my external backup disk running Snow Leopard.

     

    I finally contacted AppleCare today, who connected me to their special iPhoto team.

     

    I am using an iMac running Lion 10.7.3, with iPhoto '11 (v.9.2.3)

    They recommended a few things to do,(three different customer service people, since the methods took awhile and I had to call back).  I think the last recommendation may have had the greatest effect for the fix. However, I will provide all the steps that AppleCare walked me through.3

     

    First of all, makes sure you have a BACKUP (Time Machine, SuperDuper, Carbon Copy Cloner, etc)

    #1: Rebuild the iPhoto Library

    - Close iPhoto if it is active

    - Hold down the Command+Option keys and Launch iPhoto

    - A window will pop up "Rebuild Photo Library"

    - Check all the boxes except "Rebuild the iPhoto Library Database from automatic backup"

    - Click Rebuild

     

     

    #2: Resetting/Repairing ACLs

    In your User Account (that is giving you the iPhoto/iTunes problem, make sure your have administrator privileges.)

    Open Terminal (the application located in the Applications -> Utilities Folder

    At the command promplt, type: sudo chmod  -R -a "everyone deny delete" ~

    This may take a while

    let that run until you get a new prompt

     

    #3: (By Christine):

    -Shut down the Mac.

    -Power on the Mac and Hold Down Command+R keys until you see the Apple logo and the spinning gear wheel and let go.

    -When you finally get to an active screen, navigate to the Utilities menu

    -Choose Terminal

    - At the prompt, type resetpassword

    IMG_1453.JPG

    - Hit return

    - A window "ResetPassword" will pop up

    - Select the appropriate Volume/hard drive at the top (e.g..Macintosh HD), esp. if you have other external hard drives attached to that Mac.

     

    - Select the correct Account User that is giving you the iPhoto/iTunes problem

     

    - DO NOT type anything in the password fields.

    - Click 'Reset' at the bottom where it says "Reset Home Folder Permissions and ACLs)

    - Once Done, navigate to the Apple Menu and Restart

    - Once your Mac has restarted and you User Account is active, Hold down the Command+Option Keys and Launch iPhoto

    Screen Shot 2012-04-29 at 6.45.50 AM.png

    - Click the Last Checkbox "Examine and repair iPhoto Library file permissions" and click Rebuild

    - When iPhoto launches, launch iTunes and attach an iOS device (Hopefully your problem is fixed)

    Good Luck!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.