3 Replies Latest reply: Mar 27, 2011 6:26 PM by Sammy.
My_Key Level 1 (0 points)
OK - go easy on me - I'm new to Mac's as just purchased my new MacBook and really loving it so far.

The only thing I am having issues with is the App Store. It simply does not work. When I click on the App store icon it brings up the App Store box, with 'Featured - Top Charts - Categories - Updates' and it says:

"One Moment Please.
Connecting to the iTunes Store.

If iTunes doesn't open, click the iTunes application icon in your Dock or Windows Task Bar.
To download iTunes, please click here."

And it just stays there - for half an hour or until I get bored. If I go the menu I can see a login part, I then put in my user/pass and again it just stays there trying to login but not actually doing it.

Has anyone had any similar issues, I can find a few other related issues, but not the same as mine - I am sure as I am just getting to grips with things that I have done something wrong, although a friend of mine told me to re-install it. I can see how to delete the app, but cannot find where to download it again to re-install.

All ideas gratefully received

MacBook Pro, Mac OS X (10.6.6), 2GHz i7 4GB Ram
  • Carolyn Samit Level 10 (102,820 points)

    Yes, you can re install the MAS using the v10.6.6 combo update available at this link.


    Just click the Download button. The file is fairly large so can take at a few minutes to download even with a high speed connection.

    The "Install Mac OS X Update Combined" window should open when the update is downloaded. If not, you should see the update icon (white) on your Desktop. Just double click that then double click the MacOSXUpdCombo 10.6.6 pkg. In the next window click Continue and follow the instructions.

    Restart your Mac. Try the MAS.

    If you continue to have problems, troubleshooting help at this link.



    Message was edited by: Carolyn
  • mparis3 Level 1 (0 points)
    I'm having the same problem as My_Key. I just bought my new MBP (my second Mac) this weekend. I had successfully installed and used the MAS in my old Mac, so I don't understand why it doesn't work in this one. I'll try Carolyn's tips and post back with my result.
  • Sammy. Level 1 (0 points)
    I'm having exactly the same problem although I am now on v10.6.7

    I too have been browsing forums for some advice and we don't seem to be the only people with this problem. It's just a shame because I want to start transferring all my files across and setting this laptop up but I feel as though I shouldn't incase there is a problem here. The only "solution" I found was to delete a couple of files in Preferences which I would rather not do..

    Any advice would be greatly appreciated even if it's just a matter of waiting for another update from Apple, I must get this working! I love apps