4 Replies Latest reply: Mar 22, 2011 3:47 PM by markfmanchester
B4rtj4h Level 1 Level 1 (0 points)
Hello. I recently updated my iPhone 4 (16GB) to 4.3.
I could update without problems (not even the 1013 error!)

But then it started. My Wifi access point is set to "N only" because thats fast and hast the best range. Now on 4.2.1 the Wifi worked fine! Now that i am on 4.3 the Wifi does not work!!

I tried changing the WEP code and even did a full restore from my router. Both did not work.

At the point i was almost gona send back my iPhone i thought: what if the iPhone can not receive Wireless N just in particular anymore ?? So i switched from "N only" to "B/G mixed" and what do you know... Wifi works again!

Is anyone having this problem as well?? Or can anyone simulate it and confirm this is the truth?

Thanks in advance!



Oh and:

For people that get the error 1013.

** Solution: DO NOT USE TinyUmbrella! Just edit your Host file and paste a "#" before the gs.apple.com site**

iMac, Mac OS X (10.6.6), Uh... it's Apple :P Said enough right?
  • luvlabs Level 4 Level 4 (3,610 points)
    I would check with your router builder and see if a firmware upgrade is available for your model. Also, WEP is probably not the safest encryption to use - I would update that to WPA2 unless you have some legacy devices that can only connect that way.
  • B4rtj4h Level 1 Level 1 (0 points)
    I am normally not so fond of these "standard" answers , but here we go:

    Firmware update: It's on the latest firmware. Fortunatly it's every Wireless N router i have and none of them work (not even my Apple Airport is working) So i think this has nothing to do with that

    WEP: i know it's not safe >_>. I am an IT specialist lol... it's just a minimal protection to test my N connection so that not everyone around can surf on my Fiber connection .
  • larrynz Level 1 Level 1 (0 points)
    Hi
    Just thought i would add that i too believe it to be related to the new ios4.3 update, we currently have 4 iphones here (i work in IT too) two of which are 3gs and the other two are iphone 4. Updated one of each model to the new 4.3 and now wifi does not work, well it works albeit extremely slowly to the point that safari believes there not to be a connection there at all. Definitely appears to be linked to Wireless N. We have a netgear router N300, cisco wag160N and also the corporate Cisco WCS AP setup and if they all run Wireless N = fail. If we run mixed b/g or either b or g, it works a treat.

    Just so you know, all the routers have the latest firmware, and yes, they have been fully restarted.

    The two iphones that have not been updated work fine when routers are set to Wireless N

    We are telling people not to update to os4.3 until this is resolved.
  • markfmanchester Level 1 Level 1 (0 points)
    Hi,

    There's extensive discussion about what Apple aren't doing to fix this problem, not even in the ios 4.3.1 update, in my existing thread on this subject, which can be found here:

    http://discussions.apple.com/thread.jspa?threadID=2779454&tstart=0