5 Replies Latest reply: Mar 30, 2011 1:03 PM by nicalai
FM236 Level 1 Level 1 (0 points)
Device: iPhone 4
Carrier: Verizon Wireless
Country / Language: USA/English
OS / Browser / build number (if applicable): Version 4.2.6 (8E200)

I've never needed to post to a forum before because I've always been able to find the answers needed before, but after HOURS (10+ at least) of reading (and re-reading) posts, I haven't found an answer that works and it appears that many of those who seemed to have had similar problems were either human error or fixed by other remedies. I guess it's time for me to start contributing:

The problem:
Just got an iPhone 4 and read the instructions on how to properly set up Gmail using a Microsoft Exchange account so that my contacts, mail, and calendars sync with the phone. See the following website:

http://www.google.com/support/mobile/bin/answer.py?answer=138740&topic=14252

Upon completing the instructions, my contacts, emails, and calendar DID properly sync. Within 24 hours of this correctly working, I began having popups (or whatever they're called in Apple land) saying the following:

"Password Incorrect
Enter the password for the Exchange account '(email account name)'"

After correctly entering the password multiple times (at least 3, but maybe more) I was shown a new popup message:

"Cannot Get Mail
The user name or password for '(email account name)' is incorrect"

It should be noted that at no point since the accounts correctly synced to the iPhone was any password changed. Some unknown number of hours later, I begin receiving push notifications for email from these accounts on the iPhone. (The problem had seemingly fixed itself.) The emails had been sent a great deal of time prior to the notifications and when I checked my email from the phone, neither popup was displayed and I was able to both send and receive emails from the phone.

Fast forward a month later and these events are nearly a daily occurrence and each time it fixes itself sometimes minutes, sometimes hours later. My frustration levels through the roof!

These are some (although I'm sure I've forgotten some) of the things I've read about and tried with no success:

1. Verified user names and passwords - I've checked and double-checked all user names and passwords on both my phone and my computer. All user names and passwords are correct.

2. Re-install account - All accounts have been deleted and installed again (3 separate times) using the instructions found by following the link I posted above. I've also tried variations on the install instructions at the suggestion of others: user name only (instead of "@gmail.com") using "@googlemail.com"

3. Restore phone - Hooked up the phone to my computer and did a full-phone restore back to the way it came out of the box and started again (4th install of accounts)

4. Changed passwords - Possible problem with the strength of my password? (It was suggested, so I tried it)

5. Verified the IMAP was enabled in Gmail. (It is.)

6. Unlocked Captcha - I have done this multiple times both via my computer AND the web browser on the iPhone.
https://www.google.com/accounts/UnlockCaptcha?


There are some random observations I've noticed about this problem. They may not be anything, but maybe it'll make sense to someone else:

1. This problem seems to happen more frequently (although certainly not always) in conjunction with the turning on and off of "Airplane Mode" (I travel a lot).

2. There doesn't seem to be a pattern in the length of time between when the problem starts and when it seemingly corrects itself, nor the time between then and when it starts again.

3. I have 3 Gmail accounts using this phone:
Acct A is set to sync mail and contacts ONLY
Acct B is set to sync mail and calendar ONLY
Acct C is set to sync mail ONLY
I've noticed that Acct C seems to have the problem almost never compared to the other two (which always have the issue at the same time). I've also tried having all three accounts sync all things, but that didn't help either.

If anyone can think of anything else, PLEASE let me know! I know as soon as I click "Post question" I'll think of something else I tried, but I'll update it if I think of something. If Apple and Gmail can't work this out, I'm going to have to pick one because this is unacceptable...

iPhone 4, iOS 4
  • 1. Re: "Password Incorrect" and "Cannot Get Mail" Popups on iPhone 4
    Tonyk23 Level 1 Level 1 (0 points)
    My problem is almost identical to yours, except that I picked the Gmail option instead of the Microsoft Exchange option when setting up my mail on my iPhone 4. I just started having this problem when I upgraded to iOS 4.3. This problem does not occur on my iPod touch 4G, which is running iOS 4.1. I hope this very annoying and unnecessary bug can be fixed soon.
  • 2. Re: "Password Incorrect" and "Cannot Get Mail" Popups on iPhone 4
    sboyne Level 1 Level 1 (0 points)
    I received the same error message this morning and after logging into Gmail through Safari, I got a message saying that 'Gmail has detected suspicious activity on your account' and made me change my password. After doing this, I entered the new password in the Exchange settings and it worked.

    I also noticed that when I went into Gmail there had been a weird message sent out to some of my contacts. So there was indeed some suspicious activity.
  • 3. Re: "Password Incorrect" and "Cannot Get Mail" Popups on iPhone 4
    langpierce Level 1 Level 1 (10 points)
    I have had similar frustrations with email on a Verizon phone. Mail not being able to be sent, password wrong messages etc. I have also spent 10+ hours on three different occasions with a client. I am setting up an imap account that is hosted at godaddy. I have had it working for a few days and then it starts failing sending out messages. We have gone thru every possible setup with ports, ssl off and on and the likes. I have deleted, restarted and done everything short of restore. I have spent hours on the phone with Verizon, GoDaddy and they always just shrug withe comments to the effect that its hit or miss with the iphone.
    After 3 hours again last night doing all the same insanity and about ready to throw in the towel and the phone across the room it started working again. Yeah! I must be brilliant! Happy Client all's good.
    Until this morning when I get a call that it's not working again! UGG
    Then I tell him to restart. Now it's working. I am sure this problem isn't solved.
    I am wondering is there a pram on an iphone? I feel as though the phone is confused and needs any and all memory of all the settings changes that have been attempted. Does it hold on to this info somehow? Would a restore fix this?
    Would love some closure on this issue. I love the iphone I have had one since the beginning and am not experiencing these problems on AT&T is it Verizon? HELP
  • 4. Re: "Password Incorrect" and "Cannot Get Mail" Popups on iPhone 4
    Ladystevo85 Level 1 Level 1 (0 points)
    I'm having the same problem. I have an iPhone 4 and just updated to IOS 4.3 and now my emails won't send and keep getting this error message.
    I have restored my phone, deleted my email accounts, reset them back again and even set up a new account on my laptop and tried setting that up on my iPhone.
    Nothing works!! Please help!! Xx
  • 5. Re: "Password Incorrect" and "Cannot Get Mail" Popups on iPhone 4
    nicalai Level 1 Level 1 (0 points)
    i was having the same problem after receiving another new iphone 4 (my 5th one since october). i finally logged into gmail on my desktop, and a message appeared that 'strange activity' was happening on my account. to verify, i had a text sent to me and voila! no more 'cannot get mail' message! whoohoo...