9 Replies Latest reply: Apr 1, 2011 2:26 AM by upakrik
rastro4 Level 1 Level 1 (0 points)
OK. This is an odd one. For some reason, after I record a new MIDI track, it does not play.
As an example:
I record an "external instrument" MIDI track, it plays back fine.
I later record on the same track, starting right after the previous region ends.
I hear the first region on playback, but not the second.
I can click on the region, and hear the notes when I click on them in the "piano roll" window, but not when the actual track plays back in the song.
Sometimes, muting and unmuting works, sometimes is it doesn't. Sometimes quitting Logic and restarting Logic helps.
Anyway, this is seriously wasting my time. Any ideas?
Thanks,
Joe

Mac Pro Quad-Core 2 x 2.66, Mac OS X (10.6.6), Logic 9.1.3
  • 1. Re: MIDI tracks not playing? Odd bug?
    rastro4 Level 1 Level 1 (0 points)
    To add to the previous post.
    I closed the session and re-opened it.
    I tried "resetting MIDI drivers", and one of the other "external instruments" does not play, and the aforementioned regions are now muted! And, after unmuting them, they still do not play.
    I am using a MOTU MIDI Express XT.

    J
  • 2. Re: MIDI tracks not playing? Odd bug?
    Pancenter Level 5 Level 5 (7,640 points)
    Similar problems have been reported a few times, sounds like a corrupted project.

    pancenter-
  • 3. Re: MIDI tracks not playing? Odd bug?
    therelease Level 1 Level 1 (0 points)
    I'm having this same problem. For some reason the MIDI track just stops playing. I can still play the sounds through my controller, and I can hear the MIDI notes when I select them in piano roll. I tried muting/unmuting, But the MIDI Regions won't play.

    Then, as reported by rastro4, after saving the project, closing and re-opening, the regions are muted and after unmuting they will play again. Stupid bug.
  • 4. Re: MIDI tracks not playing? Odd bug?
    Dr_Jezz Level 1 Level 1 (55 points)
    Yeah, really common, really annoying bug. IIRC best workaround was from Eriksimon - _revert to saved_ ... since I instinctively press cmd S every 30 seconds, this works best for me. I've tried setting up new templates to avoid any possible corruption therein, but it has never worked for me. No one has ever got to the root of it. I hate it. I 'think' it's worse with take folders, but I might be wrong ...
  • 5. Re: MIDI tracks not playing? Odd bug?
    rastro4 Level 1 Level 1 (0 points)
    Glad to see that I'm not alone--thought I was going batty. I ended up using the "revert to saved" workaround as well. Very annoying. Hope it gets fixed.
  • 6. Re: MIDI tracks not playing? Odd bug?
    the-design-guy2 Level 1 Level 1 (20 points)
    This error is really annoying. I've reported it several times over the last two years. I would consider it a MAJOR BUG, but it hasn't been fixed yet, so I'm not counting on any fixes soon. My workaround is to dup the MIDI track and then drag all the regions down to the new track. Then they will play for another take or two. Don't know if the Revert to Saved is faster or not. I'll give it try. I'm just flabbergasted with how ungainly it is to work with MIDI in Logic, at least as compared with Digital Performer.
  • 7. Re: MIDI tracks not playing? Odd bug?
    the-design-guy2 Level 1 Level 1 (20 points)
    I think I just had a breakthrough. I realized that a lot of times when I'm recording MIDI takes, I'll screw up about 3 notes in (my keyboard skills need help) and rather have the take clutter up my takes folder, I just hit undo and then start another take. I was just able to record 15 takes in a row and the MIDI region still played. That was a new record for me. I then recorded one take, hit undo, and the MIDI region would NOT play any more (until I duped it and dragged all the regions in it to the new duped track—which I've found IS way faster than Revert to Saved).

    So my advice, when you're recording MIDI tracks, DON'T use the UNDO command, just keep recording new takes. Of course all these takes wouldn't be necessary if you could comp MIDI tracks like audio tracks, but that's another story.

    NOTE TO APPLE: Please take a look at how the Undo operation effects the MIDI regions. There's a bug there.
  • 8. Re: MIDI tracks not playing? Odd bug?
    Dr_Jezz Level 1 Level 1 (55 points)
    Interesting ... I'l take a look at that.
  • 9. Re: MIDI tracks not playing? Odd bug?
    upakrik Level 2 Level 2 (170 points)
    try sliding the segment to another midi track...that has worked for me when it stopped playing.

    rick