Previous 1 2 3 4 5 Next 64 Replies Latest reply: Nov 10, 2015 10:23 AM by jwalta Go to original post
  • amirbahrami Level 1 (0 points)

    That was genius, relieved me from couple of months of pure torcher!

  • MattW214 Level 1 (0 points)

    Dam0 - This was almost exactly my issue so thanks for posting your solution. My company has two very similar domains (company-name.com and companyname.com). I removed the hyphen from my email address in the mail account preferences and viola - that stopped from reply all including me. Thanks Dam0!

  • rojocaweb Level 1 (0 points)

    If you are using exchange and don't have Outlook you may find that the email address field in Preferences > Accounts > Account Information is disabled so you cannot add additional email addresses. You can still fix this issue in Mavericks by editing ~/Library/Mail/V2/MailData/Accounts.plist searching for the following line:

     

    <key>EmailAddresses</key>
    <array>
         <string>default.email.address@example.com</string>
    </array>
    
    

     

    And then adding in the address that people are actually sending email too:

     

    <key>EmailAddresses</key>
    <array>
         <string>default.email.address@example.com</string>
         <string>another.email.address@example.com</string>
    </array>
    
    

     

    Then restart Mail. If you go to Preferences > Accounts > Account Information you should now see

     

    default.email.address@example.com, another.email.address@example.com
    


    in the Email Address field.

  • Renaissance_man Level 1 (0 points)

    This solved it for me! Obvious after the fact, maybe. Thanks!

  • gssherman Level 1 (0 points)

    I see the same problem being CC'd but in our case, we have Exchange 2010 with multiple alias's. If I set the address to the correct email address, after a few days it reverts back to one of the other alias address's. Is anyone else seeing this behavior? I can even force it to happen by logging into Outlook Web Access, going to options, pulling up the phone and deleting the device. The next time the phone tries to contact the Exchange server, it picks up the wrong address and populates it in the email address field under settings.

  • FranklyPhoney Level 1 (15 points)

    found this answer for Exchange users, not sure about others.  So far, it seems to be working.

     

    http://guideguy.tumblr.com/post/40173926366/fixed-mac-mail-includes-me-whenever- i-reply-to

  • gco13 Level 1 (0 points)

    Thank you! That worked. I have an alias to my real Exchange email address. Updating my name in preferences/accounts did the trick.

  • andas78 Level 1 (0 points)

    I had the problem with MacOS 10.10.3 and mail.app and running an exchange account. I tried everything changing the adress card to this is me and so on, nothing helped.

     

    Finally, when i was looking through my exchange settings i found the problem. We get usernames based on our names eg person John Doe gets johdo. This we use as user names on the servers. Our email address is still john.doe@xxxx.xx though. So all mail i receive is to john.doe@xxxx.xx, but in mail preferences my email was listed as johdo@xxx.xx (which is also valid), when I changed this reply all started to work.

  • akhileshmohan Level 1 (0 points)

    Thank you. Your solution helped. My company moved from having '_' to '.' in the email address recently and I had not changed this in the account email address until today.

  • Angela Oliver Level 1 (0 points)

    Thank you so much!

  • Poste Restante Level 1 (0 points)

    Works perfectly on Yosemite. Thanks, man.

  • boxtology Level 1 (0 points)

    rojocaweb wrote:

     

    If you are using exchange and don't have Outlook you may find that the email address field in Preferences > Accounts > Account Information is disabled so you cannot add additional email addresses. You can still fix this issue in Mavericks by editing ~/Library/Mail/V2/MailData/Accounts.plist searching for the following line:

     

    1. <key>EmailAddresses</key> 
    2. <array> 
    3.      <string>default.email.address@example.com</string> 
    4. </array> 

     

    And then adding in the address that people are actually sending email too:

     

    1. <key>EmailAddresses</key> 
    2. <array> 
    3.      <string>default.email.address@example.com</string> 
    4.      <string>another.email.address@example.com</string> 
    5. </array> 

     

    Then restart Mail. If you go to Preferences > Accounts > Account Information you should now see

     


    in the Email Address field.

    I was unable to edit my address field in the preferences section, and this worked for me. No more CC'ing to myself!

  • CCAPPL Level 1 (0 points)

    I am also having this issue but I'm NOT using REPLY ALL, just REPLY. I have GMAIL (IMAP) coming into MAC MAIL and every email I reply to comes back to my inbox as an email to me as well! It's like doing double duty to delete them all! SO ANNOYING! Please help! I've tried everything and nothing works.

     

    Additionally, none (or very little) of my spam from gmail is coming into my mac mail--I often need to have my spam delivered so I can sort through it. I have the JUNK settings in MAC MAIL turned OFF and I have the Settings in GMAIL turned on to allow the SPAM folder to show up--it doesn't show up in the list BTW - ONLY as the JUNK folder in MAC MAIL. Why is it all so glitchy! Thanks all!

  • Pingu the Penguin Level 1 (0 points)

    Your solution worked for me in Yosemite, but no longer works in El Capitan.