Skip navigation

Facebook won't load on my Mac

16661 Views 6 Replies Latest reply: Nov 12, 2013 11:27 AM by PDH Enterprises RSS
SDirani Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 17, 2011 9:46 PM
I just got my Mac a few months ago, and I never had a problem loading any page. For the past few days Facebook won't open. I Googled many solutions, none of which worked. I restarted multiple times, updated software, deleted cookies, emptied cache, tried Facebook on Firefox, installed the newest Flash, but it won't load anywhere. Every other page loads except Facebook. Please help.
Mac OS X (10.6.6)
  • Carolyn Samit Level 10 Level 10 (84,500 points)
    Currently Being Moderated
    Mar 18, 2011 12:49 AM (in response to SDirani)
    Hi,

    updated software


    Facebook requires the latest version of Safari which is 5.0.4. Make certain your software is up to date just in case.




    From your Safari menu bar click Safari / About Safari. If the version number is not 5.0.4, click your Apple menu (top left in the menu bar) then click Software Update.

    If you have 5.0.4 installed, from the menu bar click Safari / Preferences - then select the Extensions tab. If you have any installed, turn that off, then restart Safari, try Facebook.

    And again in Safari / Preferences select the Security tab. Make sure the box next to: Java is selected. Then click: Show Cookies. Delete all Facebook cookies. Restart Safari, try Facebook.







    Carolyn
    27" iMac 3.2GHz i3 MBAir iPad iPhone 4 iLife iWork / AirPlay ATV2 AiportExtr, Mac OS X (10.6.6), QTPro Intuos Epson Olympus Airport JBL
  • kgagnon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2011 8:39 PM (in response to SDirani)
    I've been having these same problems for days now. I believe it started since facebook has been doing some changes to the layout of the site. It came back for a while one day then lost it again. Sometimes it will load a little bit but take so long that it displays with errors or doesn't display at all. If I open up citrix to work on my college network in internet explorer it opens facebook fine, so it can't be my modem or internet causing the problem. I've tried safari and firefox both can't open facebook right now. I've tried all the instructions suggested online nothing has worked yet.
    Macbook, Mac OS X (10.5.3)
  • kels1386 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2011 9:31 PM (in response to SDirani)
    I too have been having this problem for a few days now... I guess since I installed the update... I've tried all the suggestions everyone else has posted, but it still doesn't work! I can open some websites, but not facebook or yahoo. I finally have downloaded Chrome and it is working. Even firefox wouldn't work for me! I don't know what the deal is!
    MacBook, Mac OS X (10.5.8)
  • neelam18 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2012 2:36 AM (in response to SDirani)

    SAme problem...what to do...has anybody found any solution ?

  • PDH Enterprises Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2013 11:27 AM (in response to SDirani)

      Disabling "Stealth Mode" in your firewall settings fixed my issue. 

     

      Apple menu (top left corner- Its an apple) - System Preferences - Security and Privacy - Firewall button - Firewall Options - Uncheck "Enable Stealth Mode"

     

     

    Peace in the Middle East...and I don't mean Pittsburgh!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.