Previous 1 2 3 4 Next 50 Replies Latest reply: Nov 15, 2013 9:39 AM by David Neale1
atomicluck1 Level 1 Level 1 (30 points)
Is there any way to set the mail app for 'British English' instead of American English?

I have my dictionary set for British English, System Preferences>Language & Text>Input Sources>British.

Every thing operates with British English but, I still cannot get the mail app to use British/Aussie English.

MacBookPro & MacBookAir, Mac OS X (10.6.4), MBP 2.26GHz, 4GB Ram, 500GB HD + MBAir 2.13GHz, 4GB Ram, 256GB SSD
  • atomicluck1 Level 1 Level 1 (30 points)
    Actually I just noticed that it's doing the same thing with Discussions. Type in the British spelling and I get flagged that the word is spelled wrong ...
  • Tom Gewecke Level 9 Level 9 (75,060 points)
    System Preferences>Language & Text>Input Sources>British.


    Input Sources are not relevant to spell check, just keyboard layout. You need to put British English at the top of the list in system prefs/language & text/language (use the Edit button to add it if necessary), and perhaps also make sure it is set in system prefs/language & text/text/spelling.

    Finally check Mail > Edit > Spelling and Grammar > Show Spelling and Grammar to see what dictionary is being used.
  • atomicluck1 Level 1 Level 1 (30 points)
    System Preferences>Language & Text>Input Sources. I know that's only for the keyboard, but the other did not work either, not completely.

    System Preferences>Language & Text>Language. I hit the edit list and checked the British English then restarted to no effect. British English is at the top of the list, but on the right side bottom where it says 'Order for sorted lists. Only English is there nothing else and no way to edit or click within that box.

    As for Mail>Edit>Spelling and Grammar>Automatic by Language>British English. That works, but only for that one specific e-mail. You have to go back over and over and over for each e-mail you send, it doesn't stick.

    In the Dictionary app you can click it for British English and it stays unless you change it to US English.

    Frustrating .... there has to be a way to get things to understand I need British English on everything. Grrrrr.
  • Tom Gewecke Level 9 Level 9 (75,060 points)
    'Order for sorted lists. Only English is there nothing else and no way to edit or click within that box.


    That setting is not relevant for spell check.

    How about system prefs/languge & text/text/spelling? Don't leave it on automatic, make sure it says British English.

    As for Mail>Edit>Spelling and Grammar>Show Spelling and Grammar


    Make sure it says British English, not Automatic.

    In the Dictionary app you can click it for British English and it stays unless you change it to US English.


    Dictionary app has no connection with spell checking.

    By the way, if you are not on 10.6.6, you may need to upgrade. I think there may have been a spellcheck bug with British English in some earlier versions.
  • atomicluck1 Level 1 Level 1 (30 points)
    Tom,

    system preferences>language & text>text>Spelling>British English. That worked for the mail app to accept the British spelling, but not in Safari.

    When I sit an type in the window I'm using now ... it still wants US English not British English. Any way around that?

    As for updates. I check for updates daily so if there was a change it would have been there already.
  • Tom Gewecke Level 9 Level 9 (75,060 points)
    When I sit an type in the window I'm using now ... it still wants US English not British English. Any way around that?


    When you go to Safari > Edit > Spelling and Grammar > Show Spelling and Grammar, does it say British English? If not, make it so.

    As for updates. I check for updates daily so if there was a change it would have been there already.


    The reason I asked is that your profile that appears at the bottom of your messages says you are 2 updates behind.
  • atomicluck1 Level 1 Level 1 (30 points)
    The format you're talking about for Safari and British English isn't permanent. You continually have to go up and change it.

    Trying to get the profile to show things right.
  • atomicluck1 Level 1 Level 1 (30 points)
    Tom,

    What I'm trying to do is get mail, Safari ... you name it set to British English so that I don't have keep continually changing it over and over. You would think there was a way to set the system to default to British English without the need to go in and make a change to each and every app.

    Or is that asking to much?

    Mike
  • Tom Gewecke Level 9 Level 9 (75,060 points)
    You would think there was a way to set the system to default to British English without the need to go in and make a change to each and every app.


    Yes, that is supposed to happen (for apps that use Apple's spellcheck) when you put British English at the top of the list in system prefs/language & text/language and in text/spelling. I don't have your problems with the dictionary switching in Safari or other Apple apps. If you have been updating the OS incrementally, I would suggest perhaps downloading and running the combo update for 10.6.6. That sometimes fixes buggy behavior which may arise in some systems when updating only one step at a time.
  • atomicluck1 Level 1 Level 1 (30 points)
    Tom,

    I'll try, but so far nothing is changing ... maybe a call to AppleCare?

    Just gets frustrating that both the MBP & MBA keep telling me I'm nuts because of the way I spell.
  • David Neale1 Level 1 Level 1 (70 points)

    I understand your frustration on this point, atomicluck1. I have the same problem. I write in several languages, none of which is US English, but one of which most certainly is British English. I am constantly having to return to the various settings to get MacOS X to understand that I do not wish to use US English spelling conventions and would really appreciate a simple way of eliminating US English and specifying a preference for British English on a system-wide basis.

  • Tom Gewecke Level 9 Level 9 (75,060 points)

    David Neale1 wrote:

     

    would really appreciate a simple way of eliminating US English and specifying a preference for British English on a system-wide basis.

    Apple has designed the OS so that your spell check is supposed to be determined by what language is at the top in system prefs/language & text/language.  It does work for a lot of people, including me.  I don't know why it fails for others.  You can let Apple know here:

     

    http://www.apple.com/feedback/macosx.html

  • Shoogles Level 1 Level 1 (0 points)

    I'm having a very similar problem.  I've gone through the various steps suggested here, and it seems to make no difference.  Let me be more precise:

     

    System preferences>Language & Text>Language now has 'British English' at the top of the list.

    System preferences>Language & Text>Text now has 'British English' in the Spelling frame.

    Mail>edit>Spelling & Grammar>Show Spelling & Grammar> shows 'British English' as the language option.

     

    I've closed and re-opened Mail and it seems to remember British English. 

     

    All of this seems fine, but for the fact that it still puts red dotted lines under 'behaviour' and 'colour'.  The spell checker reports 'This word was not found in the spelling dictionary'.  The checker seems happy with 'color'.

     

    Where to now?

  • Tom Gewecke Level 9 Level 9 (75,060 points)

    Is your OS completely updated -- 10.6.8?  If not, what is it?

Previous 1 2 3 4 Next