2 Replies Latest reply: Dec 14, 2012 12:15 PM by Larry Nolan
hansm Level 1 (0 points)
The QNAP NAS in my network is set for connection through Microsoft networking (SAMBA) and through Bonjour (via AFP).

My Mac connects automatically via the SAMBA connection as myself as user. But in the connection log of the NAS I also see repeated SAMBA-logins as guest under the Computer Name (as given in System Preferences). I would like to get rid of these 'spontaneous' guest logins.

Enabling the Bonjour advertising for AFP in the NAS also prompts the Mac to login as guest through AFP. Although using Go>Connect to Server from the Finder enables me to login as myself through AFP, it is continuously interrupted by a logout obviously forced by a new guest AFP-login.
Where do all these guest logins come from? (I do not have an alias to the NAS in my Login Options)
How can I prevent this series of login-logout's?
I would be obliged to see an explanation for this behaviour.

MacPro hexacore, Mac OS X (10.6.6), MacBook Pro 13in
  • hansm Level 1 (0 points)
    It looks like I have found a solution through the QNAP users forum. I am posting it here in the hope this might be of use to other QNAP-NAS users reading this forum.
    In the Administration panel of the NAS look for the Microsoft Networking > Advanced Options. There one finds a checkbox Local Master Browser. Switch this checkbox OFF. You might need to upgrade the firmware of the NAS to the latest 3.4.x version to see this option. In my experience doing this does not prevent other units on the network to access the NAS by smb, but it seems to avoid the continuous logins from the Mac as guest. The Mac is conveniently connected to the NAS by selecting afp in the Bonjour settings.
  • Larry Nolan Level 2 (175 points)

    Glad I found your solution.  I was having same problem on a QNAP NAS running 3.7.3 and a Mac connecting over the LAN through SAMBA.  Turned off the Microsoft Networking Master Browser Advanced Option and the flood of 'guest' logins every three minutes stopped.


    Wonder if there is a way on OS X to have prevented the problem?


    Anyway, thanks very much for posting your solution for me to find it over  a year later.