5 Replies Latest reply: Apr 10, 2011 6:31 PM by cymrusteve
Setu Garg Level 1 Level 1 (0 points)
I am facing a weird issue with FaceTime for Mac.

FaceTime works perfectly on my iPhone 4. However, when I try to make a FaceTime call from my Mac (on my MB Air late 2010 13''), which is in the same WiFi network as my iPhone 4, it says "Connecting..." for a long time and then says "Facetime Failed". This means this is not an issue with my wifi router, otherwise, it wouldn't have worked on my iPhone 4.

Oddly enough, when I use FaceTime on my Mac using the personal hotspot feature by sharing my iPhone's 3G data connection over WiFi and connecting my MB Air to that WiFi, it works seamlessly. It also works using a 3G USB data card. This means this is not an issue with my MB Air.

Even strangely, when I try to call my iPhone 4 from my Mac or vice versa within the same WiFi network, it works seamlessly!

I have tried forwarding the ports mentioned in Apple's kb article (although I shouldn't need to as my wifi router - Belkin N150, supports UPnP), copying the FaceTime.app's LaunchAgents to /Library/LaunchAgents, changing the DNS to Google's DNS and also exposing my Mac directly on the internet using DMZ settings in my wifi router. Nothing seems to fix the problem.

Any idea what the problem might be? And how to fix it.

Macbook Air late 2010, Mac OS X (10.6.6)