11 Replies Latest reply: Apr 3, 2011 6:01 AM by jlm70
Josiah Lowe Level 1 Level 1 (0 points)
When I go to restore from backup my old iPad backup is not in the list of available backups. All my apps and things are there in iTunes but I can't restore from my old iPad backup...

iPad 2, iOS 4
  • Demo Level 10 Level 10 (82,425 points)
    Try rebooting your computer and your iPad. then try to restore again. Maybe you deleted the back up accidentally. The crosscheck is to open iTunes on you computer, select preferences, then select devices and see if the back up shows up there.
  • Josiah Lowe Level 1 Level 1 (0 points)
    Thanks for the quick response.

    The backup of my old iPad is showing up in preferences. I rebooted my computer and my iPad but the backup is still not showing when I try to restore from backup.
  • Demo Level 10 Level 10 (82,425 points)
    Are you running the most recent versions of iTunes on your computer and iOS 4.3 on the iPad? I assume ipad2 comes with 4.3 but I'm using the original iPad.

    You could try uninstalling and reinstalling the latest version of iTunes and see if that helps.

    Message was edited by: Demo
  • stephenmagown Level 1 Level 1 (0 points)
    Same problem here.
  • Josiah Lowe Level 1 Level 1 (0 points)
    I wasn't running the latest version of iTunes. After I updated, it worked!

    Thanks a bunch!
  • Demo Level 10 Level 10 (82,425 points)
    Excellent. Glad to finally get it resolved.
  • jlm70 Level 1 Level 1 (0 points)
    I'm trying to backup my iPad1 (64/3G) and restore it to a new iPad2 (64/3G).
    On my "1" I've about 9GB of photos/music and 35GB of applications (a lot). Among the many apps, I've even some 'business' apps not downloaded from the AppStore, but as custom/developer installs.

    When I backup the iPad1, it works flawlessy (except from the long time... and I correctly tick the "sync apps"), but when I try restoring to the new iPad2 I only get the 9GB of photos, the wallpaper, but NOT a single of the old apps has been restored.
    Already tried 3 times, same results.
    First two times were done with both devices with fw 4.3, latest one with 4.3 on ipad1 and 4.3.1 on ipad2. iTunes is the last version.
    Any ideas?
  • jlm70 Level 1 Level 1 (0 points)
    Update: before the 4th try... I rebooted XP and - finally - didn't work again, but something different happened: iTunes told me (115 warnings... all my apps) that the "XYZ app was not installed on the iPad because the app could not be found".

    This seems strange to me 'cos I've in my PC the folder with all the apps backed up yesterday from my iPad1 (the app timestamp on the PC is correctly the same of the backup, it's not anything old - except from the oldest apps). As an unique note... I've changed (time ago) the standard iTunes backup folder from my PC to the home NAS ('cos I've even an iPhone and cannot manage to have 60GB of my laptop HDD lost in backups...).
  • Demo Level 10 Level 10 (82,425 points)
    Did you try rebooting both the iPad as well. If not try that before you try anything else.

    Message was edited by: Demo
  • hurrahburrah Level 1 Level 1 (0 points)
    i'm having the same problem: I cannot get my iBooks and apps to download to the iPad2. i reset the iPad and then selected 'set up as a new iPad' and I got my apps, but only half of my books will download and then it stops the sync and gives me 'unknown error message -23'
  • jlm70 Level 1 Level 1 (0 points)
    Maybe I've understood: some time ago, before moving the "iTunes Media Folder location" from C: to my home NAS, I manually deleted (to save space from my C drive that was FULL) some apps (.ipa files) from the iTunes "Mobile Applications" folder, thinking that iTunes would have backed them up again on the new NAS folder.
    Instead... it seems that iTunes doesn't check the .ipa files stored in the new NAS folder and think that the old .ipa are still present in the old C drive, therefore not backing them up again in the new folder.
    As I've manually deleted the "Mobile Applications" folder on my C drive, probably iTunes thinks this folder is still in place and doesn't backup the oldest apps that were stored only there and not in the new one.

    --> Does anybody know how to force iTunes backup again ALL the apps from scratch?
    (obviously I've deleted the old backups, but deleting the old backups does not delete, nor touch the ipa files)