1 Reply Latest reply: Mar 22, 2011 4:01 AM by Bengt Wärleby
Paul Barrett Level 1 Level 1 (25 points)
Suddenly, iMovie stopped displaying any clips, projects, events. It won't import from any device or library. The projects and clips are still on the hard drive but won't display in iMovie. Very frustrating!! Any ideas for a solution, folks?

iMac G5, Mac OS X (10.5), Model Identifier: PowerMac8,1
  • Bengt Wärleby Level 6 Level 6 (19,460 points)
    Hi

    Hopefully You've not moved or altered anything in any folder named
    • iMovie Projects - or -
    • iMovie Events

    If so - iMovie get's confused and situation is hard to sometimes ir-reparably.

    Else

    *Not knowing the origin to Your problem - General approach when in trouble is as follows.*

    • Free space on internal (start-up) hard disk if it is less than 10Gb should rather have 25Gb

    • Delete iMovie pref file

    iMovie pref file resides.
    Mac Hard Disk (start-up HD)/Users/"Your account"/Library/Preferences

    and is named. (one or more of these)
    com.apple.iMovie.plist
    com.apple.iMovie3.plist
    com.apple.iMovie7.plist
    com.apple.iMovie8.plist
    com.apple.iMovie9.plist

    and find
    com.apple.iApps.plist

    While iMovie is NOT RUNNING - move this/these file/s out on to desk-top.
    Now restart iMovie.

    • Hard disk is untidy. Repair Permissions, Repair Hard disk (Apple’s Disk Utilities application)
    • Garageband-fix. Start it, Play a note and Close it. Re-try (Corrects an audio problem that hinders iMovie)
    • Screen must be set to Million-colors
    • Turn off Mac and disconnect Mains/Power for 20-30 minutes - will at least re-set FW-port
    • Third party plug-ins that doesn't work OK (not relevant for iMovie’08 or 09 or 11)
    • Problems in iPhoto Library can affect iMovie to crash on start-up. Re-build this first then try to re-start iMovie.
    This You do by
    _ close iPhoto
    _ on start up of iPhoto - Keep {cmd and alt-keys down}
    _ now select all five options presented
    _ WAIT a long long time

    • iMovie updated ?
    • QuickTime updated ?
    • Mac OS version ?

    • Program miss-match. iMovie 4 - will not work under Leopard
    • Program miss-match. iMovie 5.0.2, up to Mac OS X.4.11 AND QuickTime 7.4.1 - is OK
    • Program miss-match. iMovie 6.0.3 or 6.0.4, Mac OS X.4.11 AND QuickTime 7.4.1 - is OK (will work under Leopard and Snow-Leopard)
    • Program miss-match. iMovie’08 v. 7.1.4, Mac OS X.4.11 AND QuickTime 7.5.5 - is OK (will work under Leopard and Snow-Leopard)
    • Program miss-match. iMovie’09 v. 8.0.6, Mac OS X.5.8 AND QuickTime 7.6.4 - is OK (will work under Leopard and Snow-Leopard)

    From LKN 1935. (in this case = iMovie HD (5), I tried it all, but nothing worked.
    Your answer (above) has been helpfull insofar as all the different trials led to the conclusion that
    there was something wrong with my iMovie software. I therefore threw everything away and reinstalled
    iMovie from the HD. After that the exportation of DV videos (there has not been any problem with HDV videos)
    to my Sony camcorders worked properly as it did before.

    Lennart Thelander
    I run "Cache Out X", clear out all caches and restarts the Mac.

    Yours Bengt W