6 Replies Latest reply: Jan 2, 2012 5:36 PM by jcspencer01
rojac Level 1 (0 points)
I upgraded to the new MacBook Pro and although my old computer (MacBook Pro late 2008) had no problems connecting to my company's VPN, the new computer would not. After several weeks of trying to sort this out, I finally figured out how to solve the problem.

The early 2011 MacBook Pros boot by default into 64-bit mode, which is not compatible with Network Connect v6.x. Rebooting the computer and holding down the 3 and 2 keys while starting up puts the computer into 32-bit mode and now Network Connect works as it did before. This condition may also affect other software.

MacBook Pro (early 2011), Mac OS X (10.6.7)
  • sbcwayout Level 1 (0 points)

    I have tried holding down the 2 and 3 keys while booting up. I don't see any changes or anything out of the normal. I launched my Juniper Network Connect version 6.4.0 and my MacBookPro is 2.66 i7, running 10.6.7. I still can't make this work. Any more tips? or did I miss a step somewhere?

  • koskyr Level 1 (0 points)
    Thank you very much!!!!!!! This worked for me. I've been using Juniper Network Connect 6.2.0 to connect back to my corporate network. It used to work (still is) on my older MBP early 2008. Few days ago I bought a new MBP (early 2011) and no matter what I did it refused to establish the secure tunnel back to the gateway. By starting the kernal on 32bit mode by holding the 2 and 3 keys down together during boot up made it work!

    You can verify that the kernal is working on the 32bit mode easily from the Activity program.

    Thank you rojac
  • c0rey Level 1 (0 points)
    I wrote a little AppleScript app that makes Network Connect compatible with Snow Leopard (though it doesn't solve the 64-bit kernel issue, you still need to boot the 32-bit kernel). It currently works with 6.3 and 6.4.

    EDIT: Since it doesn't look like I can attach it here, and I don't currently have time to rewrite the parts that are specific to my environment, I'll just give you the terminal commands to run:

    sudo chmod 755 /usr/local/juniper/nc/6.4.0/
    sudo chmod 4711 /usr/local/juniper/nc/6.4.0/ncproxyd
    sudo mkdir '/Applications/Network Connect.app/Contents/Frameworks

    Note: this assumes Network Connect.app is at least installed. If your VPN portal is configured to install NC for you but your browser isn't installing it properly, open /Utilities/Java Preferences.app and make sure TLS v1.0 is enabled on the advanced tab, make sure Java is enabled in your browser, then run this:

    sudo keytool -storepasswd -new changeit -keystore /System/Library/Frameworks/JavaVM.framework/Resources/Deploy.bundle/Contents/Ho me/lib/security/cacerts -storepass changeme

    Then clear your browser cache and log in again. The client should install but if you're running Snow Leopard it will say it "Failed to establish secure connection" or something similar. If you're getting that far, the first three sudo commands above should get things working for you.

    Message was edited by: c0rey

    Message was edited by: c0rey
  • c0rey Level 1 (0 points)
    Oh, also, if anyone is running NC often enough that they don't want to reboot and hold the 3 and 2 keys every time, here's how to make the 32-bit kernel boot permanently by default:

    sudo systemsetup -setkernelbootarchitecture i386

    You shouldn't notice much performance difference doing this since your 64-bit apps will all still run in 64-bit mode.

    See http://support.apple.com/kb/HT3773 for more info.
  • viet360i Level 1 (0 points)
    I've had to resort to this "hold 3 and 2" fix for the last few weeks everytime I needed to use Network Connect. I couldn't set my Macbook to automatically boot in 32 bit mode as for certain reasons I wanted it to be running 64-bit whenever possible.

    However, my company has just upgraded from version 6.2 of NC to 7.0 and now I can connect using 64-bit no problems whatsoever.
  • jcspencer01 Level 1 (0 points)

    i am still not able to do this.. is anyone esle having problems still?