Previous 1 2 3 4 Next 48 Replies Latest reply: Feb 28, 2014 7:49 PM by MacKlas
tjware Level 1 Level 1 (0 points)
Anyone else having issues with NFS mounts after the 10.6.7 update?

I have three mounts /Volumes/media/music, /Volumes/media/video, and /Volumes/media/photos. all coming from a Synology NAS. Before the update, I had no issues, but now I don't seem to have write permissions. I can't create new folders or copy files to existing folders. If I do a "Get Info" on any of the files/folders there it says: "You have custom access", and the Finder window has the pencil with the line trough it on the bottom of the frame.

The even weirder thing is, if I go to a terminal window, I have full permissions to do anything I want.
I've tried remounting and different options, but same result.

I saw in the release notes something about Trash and NFS home directories, but that's not really what I'm doing.

Anyone?

iMac 27" i7 - Late 2009, Mac OS X (10.6.7), NFS
  • Zortrium Level 1 Level 1 (0 points)
    I'm having this issue too. NFS access screwed up after 10.6.7 update. The permissions themselves are still fine, and I have full permissions through Terminal, but Finder thinks I have no write permissions to the volume. Interestingly, I can successfully save a new text file to the volume with TextEdit, but then I cannot delete it through the Finder, since it tells me I have no permissions. Looks like a bug.
  • tjware Level 1 Level 1 (0 points)
    Ahhhh.
    Ok, after some fooling around with this last night. I got NFS to work properly again.
    I had shortcuts/aliases in the Finder sidebar for these mounts. I removed them, unmounted the volumes, then remounted them (and took the opportunity to play around with mounting options).
    In the end, I got Finder to properly see the NFS volumes with the proper permissions. I have not tried to re-add to the sidebar, but I did create aliases to the desktop.

    Final determination, the update messed up my Finder sidebar links to the NFS mounts and made them appear Read-Only.
  • Zortrium Level 1 Level 1 (0 points)
    What I did to fix it was unmount the NFS volume, then delete the NFS mount configuration entirely from within Disk Utility, then reboot, then recreate the NFS mount in Disk Utility. It then mounted with the correct permissions. I didn't have to change any mount parameters or NFS parameters serverside and just used the same mount parameters as before (-i -s in my case).
  • AbMagFab Level 1 Level 1 (0 points)
    I'm having this problem as well. FWIW, they are R/W from terminal, but RO from Finder. Really annoying!

    When you umount/mount -a, this works until you reboot. It creates new desktop aliases temporarily, but they all go away on a reboot.

    I have tried deleting/adding again in DiskUtil, and this only works until a reboot.

    Has anyone permanently fixed this?
  • danmcdatkebe Level 1 Level 1 (0 points)
    This also fails with autofs. I use symlinks in my ~/Desktop directory to access my home NFS server. I'm seeing the same read-only-in-the-Finder problem. As mentioned earlier, these problems don't exist when using the shell. I think it's just in the Finder, because things still work if I access the NFS server via a save-file dialog (I printed-to-PDF to the NFS server just fine).

    This is definitely a bug, and I'll be glad to test a fix if someone needs a guinea pig.

    Message was edited by: danmcdatkebe
  • kavehv Level 1 Level 1 (15 points)
    I'm also experiencing this issue....it's quite annoying!
  • -Michael- Level 1 Level 1 (0 points)
    I've tried a number of variations on the delete the old mount stuff from Disk Utility, reboot, recreate. It seems like 1 in 5 times, this works. But as soon as I reboot again, Finder (under 10.6.7) can no longer do write operations to the NFS mount point. Access via Terminal works in all circumstances.

    This is definitely a bug in Finder. The only option I'm seeing is to keep my machines at 10.6.6 until this is fixed.

    Message was edited by: -Michael-
  • lex483 Level 1 Level 1 (0 points)
    Hello,
    i can't connect to a smb share at all. In Finder it sees the share, it says it is connected but when i click it it says it can't connect because " an original part of "the share" is missing.?????????
    I'm not that familiar with unmounting and mounting. I'm sure the error is Finder related and 10.6.7 related. Two Win 7 machines can connect to the share without a problem.

    hope someone can help.

    greetz Lex.
  • AbMagFab Level 1 Level 1 (0 points)
    I finally just installed Path Finder, which is a third party finder tool. It works fine, except I can't copy/paste from iPhone - I need to drag/drop instead. I installed the trial version which I think lasts for a month - hoping that Apple fixes this before I have to buy it!

    Clearly a 10.6.7 Finder bug.
  • -kendall- Level 1 Level 1 (0 points)
    Same problem for me after the 10.6.7 update. Can write to NFS shares from terminal but Finder thinks they are read-only.

    I mount my NFS volumes using autofs with entries like this in /etc/fstab:
    myserver:/data ignored nfs net,-P,async 0 0

    To the folks that say the problem is solved...does Finder still work after a reboot or do you have to delete and recreate the NFS mount each time?
  • kavehv Level 1 Level 1 (15 points)
    I don't believe anyone's said this problem is solved, rather Apple needs to fix the bug in Finder before we can consider it solved.

    Has anyone filed a bug at bugreport.apple.com for this?

    Message was edited by: kavehv
  • -kendall- Level 1 Level 1 (0 points)
    I agree with that kavehv, but am confused in that the topic is considered answered/solved. From the top of the topic page:

    "This question is answered. "Helpful" answers available: 2 . "Solved" answers available: 1"
  • CubeSys Level 1 Level 1 (0 points)
    Just a note to confirm the problem, already submitted to bugreport.apple.com.

    Funny thing is that /Network/Applications and /Network/Library (mounted from an OSX Server) are read write, while /Network/Public (mounted from same server) is not.

    Another funny thing is that we have two linux server, one exports /Docs (into /Network/Server/fileserver/Docs) and it is read only,
    the other exports /var/www in /Network/Server/apollo/var/www and it is read/write...

    Seems that BBedit has the same problem of Finder.

    Regards
  • freerock Level 1 Level 1 (0 points)
    After spending several hours trying to figure out what suddenly happened, I finally stumbled on to this thread. I am also having the same issue with Finder.

    Very disappointing Apple released 10.6.7 with this sort of glaring error....
Previous 1 2 3 4 Next