Previous 1 2 3 4 5 Next 61 Replies Latest reply: Jan 5, 2014 7:01 AM by CT Go to original post
  • blieben Level 1 (0 points)

    Now it's four people. I got a magic mouse last night and it started happening after that, I have done nothing else differently!

  • Lanny Level 5 (6,929 points)

    Just a note, if you hold the Option key down when you click on any of the Red buttons, all of the windows will close.

  • admann Level 1 (0 points)

    I've created multiple users, reinstalled OS X fresh with no backups and still have the same issue.  There are other threads open on this behaviour as well, not just this one.

  • Barney-15E Level 8 (46,274 points)

    That could be a possibility of the source if anybody else is using a magic mouse.


    I don't have one, so if that's the cause, that may also be why others can't replicate it.

  • admann Level 1 (0 points)

    2011 MBP 15" here all stock.  No mice

  • decrypter Level 1 (0 points)


    i bought my macbook few weeks ago,its late 2007 ,im working on snow leopard and have the same problem as u,

    is anyone know whats happen?

  • decrypter Level 1 (0 points)


    problem is solved i think so,from 4-5 days the red X in the corner of webbrowser and other windows are working perfect.I just installed snow leopard downloaded from web but before a did format ,then i did all of the udates after installation and working fine up to now.

  • WillyWoo Level 1 (0 points)

    Here is how I solved this quite frustrating problem.  It has actually been solved in a couple of other posts, but since they can be hard to find, I am reposting what seems to work for most folks:


    In Preferences> Trackpad: change the Double-Click Speed to something fairly fast.


    Thats it.


    I assume this would work for mouse only systems by changing the mouse setting double click as well but I don't use a mouse.


    BTW: this problem can be re-created by clicking between the Red and Yellow close buttons, then click the red button.. nothing happens, the window won't close until you then click to move the screen (the second part of a slow double click).


    Anyway, this solved my problem - hope it works for you. 


    PS - I also had this problem when trying to close a tab in Safari. Solution solved both issues.

  • admann Level 1 (0 points)

    I'll try this for a few days and see if that helps at all.  Thanks.

  • admann Level 1 (0 points)

    So far so good.. setting the Double Click rate to a high level seems to correct the issue.  Seems like an odd and unrelated temporary hackish fix.

  • sahile Level 1 (0 points)

    I am having the same issue... I have an iMac (27" i5) at home which I use with Magic mouse and Track Pad. I have a Macbook Pro (i7 / thunderbolt) and use that with a magic mouse as well. This issue persists on both the machines, and is typically on the red close button or the tabs in the browsers. I cannot explain how FRUSTRATING this is..... I don't exactly wish to make my double click speed too fast as that creates a different frustration all together..... but I will try that.... Wanted to post here to support the numbers for people facing these issues if that helps Apple in addressing the issue.

  • bethm87 Level 1 (0 points)

    It happens to me as well.  Just because only a few people happened to search the problem and reply, does not mean there aren't more people having the same issue.


    It is brutally frustrating.  I figured it was just a glitch that there would be an update/download for; however... no dice.

  • Peter Bannon Level 6 (10,095 points)

    I have the same problem. It appears randomly and not that often. Window minimizes instead of closing when clicking the red button.

    I've put it off to not selecting the red button carefully with the cursor dead center. Happens in applications - documents. I seldom if ever use the red button in the browser window.


    You can find this issue discussed online via Google, but I have found no answers.

  • decrypter Level 1 (0 points)

    As im said,i did format than remove partition,create partition and instaled newest version snow leopard downloaded from web.From 1 months everything working perfect,i have no more trouble with RED X in browser windows.

  • WillyWoo Level 1 (0 points)

    I really think this post should be closed as solved.  As I mentioned about 1 month ago, the solution is: In Preferences> Trackpad: change the Double-Click Speed to something fairly fast.


    Although I feel its a bug that Apple should fix, this is a solid work-around.  All of the 're-loads' of the operating system are a waist of time - I assume they fix the problem by simply setting the Double-Click speed.