Previous 1 2 3 Next 31 Replies Latest reply: Mar 17, 2014 2:40 PM by bethers98 Go to original post
  • katie8288 Level 1 (0 points)

    No fix for this yet? Same issue for me. I'm using Mac OS-X and the iPhone 3GS. Had recently updated the iPhone software to get all of the new goodies like Find my Phone and voice control and icloud. Missed a couple of appointments before I realized what was happening. I don't want to stop using iCloud so I'm just going to have to remember to check the calendar on the phone, I suppose.

  • wingster111 Level 1 (0 points)

    I am having the same problem - noticed only a few days ago after a year of flaw-free use. I am on iPhone3GS, not using icloud (sync only by cable connection through itunes) and have not accepted the latest software via itunes ad I hear it is full of bugs, perhaps I need to do so.... SO FRUSTRATING

  • mary-annfromsan jose Level 1 (0 points)

    Quick fix here.  When entering  an event on the iphone ical make sure to select either home or work calendar.  For me the probelm was that the automatic selection was going to my exchange icalendar and that was why it was not syncing with the computer.  You will need to go to the events that are not synced and manually change the calendar to home or work and then voila it will appear on the the ical cloud and computer calendars.

  • caarin Level 1 (0 points)

    mary-annfromsan jose is right!  I noticed when I added events to my iPhone 4S iCal there was a green dot next to them, as opposed to all of the other events which were blue.  I thought the colored dot was to distinguish between events added on the phone as opposed to the desktop, but the color of the dot indicates a different calendar. A calendar had accidentally been added to my Phone which I hadn't realized. I went back to the phone and edited the events I had input on the iPhone and under the "calendar" option I was able to select my HOME calendar (blue dot) as opposed to the other calendar (green dot) and now it's all fixed.  

  • Emeze Level 1 (0 points)

    Yes that was also my problem and synching with my Lotus Notes calendar. All the Apple changes and the biggest being iCloud and having to have LIon as the Operating system which I do not have as it is too costly to upgrade the RAM memory  on the Desktop and laptop to take Lion. This means I will have to use something else like Drop Box for my iPhone and Macs which is not as good but is a solution until I decide whether to continue with Apple. I have enjoyed the technology with a few hiccups for the last 7 yars. But the latest is beyond me as they stuffed up a simple and easy to operate system becasue they want more money. New users should be fine but for the rest of us it is a backward step.

  • MCFC2810 Level 1 (0 points)

    Yep this sorted me out


    Thanks very much

  • Wgo- Level 1 (0 points)

    All troubles started with the update of iOS 5 on my iPhone & introduction of iCloud (which claimed to push your date Automatic, effortless, and seamless to all your devices!)... not with mine...


    I just deleted the iCloud login on my iPhone & Mac, and started working like before connecting to my Mac.

    don't forget to tick on what you want to synchronize in iTunes...

    Still have to rearrange all my data in my iCal too...


    only troubles since the introduction of iOS 5 and iCloud... what a shame!

  • mvgallagher Level 1 (0 points)


    I've been tearing my hair out with this. But I've just spoken to one of the iPhone/iMac support guys who fixed this problem. After checking all my settings on MAC and iPhone he immediatley knew what was wrong and it took about 2 minutes to fix. The phone call in total was about 5 minutes. I'd wasted about  3hours.

    Worth giving them a call. I'm afraid I'm not technically minded enough to advise you what to do.

    Good Luck,


  • rorygilmore Level 1 (0 points)

    here's a fix that worked for me (from: .html) .htmlHow To: Fixing iCal iPhone Sync Issues


    You'll know the syncing issue when you see it, because the new events you enter into the Calendar on your Apple iPhone will not appear in iCal. Said another way, you'll enter a new event into your iPhone, use iTunes to sync with your Mac (or MacBook in our case) and the new event on your iPhone will not show up in iCal. Keep trying, synch as you might, iCal and the Apple iPhone just won't get along.


    Here's the down and dirty fix:

    1. Open iCal and backup or export your entries. Make a note of the fie name and location, you're going to need them in a minute. Once your backup/export is completed, close the iCal application.
    2. Open Finder and remove everything inside the "Username/Library/Calendars" folder. For instance, if your username is "Joe", then move everything inside the "Joe/Library/Calendars" folder.
    3. Open the iSync application. It's located in the "/Applications/" folder. Once iSync is opened, go into the iSync Preferences (iSync -> Preferences) and push/click the "Reset Sync History" button. Then, close the iSync application.
    4. Re-Open the iCal application and Import (File -> Import) a new calendar. When prompted, use your notes from Step #1 to select the file your created earlier. Once completed, close the iCal application (you should have all of your calendar entries back.)
    5. Open the iTunes application and connect your Apple iPhone to the computer.
    6. Within the Advanced section of the Info tab for the Apple iPhone, check the box the overwrites/replaces the Calendar data on the Apple iPhone.
    7. Click the Apple/Sync button. New, modified and deleted entries should now be syncing correctly.

    That's it! You should be all set and iTunes, iCal and our Apple iPhone should all be playing nicely as friends again. We've used the exact method to repair our own Apple iPhone at least once... maybe even twice.

  • longtimeuser Level 1 (10 points)

    Here's what I did.  On the iPhone, in settings/iCloud, I turned Calendars off, keeping the iCloud calendars which had been created after I got my new iPhone 4S and the salesman suggested turning iCloud on for calendars.  Then I turned iCloud back on for Calendars and selected "merge".  This gave me only one set of calendars on the iPhone, the iCloud calendars, not my old ones.  Then, on my iMac, I started going through discarding duplicates, mainly repeating events.  (Why Apple doesn't enable the "merge" function to ask if you really want to merge identical events, I don't know.)  Since I have only one set of calendars now, the duplicates should be eliminated in the future.  It remains to see whether I will again have the same problem - entries in the iPhone not appearing in the iMac (ICal) calendar.  Just tested it.  NOPE.  Additions and deletions made on iPhone don't show on iCal, whether syncing in iTunes or hoping for wifi to work (wifi syncing turned on).  Not Solved - what a pain.  And there are duplicates on iPhone not showing in iCal. So Calendar syncing is no good at this point.

  • JsHT Level 1 (0 points)

    I FIXED this for my iPhone 4S and MacBook Pro! I went into the settings on my iPhone and changed the "Default Calendar" to an iCloud calendar. I did have to go back and individually change all the events that I had entered into my iPhone prior to changing this setting (the default on the iPhone is "Calendar" which doesn't show up in iCloud) and like magic they all started showing up one by one!

  • DCC69923 Level 1 (0 points)

    This worked for me also.

  • bethers98 Level 1 (0 points)

    I was able to fix this without as much of the busy work.  I'm still on Snow Leopard on my MacBook Pro and have an iPhone 5.  I have icloud on the iphone but since I haven't upgraded to Mount Lion (or whatever it's called now) I am unable to have icloud on this laptop.  I do however have it on the iphone.  With that being said, go into your settings on the  iphone and click on icloud.  Make sure CALENDARS is turned OFF.  Now when the sync takes place it will go to itunes for the information instead of icloud.  Whala, problem solved.

  • Samuel Huskey Level 1 (5 points)

    My calendars and contacts were not syncing between my iPhone 5 and my iMac running 10.7.5. I followed the various instructions for resettting sync services, to no avail. I finally fixed the problem by disabling my Exchange account in iCal preferences=>Accounts, which I don't use for calendar purposes anyway. Now my calendars are syncing in both directions. It would be nice if I could include the Exchange account, since I often receive meeting requests that way, but I'll work around it.

  • lshaw123 Level 1 (0 points)

    Thank you...worked like a charm!