Previous 1 2 3 4 Next 90 Replies Latest reply: Nov 28, 2014 11:05 AM by cyberflyer Go to original post Branched to a new discussion.
  • nikv Level 1 Level 1

    This error can happen if Settings -> Spotlight has the Macintosh HD in the Privacy section (not to be indexed).  Reason being App Store uses Spotlight.  If you don't do this and Spotlight can index the Apps then it finds the updates and works okay.

  • Ralebird Level 1 Level 1

    I have tried trashing the program (Pages) restarting, searching for install files..... still no dice for me! Any other suggestions?

     

    Also, even thought I trashed Pages, I can still open docs in the pgm. How does that even work!?

     

    Okay, nevermind! I thought it strange that I could still access files. I did a "show in finder" from the Dock, and lo and behold, there was the app, still on board! Moved it to trash, reopened App store, and I seem to be okay. Thanks, everyone for you input... forum is a blessing!

  • nikv Level 1 Level 1

    Did you check if Spotlight is indexing your Mac HD and Apps folder too?  It needs to be able to find the orginal application  .app file as well.  As mentioned the Apps Store uses Spotlight.  If its been turned off for some time give it a chance to index.  If you have deleted the orginal app then this won't work.

  • Beartech Level 1 Level 1

    I had this bug, it's related to Spotlight. The App Store used Spotlight in some way. My fix was to add the entire HD to the "Privacy" tab in the Spotlight System prefs pane, close the prefs and wait 30 seconds, re-open and remove your HD from the Privacy tab. Spolight begins reindexing. Re-opened the App Store and problem was fixed! Posting this here for others who might search later on. Also filed a bug report with Apple.

  • New Test Leper Level 1 Level 1

    Simple, yet effective.

  • Straky107 Level 1 Level 1

    I have the same problem only mine is garage band and iPhoto. I have too many photos to delete the app and reinstall. What can I do with this? Help please :-)

  • Beartech Level 1 Level 1

    Have you tried the fix listed in this thread? Exclude your entire hard drive from the spotlight preferences (in the system preferences under "Spotlight") then reopen the pref pane and remove the exclusion. It will reindex your HD in Spotlight. But you probably won't even have to wait for the indexing to finish. My was fixed as soon as the re-index started.

  • Straky107 Level 1 Level 1

    Thank you, yes I did and it worked.

  • leonjrich Level 1 Level 1

    okay I deleted the APP. but now in the app store it is saying accept. then when I do. it tells me that this app can not be accpeted by this computer....

     

     

    can anyone help. Now my Iphot nad garageband is gone... Oh jesus.

  • Beartech Level 1 Level 1

    Did you read the posts above and perform the Spotlight Re-Indexing? If you haven't done that, deleting the App won't help.

  • theartist Level 1 Level 1

    Does anyone know the real solution?

    I have this problem in 10.6.8 and have tried every single one in this thread and have not been able to update.

     

    I must have 30 Apps to update via Purchases, but none of them will update and I get the dreaded Sign into other account, which of course there isn't one. I have a developement App that I really need to get updated and can't.

     

    Thanks in advance to anyone who can help!

  • Straky107 Level 1 Level 1

    You will need to contact Apple Support. You will have to delete each of the apps, and reinstall them. Apple will give you a voucher to purchase them again so you do not have to pay to reinstall them. I tried everything in these posts and nothing worked. It took about a week of working with Apple Support but it is finally resolved :-)

  • theartist Level 1 Level 1

    @Straky107   Thank you very much for your help!

  • jesture Level 1 Level 1

      Close App Store then open Terminal and type "sudo mdutil -a -i on" without quotes press enter type your computers password if needed for permission, then close Terminal.

     

    Wait for your computer to finish indexing, you can watch its progress by clicking Spotlight in the top right corner of your Mac (The Magnify Glass).

     

    Reopen the App Store and make sure you're signed in and the update tab should have a number by it with your optional updates.

     

    Voilà, your nightmare is over.

     

    jesture is the Audible He(art) of justian read.

     

     

    http://AudibleHeart.com

    http://facebook.com/jesture 

     

     

     

    Source=http://osxdaily.com/2011/12/10/disable-or-enable-spotlight-in-mac-os-x-lion/

  • iJRB Level 1 Level 1

    Having the same problem with Aperture and the error "To update this application, sign in to the account you used to purchase it" - App Store obviously not realising that it wouldn't even be showing if I was not signed on! .. anyway following this thread it looked like the secret was to move the app out of the applications folder. So I moved it to Trash and then 'Put Back' to Apps and wow it worked.

     

    There is certainly something screwed here Apple with the Apps store

     

    But glad this workaround fixed my update issue!

Previous 1 2 3 4 Next