Previous 1 2 3 4 5 Next 90 Replies Latest reply: Nov 28, 2014 11:05 AM by cyberflyer Go to original post Branched to a new discussion.
  • tfsapps Level 1 (0 points)

    jesture solution works great. thanks.

  • oy Level 1 (0 points)

    Thanks for the reply - I had the same problem - message saying i need to log in to the correct account though I only have one -  and found out I had put the "Apllications" and "Library" folders in the exclude list in Spotlight. Removed them, restarted the Mac and waited a few minutes to let the indexing start. Voilà - no more problems and alle the apps could be updated again. No need to trash them (I had 13 apps needing updates)!

    Thanks for this forum and your contribution!

  • waterloobob Level 1 (0 points)

    Did this as detailed and it didn't work for me. Hope you have better luck.

  • waterloobob Level 1 (0 points)

    In fact none of the proposed solutions worked for me. What did work was signing in under my old username and password. So if you're thinking of changing Apple ID's remember your old one, because the App Store apparently doesn't get the memo.

  • Richard Swainson Level 1 (20 points)

    Problem fixed. I tried all the methods mentioned in the forums and none worked. So I called AppleCare today and the fixed the problem in 5 minutes.

     

    1. Open Spotlight

    2. Enter 'adoption.plist'

    3. Locate the file (show all in Finder)

    4. Trash the adoption.plist file

    5. Launch App Store

    6. Select 'Purchases' and 'Accept' the apps you couldn't update

    7. Select 'Update" and update your apps

     

    This worked perfectly for iPhoto, iMovie and Garageband which were pre-installed on my new Mac, but would not update. I had the same dialogue box saying I needed to sign in with the account I used to purchase the apps. Of course, I hadn't purchased them for this Mac as they were pre-installed.

     

    All apps are now updated and working fine, so I hope this helps.

  • Omgedraaid Level 1 (0 points)

    Thanks Richard, this solved the problem with my new MacBook not updating the iLife apps.

  • Patrick123 Level 1 (65 points)

    I was getting this for Xcode.

     

    For me, this was a Spotlight issue.  I dragged Applications into Privacy, closed prefs, and then went back in and took it out.  After the reindex completed, I could do the update.

     

    It was strange.  When I typed Xcode into Spotlight, it would not come up.  Anything else in Applications would come up.

  • Claidheamdanns Level 1 (0 points)

    I'm having the same problem, but with installing Lion.

     

    At home I upgraded first to Lion and then to Mountain Lion. At work, we can't update to Mountain Lion because of incompatibility with some of our daily use apps.

     

    So, I downloaded Lion, and the Mac froze up before I istalled it. When it rebooted, the install sceen was gone, and so I went to the App Store to redownload it, but that's when I started getting this message.

     

    I've tried everything but the Terminal code trick (but it seems liek that is just another way to get the Spotlight to reindex).

     

    I can't find Lion anywhere on the system, in order to trash it, as instructed in this thread. I can't find where it downloaded it to either.

     

    So, I'm stuck. Any ideas??

     

    P.S. The work computer is currently on Snow Leopard. And I only have one Apple account.

  • jk3gs Level 1 (0 points)

    I've been trying to search for the adoption.plist - nothing.

     

    I've tried other solutions of trashing the apps (in my case, iPhoto & iMovie ...) and nothing helps.

     

    I messed with spotlight by adding the computer and then letting it re-index, it didn't help either.

     

    Cannot get them updated.

  • waterloobob Level 1 (0 points)

    Have you ever changed your Apple ID?

  • jk3gs Level 1 (0 points)

    negative.

  • waterloobob Level 1 (0 points)

    Crap. To be honest I never thought I had until I went into an Apple store. Then I remembered when I first had an Apple ID it didn't require an email address. Popped in the old ID (after trying to recall the password) and I was able to update. I changed that password to match the current one.

     

    Sorry. Don't know what's going on with Apple but lately it seems to be as convoluted as the other guys.

  • jk3gs Level 1 (0 points)

    to update on this, I called apple support and had to go to a higher level.

     

    then, they had to talk to either itunes or app store support and after about 45 minutes discussing the issue, they had to issue me credits on the app store, then download the apps ... and all is well.

  • Claidheamdanns Level 1 (0 points)

    I finally got mine to work. I couldn't find the adoption file mentioned earlier. But I did find the Lion install file, deleted it, redownloaded, and installed. That worked.

     

    By the way, I didn't see the file earlier, because I was looking alphabetically for Lion, but it had the word "Install" at the beginning of the file name. Hopefully, this will help someone else with the same issue.

  • dmauas Level 1 (0 points)

    I have a brand new macbook pro retina display.

    I had the same problem, with both iPhoto and iMovie. So I followed the advice and uninstalled them both.

    But when I closed and reopened the appstore, there was no "install" button - both programs are gone from the "updates" section.

    Furthermore, when I searched for iPhoto or iMovie - they both appear with a price tag.

     

    I already had to pay $19.99 for osx mountain lion... and I don't feel like throwing in more money, for applications to which I should be entitled for free, having purchased a $2,200 macbook...

     

    Any idea what I can do to get my "free" iphoto and imovie programs back?

Previous 1 2 3 4 5 Next