4 Replies Latest reply: May 11, 2011 6:19 AM by detroitquattro
Dazwan3 Level 1 Level 1 (0 points)
I have a belkin car adaptor that I have been using for some time, after installing IOS 4.3 I've been getting the error message saying it isn't compatible and so it refuses to charge my phone, this is important as I use it to charge my iPhone as I use it as a GPS device, i dont see how this problem has come about as prior to IOS 4.3 it charged perfectly!
Could I have some advice on this and fingers cross that apple reads and acts upon this forum!

Sony Vaio, Windows 7, Z Series 8GB DDR3, 2 YRS old.
  • rtkenmore78 Level 1 Level 1 (0 points)
    I'm having the same problem with my Belkin Tunecast since upgrading to 4.3 and it's now worse with 4.3.1. I'm at the Apple store now having them look at the issue.

    You're not the only one. Apparently the software upgrade doesn't agree. Apple says my phone is fine and could just be an incompatibility between Belkin and the new update. Hopefully it will be fixed in a future bug fix.
  • Free iPad. Hoax, or truth? Level 1 Level 1 (5 points)
    Actually, in most cases your car actually is charging the phone. I have an Autte A8 and the message shows up with me as well! But I figured out that it still charges it but claims to be uncompattible. Se if this works for you as well.
  • reilm2b Level 1 Level 1 (0 points)
    I am having the issue with the belkin and my wife has a car stereo that supports iphones and ipods via a usb connector it says the device is not supported. My belkin charges but doesnt play on the tuner at all.
  • detroitquattro Level 1 Level 1 (0 points)

    I've also had this issue with charging since upgrading to iOS 4.3.1  Actually upgrading to 4.3.2 and then to 4.3.3 has not solved the charging problem.  Here's my story:

     

    I own an iPhone 3GS and started noticing error messages with 4.3.1 such as "charging is not supported with this accessory".  I've tried differnent USB cables and chargers (Apple and non-Apple), hooking up to computers and wall outlets.  I get the same message.  As a last resort I restored my device as a new phone (syncing works oddly) and erasing everything.  This did not help the situation.

     

    So yesterday I took my 3GS to the Apple Store and they were kind enough to replace my iPhone with a new (refurbished) 3GS under AppleCare. That was awesome - I love Apple. However, that didn't fix the problem

     

    So now I'm not sure what to do accept wait for a new iOS version and hope Apple addresses this problem.  Anyone else have a similar experience?