6 Replies Latest reply: Jan 4, 2012 9:02 AM by MN99GT
Hunter3740 Level 1 Level 1 (0 points)
Go, Connect to Server, "smb://netbiosname;username:password@hostname/share" and connect totally works (or omit the domain;username:password@ and when prompted for name and password, type "netbiosname\username" and the password), but I'm assuming you can only script this with applescript, and I would much prefer normal bash scripting...

...Go, Utilities, Terminal, "mkdir /Volumes/share", then "mount -t smbfs //netbiosname\username:password@hostname/share /Volumes/share" does not work, one gets a "mount_smbfs: server rejected the connection: Authentication error" message.

Note: I can use the mount command without the "netbiosname\" as long as I use a domain name and password, but I'm trying to connect to the machine with a built-in username, thus the username = netbiosname\username. At least for now, I add a domain account to all machines' administrators group (via a group policy to make my life easier!), so I'm scripted, but still curious...

Tried setting the workgroup name to match the target netbios name via the WINS tab/pill in the Advanced button in Network System Preferences (and omit the "domain\" in the call above), but to no avail (and if it did work, wouldn't help me when it comes to multiple machines). Also tried disabling the "Microsoft network server: Digitally sign communications (always)" and "Domain member: Digitally encrypt or sign secure channel data (always)" in the group policy (for the 2008 domain), but to no avail.

Also, tried various mount_smbfs, smbclient, mount -t cifs, and even an .nsmbrc file, but to no avail.

This is for a 10.6 machine connecting to a Windows 7 machine attached to a Windows 2008 (and 2003) domain, but attempting to connect with a local username in the command line (as opposed to GUI working in all circumstances and command-line only working for domain usernames).

Macmini3,1, Mac OS X (10.6.7)