5 Replies Latest reply: Nov 19, 2011 9:56 PM by CrazyLilAznChik
Pangolin1 Level 1 Level 1 (0 points)
My bank has an application that will allow me to do deposits online by scanning the checks. When I try to use it, it says I have 64 bit Java and they are a 32 bit Java ap and to select 32 bit Java.

So I went to the Java control panel and changed the order to check for 32 bit first then 64 bit.

Both are checked. When I try to de-select the 64 bit Java the 32 bit also de-selects.

How do I specify that I want only 32 bit Java?

MacBook 5.1, Mac OS X (10.6.7)
  • Kappy Level 10 Level 10 (263,150 points)
    This may be affected by how Safari is loaded. By default it loads as a 64-bit application. Quit Safari. Select the Safari application in your Applications folder. Press COMMAND-I to open the Get Info window. You should see a checkbox labeled, "Open in 32-bit mode." Click the box to check it enabled. Close the Get Info window and relaunch Safari. Now try your bank site to see if this fixes the problem for you.
  • Barney-15E Level 8 Level 8 (44,330 points)
    I didn't see this as being run under Safari, but Kappy might have a better answer.

    I didn't have a pure java app to try, but I did notice that if it is a .jar, you can set the default Open With to the 32-bit Jar Launcher. The other thing I was thinking was similar to Kappy's suggestion with Safari; just see if you can set it to open in 32-bit from the Get Info window.
  • Pangolin1 Level 1 Level 1 (0 points)
    You know - I tried this with Firefox but not Safari. With Firefox it still told me I was running 64 bit Java. I am trying now with 32 bit mode for Safari. So far it's not tanking. It's not working either but it's not tanking. I'm going to mark this answered. Thanks.
  • KJK555 Level 4 Level 4 (2,895 points)
    Here is some info about java and Firefox:

    The Java firefox uses is determined by the bottom window selection in Java Preferences.

    The Java Safari uses is determined by the top window selection in Java Preferences.

    Test your java here:
  • CrazyLilAznChik Level 1 Level 1 (0 points)

    Try This, I think it might fix your problem:


    Go - > Utilities -> java preferences


    Click and Drag the

    32bit Java

    and Bring it over the 64 Bit Java


    That should make it look like:

    32bit Java

    64bit Java


    which should launch 32bit Java first.. then 64bit.

    You can also choose to disable 64bit altogether though I find it better to just disable it.


    You may have to restart your computer.


    Let me know if this helps!