7 Replies Latest reply: Apr 18, 2012 11:43 AM by bfromg
claytoday Level 1 Level 1 (0 points)
Hi. I am hoping someone can help me with an issue I have. I have a 15" MacBook Pro with OS X 10.6.7. I also have a Canon MP830 all-in-one printer, scanner and fax. I can print using my Macbook but I can not scan. I have exhausted help with Apple and Canon. I have the latest scanner driver from Canon. I have the latest software from Apple. The MP830 is connected directly to my computer via USB.

I have tried scanning using Image Capture, Acrobat and MPNavigator. At best they will make the scanner head scan the document on the platen but an image is never displayed. At some point, there is usually a communications error displayed 155.0.0.

Can anyone help me? I really want to be able to use the MP830 with this computer. Since no one from Apple or Canon can help me, I am hoping someone here can assist me. Thanks for your time!

MacBook Pro 15", Mac OS X (10.6.7)
  • rkaufmann87 Level 8 Level 8 (48,920 points)
    You may be a good candidate for Vuescan. Here is a link to it:

    http://www.macupdate.com/app/mac/4763/vuescan
  • drewt1 Level 1 Level 1 (0 points)

    there is an issue with canon scanners and the 10.6.7 update. I have been on the phone for hours with canon and they claim they can't recreate the problem on their mac's, but I read all over having issues. I use LIDE20 Canoscan and MP Navigator software, been using for years without any issues until the update.

  • bjornfromgullholmen Level 1 Level 1 (0 points)

    I realise the same problems with my brand new MacBookPro 15", 10.6.7, and the new Canoscan 9000 and old Canoscan 8800 and also Canon MP750. I have to go back to my five years old PowerBook G4 (10.4.11) to scan and print!

    Hope to see a solution soon.

     

     

    PS when downloading or installing from DVD the scannerdriver, a window comes up saying:

    "Cant't find TWAIN library in your system!"

     

    When installing SilverFast from DVD this sign comes up, saying incorrect installing.

  • drlocker Level 1 Level 1 (0 points)

    I am having the same issue.  Have a MP830 that I can print, but can't get it to scan.  In image capture it says no scanner.  In presto says no scanner or driver installed.  Have all the updated drivers, etcc..

     

     

    Really frustrated

  • bfromg Level 1 Level 1 (0 points)

    Same problem here.

    Macbook PRO 13" (10.6.7 and now 10.6.8) with Canon MP830. Prints fine but fails attempting to scan. Image capture does recognize the scanner though.

    Lost an hour again today trying to scan 2 pages with no result at all.

     

    Anybody?

  • Taylordesign Level 1 Level 1 (0 points)

    Was having similar problems. First, ran Disk Utility (see under heading: "Try Disk Utility") using Snow Leapord disc on startup and repaired disk and repaired permissions.

     

    Then deleted the MP830 from the computer's printer list, and re–added it. Manually went to download and install the newest printer AND scanner drivers separately for the MP830 (on 4/17/12) from the Canon website.

     

    Now, using USB to hardwire MP830 to my 15" Macbook Pro (10.6.8), Image Capture now recognizes it as a scanner and works perfectly using and selecting both the document feeder and the flatbed.

     

    Hope this helps solve the problem for somebody.

  • bfromg Level 1 Level 1 (0 points)

    Amazing!

     

    I have been struggling for months, if not years to solve this issue. Even last week, re-installing the drivers and printers.

     

    I just finished repairing the disk permissions (nothing was wrong with the disk itself), installed the drivers and printer again, ... AND IT WORKS LIKE A CHARM!!!!.

    (Must be a problem related to disk permissions)

     

    Thanks a lot Taylordesign!