5 Replies Latest reply: Sep 20, 2011 3:37 AM by Mikey mike mike
fdiesel Level 1 Level 1 (0 points)
This question might be answered... Posting anyway in case it helps anyone else (did not find answer when I searched). Feel free to ignore or contribute as you wish.

iPhone 3GS currently streaming a movie from MacBook Pro iTunes library so home sharing is working. It connected fine the first try.

iPad has not been able to connect. When it tries, it shows the library in the list. I select the library and the spinner starts. After about a minute (60 seconds) the error says Cannot connect to media library.

I have tried logging both devices off the wifi and logging back on while they are sitting right next to each other.

My wifi is set up with the wireless modem (n) with an Ethernet cable to another router used simply to extend the signal to the other side of the house (same network name -- this will probably cause some questions but I can't be sure it's the problem) ... So far AirPlay has worked fine, Apple tv works fine.

The library is not too large, only 1,000 songs and a couple dozen movies.

Not sure what other variables would be relevant.

iTunes 10.2.1
OSX 10.6.7
MacBook Pro
iPad (not iPad 2) iOS 4.3.1 (8G4)
iPhone 3GS iOS 4.3 (8F190)


Hmm... I wonder if that is the problem. The version on the iPad (not working) is newer than the iPhone (working).

I thought I just updated both to the newest but I guess 4.3.1 is only a few days old.

Might have just answered my own question.

MacBook, iMac, iPhone 3GS, iOS 4, iMac does not have home sharing turned on.
  • thx1138jt Level 1 Level 1 (0 points)
    There is definitely something wrong with 4.3.1.

    My setup:

    iMac OS X 10.6.6

    iTunes 10.2.1(1)

    iPhone 4 4.3.1 (8G4), Remote app on this phone was working fine with ATV's until I upgraded it to 4.3.1 today. Now it can not find the home share library or the ATV's.

    iPad 2 32GB Verizon 4.3.1 (8G4), Just upgraded to 4.3.1, not seeing home share library at all.

    ATV2 OS 4.3 (8F202), Software 4.2.1, Was working until the last update, now don't see home share library at all.

    ATV2 OS 4.2.1 (8C154), Software 4.1.1, This one I did NOT get the update, works fine with no issues at all.


    I have tried to turn Home Share On/Off, turn ATV's/iPhone/iPad On/Off and reset Home Sharing. Nothing works. I think it is pretty telling that the ATV without update works fine were all devices with 4.3.1 stopped working.

    Apply please fix!!
  • thx1138jt Level 1 Level 1 (0 points)
    I finally got mine to work last night. Here is what I had to do:

    - Stopped home sharing on ATV. Powered it off.
    - Stopped home sharing on iTunes. Stopped all apps.
    - Updated OS X to 10.6.7
    - Powered off iMac.
    - Powered off router/wifi access point (Verizon FiOS)
    - Powered on router.
    - Powered on iMac.
    - Enabled home sharing on iTunes.
    - Powered on ATV.
    - Enabled home sharing on ATV.

    Now ATV, iPhone, iPad see's the home sharing library and I was able to stream music and pictures. Haven't tried movies yet.

    I have no idea which one of the steps actually did the trick. I'm guessing either the OS X update or turning off the router and let devices re-estabhish network connections. But all of trouble started after the latest round of updates so it definitely has issues.

    Hope this helps.
  • ccasbal Level 1 Level 1 (0 points)
    In both, Iphone and Ipad, there is a message that says " cannot connect to media library". First time. I have updated all the OS of all equipmnet.
    Any help is welcome
  • Grundit Level 1 Level 1 (0 points)
    I have not been able to connect Apple tv to either mbp or imac since update....

    APPLE FIX ASAP PLEASE


    there is a serious bug.
  • Mikey mike mike Level 1 Level 1 (0 points)

    Hi, After a lot of getting fed up with forums not helping, I disable the personal firewall in our Eset Secruity, then it's good to go.

     

    Hope this helps someone like me looking for the answer for ever.