4 Replies Latest reply: Apr 11, 2011 3:06 PM by Kate Porter
Kate Porter Level 2 Level 2 (215 points)
Hi, I'm not sure I'm on the right forum, but to change my admin password, I inserted the Install DVD. Once I had changed the password, I tried to eject the disc, but it started to install Mac OS X. Since I already have it, I tried to stop it, but even after I closed it out, it continues to try to install and now I can't turn the computer off. It just goes to sleep and when I move it, it wakes up and there on the screen is the beginning of the software that asks what language I want it in. I'm perplexed, but I think the computer is holding on to the disc because it thinks I want it to install. Thanks for any ideas. Kate

MacBook Pro 15", Mac OS X (10.6)
  • 1. Re: MacBook Pro will not eject Install DVD.
    Kappy Level 10 Level 10 (226,765 points)
    Five ways to eject a stuck CD or DVD from the optical drive

    Ejecting the stuck disc can usually be done in one of the following ways:

    1. Restart the computer and after the chime press and hold down the left mouse button until the disc ejects.

    2. Press the Eject button on your keyboard.

    3. Click on the Eject button in the menubar.

    4. Press COMMAND-E.

    5. If none of the above work try this:
    Open the Terminal application in your Utilities folder. At the prompt enter or paste the following:
    /usr/bin/drutil eject

    If this fails then try this:
    Boot the computer into single-user mode. At the prompt enter the same command as used above. To restart the computer enter "reboot" at the prompt without quotes.
  • 2. Re: MacBook Pro will not eject Install DVD.
    Kate Porter Level 2 Level 2 (215 points)
    Cappy, thanks so much. I know this information will be valuable to me at some point down the line, but I'm not getting anything on my screen but the "what language do you want to use?" black box of the Install DVD. The menu bar isn't there, so I don't have the options. I think the Install program is actually running somehow. Should I be on another forum for this problem when I look at it from this perspective? Thank you. kate
  • 3. Re: MacBook Pro will not eject Install DVD.
    captfred Level 7 Level 7 (26,235 points)
    Kate,

    If all else fails hold the power button down for 5 seconds and do a "hard shutdown". Then power back up and hold down the Option key between the gong and logo with pinwheel. It will give you your boot device options, select the HD. You should then be able to eject the disk.

    Regards
  • 4. Re: MacBook Pro will not eject Install DVD.
    Kate Porter Level 2 Level 2 (215 points)
    Thanks Fred, this helped. Kate