13 Replies Latest reply: Dec 29, 2011 9:43 PM by LarryCNYC
thx1138jt Level 1 Level 1 (0 points)
I have searched the forums and seen similar issues but not exact the same. I believe there is definitely something wrong with 4.3.1.

My setup:

iMac OS X 10.6.6

iTunes 10.2.1(1)

iPhone 4 4.3.1 (8G4), Remote app on this phone was working fine with ATV's until I upgraded it to 4.3.1 today. Now it can not find the home share library or the ATV's.

iPad 2 32GB Verizon 4.3.1 (8G4), Just upgraded to 4.3.1, not seeing home share library at all.

ATV2 OS 4.3 (8F202), Software 4.2.1, Was working until the last update, now don't see home share library at all.

ATV2 OS 4.2.1 (8C154), Software 4.1.1, This one I did NOT get the update, works fine with no issues at all.

I have tried to turn Home Share On/Off, turn ATV's/iPhone/iPad On/Off and reset Home Sharing. Nothing works. Even created a new home share on a Win 7 machine, it shows up on the un-updated ATV but not on the others.

I think it is pretty telling that the ATV without update works fine were all devices with 4.3.1 stopped working.

Apply please fix!!

iMac 24 Inch
  • LadyBrett Level 1 Level 1 (0 points)
    I'm glad to run across your thread. I bought a Apple iPad 2g ( 16GB/WiFi) yesterday. The first thing I did was upload 4.3.1. I wondered why "Home Sharing Library" feature isn't coming up on my iPad 2g. So, I hope someone will reply to help us both. Windows Vista/XP notebook computers ....
  • JimHdk Level 7 Level 7 (28,295 points)
    thx1138jt wrote:
    I have searched the forums and seen similar issues but not exact the same. I believe there is definitely something wrong with 4.3.1.

    Not quite so simple a problem as simply doesn't work. I'm running iOS 4.3.1 with iTunes 10.2.1 (1) and Home Sharing works fine for me. This also worked with iOS 4.3. I'm currently using Mac OSX 10.6.7 but this also worked with 10.6.6. This is with an iPad1 and a iPod Touch 3g both running iOS 4.3.1.

    There must be something unique about your environment which is involved in the problem you are having.
  • thx1138jt Level 1 Level 1 (0 points)
    I believe the problem do not affect every device upgraded to 4.3.1 otherwise there would be much bigger outcry. However, I do see enough similar issues (dropping home share connection, not able to play movies ....) on the forums to know it is not isolate to myself. Also, all of the issues showed up after I got the update to 4.3.1. And the ATV without the update works fine.

    I'm waiting for another iPad 2 to show up tomorrow. Will try to new one and see.
  • JimHdk Level 7 Level 7 (28,295 points)
    I think that you should forward all of the information that you posted together with information on the network you are using (router make/model/version/firmware level, network security type, etc) to Apple at: http://www.apple.com/feedback/ipad.html. This is a much better vehicle to get your problem to Apple's attention than simply posting here. Since this is principally a user-to-user forum Apple may never hear of it from here.

    Perhaps you'll get luckily and someone will have a solution or work-around but, most likely, you'll at best just get some "me too" posts. Comforting perhaps but not much use.
  • jthor Level 2 Level 2 (310 points)
    Same problem for me. Happened after updating to 4.3.1. I used Home Sharing on my iPhone that morning; after updating it no longer works.

    Not working on two iPhones, and an iPad.
  • Johnathan Burger Level 6 Level 6 (15,695 points)
    iPad 2 and iPhone 4 working just fine for me.
  • thx1138jt Level 1 Level 1 (0 points)
    I finally got mine to work last night. Here is what I had to do:

    - Stopped home sharing on iTunes. Stopped all apps.
    - Updated OS X to 10.6.7
    - Powered off iMac.
    - Powered off router/wifi access point (Verizon FiOS)
    - Powered on router.
    - Powered on iMac.
    - Enabled home sharing on iTunes.

    Now ATV, iPhone, iPad see's the home sharing library and I was able to stream music and pictures. Haven't tried movies yet.

    I have no idea which one of the steps actually did the trick. I'm guessing either the OS X update or turning off the router and let devices re-estabhish network connections. But all of trouble started after the latest round of updates so it definitely has issues.

    Hope this helps.
  • Mike Donscheski Level 1 Level 1 (0 points)

    I was running into this problem as well.  I can't say for sure that it was the iOS update, however, after shutting down my Mac, Router, and iPad, and then restarting, I found that everything was working as before. I inadvertantly did not shut off Home Sharing on either my Mac or iPad, so it appears to be something around the networking.

  • Mr Cranker Level 1 Level 1 (0 points)

    I thought I'd come in with my discovery and this relates to both Home Sharing on iPad, iPhone and the Remote App.


    I have an iMac and a MacBook Pro which both run Lion and are updated with all the latest firmware. I have been on and off, trying to get home sharing to work and recently discovered the remote app, and that wouldn't work either.


    I have a TimeCapsule at home: My iMac is a wired connection and my MacBook is a Wfi, as is the iPhone and iPad. However, The TC was configured with a wireless network for me to use and a guest network for anyone else to use. I stupidly had forgotten the password to my network a while back so had my iPhone and iPad set up on the guest network and the iMac and MB set up on the private network.


    Once I remembered the password for the private network and got ALL devices talking on the same network, I could see the home sharing library and use remote as it was intended.


    So even though you may think that you have your Time Capsule or Airport Express base station talking to all computers, if they're not on the same network, your IOS devices won't be able to see the home shares.


    I hope this helps at least somebody - I have been so frustrated with this, and I'm pleaseed to have it running as it should!


    Best regards,



  • Richard Woolmer Level 1 Level 1 (20 points)

    Had this problem on my iPad 2, but all my other devices were ok iPhone 4, Apple TV 2, iPad 1. Restarted hard drive and iPad 2 still the same but after resetting the "Network settings" on the iPad 2 everything was there. Worked for me give it a try.

  • ZX6Warrior Level 1 Level 1 (0 points)

    I'll second Richard's solution as that worked like a charm for me as well.

  • anthony21p Level 1 Level 1 (0 points)

    i have 3 ipad1, 1 ipad2 & an iphone4 at home. my fastest and most reliable solution tohome sharing is:

    1) end the video, music/ipod app on your idevices

    2) unplug your router power cable. (restart it)

    3) works like charm.


    ps: your idevice must be connected to the same wifi, itunes must be opened in your pc/mac

          when you restart your router, your idevice must be on and connected (tried & tested)

  • LarryCNYC Level 1 Level 1 (0 points)

    Disable AP Isolation on your Wireless Router, then restart the music and video apps on the ipad, iphone, etc.. I just got the ipad2 and had the same problem.  Now its fixed.