8 Replies Latest reply: Nov 3, 2012 6:18 PM by HobiePilot
Sarah CMac Level 1 Level 1 (0 points)
I am trying to access my shared folder on my MacBook from my iMac.
I am trying to access the files from finder. The left hand navagation in finder (which holds categories such as 'devices' and 'places') no longer lists 'shared' as one of the categories. Ive tried using search and spotlight to find the shared machine and the shared folder to no avail. However If i am in photoshop, and i go to file>open, the shared category (complete with my macbook and the files i am looking for) appear, and i have no trouble accessing them that way.

Why is 'shared' no longer listed in finder, and how can i get it back there?

iMac, MacBook, Iphone 3G, Mac OS X (10.5.8), Leopard. MacBook: 2009 13" Aluminum, 2.0 GHz, intel core 2 duo, OS X 10.5.8
  • Jolly Giant Level 7 Level 7 (25,440 points)
    finder > preferences > sidebar. make sure +bonjour computers+ and +connected servers+ are check marked



    ( *click on image to enlarge* )
  • Sarah CMac Level 1 Level 1 (0 points)
    Thank you for the suggestion... i thought this would solve it, but it did not.
    Any other suggestions?
  • Jolly Giant Level 7 Level 7 (25,440 points)
    try this:

    trash the following plist: ~/Library/Preferences/com.apple.sidebarlists.plist, log out and back in.

    what happens ?
  • Mark Shuttleworth Level 1 Level 1 (0 points)
    I have the same problem.

    Our WiFi network contains two MacBooks (one 10.5.8, one 10.6.3), one XP machine and one Mac Pro (10.6.3). All Macs have filesharing on, Share preferences set to show connected and bonjour servers and so on. My MacBook (10.5.8) at first did show the Windows machine at least and even let me copy files from it, but now not even that. I've tried all sorts that I've picked up on forums:
    - Forced quit of finder
    - Manually connecting to the servers via cmd-K and IP address
    - Reapplying the 10.5.8 combo update
    - Switching on/off sharing, and now
    - Trashing the sidebarlists.plist file.
    - ...

    Nothing works. I don't even see the Shared category in Finder when opening files in applications like Photoshop.

    Need help big time as our local network is effectively useless for sharing between machines at the moment.
  • Mark Shuttleworth Level 1 Level 1 (0 points)
    UPDATE:

    Interestingly, if I power up our Windows laptop and try to connect (cmd-k) to one of the Windows items in the "Favorite servers" list of the cmd-k dialog, I get an error response saying "+Connection failed: This file server is running on your machine. Please access the volumes and files locally+".

    This suggests that under the hood the Macbook can see the servers and may be able to access them, but they are simply not appearing in Finder. What's more baffling though is that all three of our Apple machines have the same problem even though different hardware, ages and operating systems.

    Any ideas? Anyone?...
  • Mark Shuttleworth Level 1 Level 1 (0 points)
    Ok, another twist. I cycled our router, trashed the MacBook plist again then immediately rebooted it and now *all four* machines are able to share files again.

    I have no idea if any or all of those things were responsible for fixing the problem (for now at least), or whether Leopard just felt good because it was a sunny day. But it baffles me how trashing a plist on the MacBook could possibly make a the Mac Pro suddenly start to show shared files too... Maybe there was something about the state of the router that made the biggest difference?

    Anyway, who knows, but for now we have a useful network again though I'm very nervous as to whether it will last.
  • Bwhalen2000 Level 1 Level 1 (0 points)

    Hi Mark (and everyone), Any solutions or improvements?  I'm in Lion, and STILL have the same old problems. Thanks,

    Brad

  • HobiePilot Level 1 Level 1 (0 points)

    I have the same problem on my new macbook pro.  I can see "shared" on the home network but not when I'm away. After doing a little research on different sites I came up with this key sentence that did the trick for me!!

     

    You can use screen sharing on the road if you enabled "Back to My Mac" in:

    System Preferences>iCloud> check the "Back to my Mac" box.

     

    I did this and it synced and I went back to finder and there it was.

     

    Bill