7 Replies Latest reply: Dec 16, 2013 9:12 AM by freeqzaq Branched to a new discussion.
Darryl Mylrea Level 1 (105 points)
I'm having a rather odd issue with attempting for partition/format some USB flash drives on both my new Macbook PRO 17 (SB) and a new Mac Mini server.

It started out with me trying to partition and format a 16GB USB flash drive (Transcend). During a long attempt, it failed. I took it out and checked it on my Windows 7 notebook. It was fine. I erased it in Windows 7 and put it back in my Macbook Pro. Another attempt to format was successful, but only 10GB was partitioned. Disk Utility showed the remainder (minus a GB or so) as available.

At this point, I tried a different, brand new Sandisk 4GB flash drive. It formatted correctly to the full 4GB.

I then tried an 8GB Sandisk. Only a partial format, leaving 2.71GB available.
I tried a fourth flash drive...another 8GB Sandisk, and the same thing, some random amount formatted, and the remainder as available.

Thinking my Macbook Pro was the problem, I tried it on my new Mac Mini server. Same thing. Partial format/partition.

After many more futile attempts at partitioning and formatting the 8GB flash drives, and getting random amounts of formatted capacity with the remainder showing available, I gave up.

I am partitioning using Disk Utility, as 1 partition, MAC OS Extended(Journaled), and GUID partition type.

What am I doing wrong? Why does the 4GB work, but 8GB and 16GB only give me a portion of the drive?



Macbook PRO 17 (2011), Mac OS X (10.6.7), Mac Mini Server 2010
  • Kappy Level 10 (263,335 points)
    Would you try this:

    Drive Preparation

    1. Open Disk Utility in your Utilities folder.

    2. After DU loads select your hard drive (this is the entry with the mfgr.'s ID and size) from the left side list. Click on the Partition tab in the DU main window.

    3. Under the Volume Scheme heading set the number of partitions from the drop down menu to one. Set the format type to Mac OS Extended (Journaled.) Click on the Options button, set the partition scheme to GUID then click on the OK button. Click on the Partition button and wait until the process has completed.

    4. Select the volume you just created (this is the sub-entry under the drive entry) from the left side list. Click on the Erase tab in the DU main window.

    5. Set the format type to Mac OS Extended (Journaled.) Click on the Options button, check the button for Zero Data and click on OK to return to the Erase window.

    6. Click on the Erase button. The format process can take up to several hours depending upon the drive size.

    I don't know what you are looking at to determine space available. You need to do that by selecting the device's Desktop icon then press COMMAND-I to open the Get Info window. The capacity and available space will be displayed in the Get Info window. A portion of the device will be allocated for the RDB and directory, so some space will be shown as in use.
  • Darryl Mylrea Level 1 (105 points)

    Apart from the full erase, those are the steps I am using. A full erase is very time consuming and should not be needed in order to get USB flash drives to format.

    After performing the partition procedure, DU shows the graphic of the drive, and part is blue, and part is white. I believe the blue part is the portion that was not (for whatever reason) part of the partition created. It also says to the right of that, the total size of the drive and some amount of GB as "available". I presume that amount it shows as available is the portion that was not used in the partition. When I format a 4GB USB flash drive, it all shows as part of the 1 partition, and says nothing about any amount available (which is how it should be).

    Since this is happening on 4 different 8-16GB flash drives, I doubt it's a flash drive problem, and since my Mac mini server did the same thing on one of the 8GB flash drives, it doesn't look likes it's just my Macbook Pro!
  • Kappy Level 10 (263,335 points)
    You are correct, but if the device had a Windows partition and format, then the zero data option is recommended but no necessary.

    The blue area you see in the partition rectangle doesn't mean a thing. I believe OS X displays that as the space the OS would require for installation. On 8 GB devices it's mostly blue. But that has nothing to do with available space. Use Get Info for that or look in DU's status area after you select the volume (not the drive entry.)

    The blue area will not show up on devices smaller than 8 GBs because they are not large enough to install OS X.
  • danegeld Level 2 (185 points)
    Do the Sandisk drives have their obnoxious U3 software on them? If so, that could explain the discrepancy. The U3 stuff is in a partition of its own that's notoriously difficult to get rid of. There's a tool on Sandisk's website that will do the job.
  • Darryl Mylrea Level 1 (105 points)
    If the blue area is meaningless, then I was led astray with that graphic. The fact that DU was showing 8.03GB total capacity, then, to the right of the partition blue/white box, it says "size: 7.69GB, 2.29GB available", it sure looked to me that it was not using all 8GB for the partition.

    I will attempt to use the flash drive, as it is formatted, then and see if there is a capacity problem.

    Thanks for your help on this!
  • Kappy Level 10 (263,335 points)
    Ignore the partition graphic. Rely on what is shown when you do a Get Info on the device.
  • freeqzaq Level 1 (0 points)

    Bue area is very IMPORTANT. Every time I use to erase the ''current" partition and create a new one (just one) the blue area is getting bigger ( only when you need to use the GPT ) .  When you go and do a Get Info the available space is getting lower and lower ...


    I am searching this , if I manage to find out information about it I will comment here again.