5 Replies Latest reply: Mar 31, 2011 5:36 PM by Joseph Kriz
Subito Piano Level 1 Level 1 (0 points)
So I want to install Myst on my iPod touch using the iTunes app. However, this app requires an operating system of at least 3.1.3. Currently, my 2nd Generation iPod Touch is running version 2.2.1 (5H11). When I try to update my system through iTunes, it says that the software is up to date. What options do I have to improve the operating system of my iPod?

Thank you for your responses.