Previous 1 2 3 Next 41 Replies Latest reply: Mar 16, 2015 9:39 AM by Rich Grosch
e4effect Level 1 Level 1 (5 points)
I have a Mac Pro (early 2008) Quad-Core Intel Xeon, 2.8 GHz, 4GB ram, Airport card, Magic Mouse. Suddenly the keyboard and wired/bluetooth Mouse are unavailable, so it is not possible to control the computer. The only way I can use it is by using Screen Sharing from my MacBook Pro - which is obviously pretty useless except for diagnostics! All the USB ports (front and back, as well as those on the Cinema Display - when connected) are dead. System profiler shows no problem with them, but also shows nothing connected. Bluetooth in menu bar shows as "Bluetooth: not available", and in system profiler shows as "No information found".
I've tried all the usual remedies. Powering off overnight with power cord disconnected, all peripherals disconnected, then booting up again. Holding in the power button for ten seconds when the power cord is disconnected. Obviously I can't reset the pRAM (because the keyboard is not recognised, even before the OS loads). The first couple of times I tried this process, it did bring back the USB ports, even the bluetooth became temporarily available, but soon disappeared again. USB ports died next time I rebooted.
However, in the last couple of days, the process produces no results. No matter how long I leave it disconnected, USB ports are not working and bluetooth is just not there...
I've checked for other threads on this topic, but most other people seem to have issues with either front or back USB ports, or even just one or more individual ports. My problems have only been with all ports or none.
Does anyone have any suggestions to get my MacPro up and running again properly?

Mac Pro, Mac OS X (10.6.7)
  • satcomer Level 4 Level 4 (1,110 points)
    Some users with 10.6.7 Bluetooth problems have report if they Reset their Pram and Bluetooth starts working again. So try it and see if it fixes your problem.
  • e4effect Level 1 Level 1 (5 points)
    Thanks for the reply.
    Unfortunately I can't reset the PRAM because that requires use of the keyboard. Without USB I can only connect via Screen Sharing once the Mac Pro has booted. On another thread I found a terminal command to reset PRAM :: sudo nvram boot-args=”-p -r” :: but that returns an error message :: nvram: (usage: no such option as -r) ::, and the -p switch means "print all firmware variables", so that's not going to work. So unless anyone knows of a terminal command that works, I can't see any other way to reset the PRAM.

    I am wondering if the USB issue could be anything to do with a bad bluetooth card. Or do you think it's more likely to be a power issue?
  • e4effect Level 1 Level 1 (5 points)
    For about an hour yesterday, both the bluetooth and USB ports came back to life (after a long period of power disconnection etc). Then I noticed that the bluetooth had disappeared again (I hadn't been using the mighty mouse, so I don't know exactly when it went). Then, one by one, the usb ports started becoming unresponsive. When I attempted a restart, there was no usb or bluetooth. Further power disconnections and SMC resets later, still no joy.
    Does anyone think I should remove the bluetooth card since it seems to be the first thing to go offline?
    Or are there any other diagnostics I can try to identify the cause?
  • cgn1234 Level 1 Level 1 (0 points)
    I have the same problem. My Bluetooth Touchpad stopped working. The pRAM reset fixed the issue, but after the machine went to sleep and woke up again, it was disabled again.
  • e4effect Level 1 Level 1 (5 points)

    Just waking this thread up again in case anyone has had any other ideas.

     

    Since last posting, usb became functional again, (came back on a couple of hours after a restart) and as long as I kept the machine alive, usb would stay alive. Bluetooth came back on briefly, but for most of the time was unavailable. System profiler shows no problems and Console does not report any usb related errors as far as I can see.

     

    After a recent restart, usb disappeared again, and despite numerous restarts and being left on for a couple of days (and subsequently left off for several days) it has not come back. When usb is not working, examining the system profiler (through screen sharing from my macbook) usb shows no errors, but also shows no connected devices. I can charge my ipod nano with any of the usb ports (front or back), so power does not seem to be the issue.

     

    I can't reset pRAM (because the keyboard is not available at boot), but have reset SMC numerous times. Have tried other keyboards, and mice. No joy.

     

    I seem to have run out of ideas. Any suggestions?

  • e4effect Level 1 Level 1 (5 points)

    As a matter of interest, USB functionality suddenly returned yesterday after the machine had been left on (but unresponsive) for just over a week. There was absolutely nothing that I can think of which could account for this, it appears to have happened in the middle of the night when I was asleep and nothing external was connected to the mac (other than keyboard and mouse). Though the USB was alive, bluetooth remained stubbornly unavailable.

    Then, just as suddenly, some time during the same day, the USB died again!

    Back to square one, and none the wiser...

    ?!?!?

  • Probl3mSolv3r Level 1 Level 1 (0 points)

    Had this same exact problem on my 2010 6-core Mac Pro. All bluetooth and usb stopped responding. I unplugged everything, opened it up, removed all drives and memory tray, and pushed in all cable connections I could see. Put everything back in, closed the case, plugged all my usb/firewire cables back in and it worked perfectly.

  • miguemac Level 1 Level 1 (0 points)

    same problem on macbook 4.1, any news?

  • HDme Level 1 Level 1 (0 points)

    Similar problem here. All external ports (USB and FireWire) work intermittently. When importing images from Compact Flash card through an USB adapter, it will download normally for 1-5 min. then suddenly lost contact to the USB port. I unplug and plug right back in then it work again and after a few mins it will re-happen. I use the same card reader on my other iMac and it's working perfectly fine. I also have the original iSight, and it have the same problem. During Facetime, it will cut off automatically; unplug then put it back in and it work again for a little while then cut out again. I also tried to reset the PRAM many times and had no luck.

     

    So far, I don't have problem with external hard drives, only iSight and USB readers. Strange. Are the external ports defective?

  • nonoNC Level 1 Level 1 (0 points)

    Hello, I had the same problem. I use the bluetooth trackpad with my laptop at home and wanted to use it with my mac pro (early 2008) at work but it wasn't working. So I read the trackpad's manual and it says you should unpair the device before pairing it up with another computer. I did that and it worked. I hope the solution will be just as simple for you.

  • Rahxn Level 1 Level 1 (0 points)

    Hey....uh.....may I ask??? Would any of you, by chance, be running Windows 7 Pro as a dual boot on your Mac??? I am having the same issue and not gettng much help from Apple. I cannot run my wireless hardware on my PC side and it really suck....I was wondering if this had any correlation or effect on the USBs and the Bluetooth function!!!!

  • TinkerShell Level 1 Level 1 (0 points)

    I have the same problem on my Mac Pro 2.26 GHz Quad-Core. When I first got the computer I only had the Bluetooth issue and I was able to get it working again. In the end I'm not really sure which "fix" did the trick but it was fine for months. Now it's just like the original poster described. It seems like the computer is frozen but it's actually the keyboard & mouse not functioning (Bluetooth mouse, USB keyboard). I can still control the computer through screen sharing or log-me in, thankfully, but it's not a solution to the problem. I have tried everything that I have read to do but, the issue keeps coming back. I'm at a loss, has anyone found a solution?

  • slammyman Level 1 Level 1 (0 points)

    Same problem here. Happened twice in a week.  I opened it up both times and poked things, and then it was working again.  Super annoying! 

  • dermatoid Level 1 Level 1 (0 points)

    OK, same problem here.

     

    Goggled around, with no success.

     

    The problem showed up suddenly, both with Magic Trackpad, Magic Mouse AND Logitech USB mouse.

     

    Terrible.

Previous 1 2 3 Next