1 Reply Latest reply: Apr 13, 2011 10:28 AM by ProtoDrake
Matthew Tuerk Level 1 Level 1 (0 points)
I am working on a Macbook purchased in November 2008. Until now, no problems, but this morning after a full night's charge, I ran it for about two hours without being plugged in. When I plugged it in to charge, the indicator light on the magsafe would not light and the macbook would not take a charge. Fortunately, I had another magsafe power adapter, but this would also not charge the battery. I reset the SMC, thinking it was the cause of the problem, but still no luck with either adapter.

I went to the genius bar, where they plugged in my macbook with one of their adapters. Charging and startup. They recommended that I had a problem with my adapters, so I purchased an 85w adapter. I brought that adapter home and plugged it in macbook. Nothing. I went to my THIRD older magsafe adapter and when plugged in I got a faint/dim LED. Unplug, take it back to 85w. No light, no charge. Back to third, older magsafe and I get a faint/dim LED that flashes between faint amber and faint green.

The computer will not start up now even with the battery removed.

Thoughts?

aluminum macbook (late 2008), Mac OS X (10.5.8)