6 Replies Latest reply: Dec 6, 2012 11:27 AM by oneofffeedback
markgca Level 1 Level 1 (0 points)
i have a iPhone 4 with 4.3.1 firmware.

i used to have tethering and it worked fine. they canged tethering to hotspot; i can still connect my laptop (ibm t40-p) to the iphone via a cable, and the 'hotspot' works that way.

but using wifi to connect, it doesnt work.

the ssd does show up in the listing, but when i enter the password (which i changed twice to try letters only etc.) it sits there, trys to connect, then doesnt.

again, if i connect via cable its ok.

my laptop can connect to other wpa2 connections with no issue.

any ideas as to what to look for here?

iPhone, iOS 4, 4.3.1
  • SteveCWatkins Level 1 Level 1 (60 points)
    Same issue. WiFi connection was working great a few days ago, now it just says "unable to connect" after the password. Bluetooth works fine, just not WiFi.
  • SteveCWatkins Level 1 Level 1 (60 points)
    A full reboot of the iPhone seems to have fixed the issue for me. Hold down both the home button and the sleep button until the phone shuts off. Keep holding until the Apple logo reappears. After the reset, it works again for me.
  • markgca Level 1 Level 1 (0 points)
    i have been travelling, and found a few things.

    laptop will connect to open WiFi connections like in the airport
    other/random computer i found can connect to my iPhone without issue
    laptop will connect to my WiFi at home

    so the only combination that doesnt work seems to be laptop to iPhone, and perhaps laptop to other connections with different security.

    not sure what to do with this, as it seems to be an incompatibility either with the security/settings/drivers or ???

    any suggestions?
  • welderpenny Level 1 Level 1 (0 points)

    I have a simplar problem. my laptop connects to my iPhone 4 hotspot fine by cable but won't connect using wif.

    It is listed as one of the available wireless connections on my computer but when i try to connect it just tells me that the connection was cancelled?

     

    It doesn't even ask for the password anymore. It used to work fine until a couple weeks ago. Not sure if I turned something on or off in my phone?

     

    Frustrated!

  • welderpenny Level 1 Level 1 (0 points)

    solved the problem... right clicked on my iPhone listed in the wireless available connections list on my laptop. slected properties... then retyped my iPhone's hotspot password in there. retried to connect and success!

  • oneofffeedback Level 1 Level 1 (0 points)

    Hi All

     

    Just a quick note for anyone having this problem... I had the same problem, and managed to fix it by taking the apostrophe out of my iphone name.

     

    e.g. If your iphone is called

     

    Matt's iPhone

     

    if you change it to

     

    Matt iPhone

     

    (Instructions here: http://support.apple.com/kb/ht3965)

     

    AND THEN TURN YOUR PHONE OFF AND ON AGAIN

     

    you should find that you can connect no problem (unless you have other issues as well of course!)