Skip navigation

"None of your preferred networks are available" but I can see them!

2944 Views 2 Replies Latest reply: Feb 6, 2012 3:59 PM by MysticKnights RSS
lucysnowe Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 3, 2011 6:21 PM
Occasionally when I start up my MacBook I get a window saying "None of your preferred networks are available," even though my network is listed among those located. If I try to connect via network preferences it tries, but then tells me the connection timed out. I am connecting via wifi. The only thing that works is to turn the router off and restart it. As soon as it has started up again and has a network connection, I can go to the AirPort icon and connect to the network.

I have tried re-entering the network password, restarting the computer, turning AirPort off and on, removing and changing firewalls, but nothing has helped.

Any ideas?
MacBook, Mac OS X (10.5.8)
  • William Boyd, Jr. Level 6 Level 6 (10,475 points)
    lucysnowe wrote:
    "None of your preferred networks are available"


    Welcome to Apple's discussion groups.

    It might help to reset the connection settings on your Mac using these steps one at a time until the problem is resolved, recognizing that, depending on your problem, not all of these steps will make sense:

    1) Use the AirPort menu bar item to turn AirPort off, then on again.

    2) Try to select your Wi-Fi network from the AirPort menu.

    3) In the Network panel of System Preferences delete the AirPort item from the left column, then add it back.

    4) In the same panel as (3), define a new location and see if you can make that work.

    5) In the same panel, select the AirPort connection item, click the "Advanced" button, select the "TCP/IP" tab, then click "Renew DHCP Lease".

    6) In the folder /Library/Preferences ( not <yourhomefolder>/Library/Preferences), move the folder SystemConfiguration onto the Desktop, then restart your computer. See if you can now make your AirPort connection work.

    These steps may not help, but they'll only take a couple of minutes to try. Before you try these, if you have any special network settings on your Mac for things like DSL credentials, note all your network settings, because the latter steps will destroy them. If you got all the way to the last step, if things don't work any worse than before, you can trash the saved SystemConfiguration folder.
    MacBook 5,2 2.0 GHz, 4GB RAM, Mac OS X (10.6.7)
  • MysticKnights Level 1 Level 1 (0 points)

    I had the same problem. It started when I temporarily turned off my filewall in Airport Express. When I turned the filewall back on, I would lose my WiFi connection anytime the computer would sleep.

     

    When I went into System Preferences > Network and selected Wi-Fi and then clicked on the Advanced... button in the lower right corner, it showed my Network name but it said "None" in the right column under Security.

     

    I highlighted network name and then clicked on the - button just below to delete the "Preferred Network". Then I clicked on the + button and added my network again.

     

    Once I did that, it showed "WPA2 Personal" in the right column under Security. I suspect that's going to fix the problem, but I just did it so I can't say for sure until I've tested it for a couple of days.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.