Skip navigation

VST Plugins in Logic Pro Academic

3294 Views 3 Replies Latest reply: Apr 5, 2011 2:17 AM by Eriksimon RSS
breakingbad Calculating status...
Currently Being Moderated
Apr 4, 2011 3:58 AM
I have Logic Pro 9, the academic version, and I am attempting to use a vst plugin. I have searched online and found that I need to locate the logic folder and drop the vst plug in I want to use in the vst plugins folder. I cannot seem to find the "vstplugins" folder within the logic folder nor can I find the AU insert where I would choose a vst plugin. Am I too thick to find what I need or is it possible that the academic version does not support this function? If so, is there any other way I could use a vst plugin? Please help!
Much obliged

Message was edited by: breakingbad
Mac OS X (10.6.6)
  • BenB Level 5 Level 5 (7,535 points)
    Currently Being Moderated
    Apr 4, 2011 9:19 AM (in response to breakingbad)
    OK, in Logic, the Help menu, Logic Pro Help, the Logic user manual, do a search for VST for some important info about wraping VST's into AU's (and for Audio Units, also.

    [System Drive] > Library > Audio > Plug-ins > VST
    FCS3, FCSvr 1.5, Aperture 3, Logic Pro 9, Snow Leopard, Mac OS X (10.6.7)
  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Apr 4, 2011 12:04 PM (in response to breakingbad)
    Logic cannot use VST plugins, only Apple's AU format.

    There used to be a VST wrapper but that was early on, have no idea if it's Snow Leopard compatible.

    pancenter-
    Power PC G5 Dual 1.8GHz, 4GB RAM, Mac OS X (10.5.8), RME Audio - MOTU MIDI, (Logic 8.02), Intel/Windows-7 Quad Core PC
  • Eriksimon Level 6 Level 6 (10,415 points)
    Currently Being Moderated
    Apr 5, 2011 2:17 AM (in response to Pancenter)
    Pancenter wrote:
    Logic cannot use VST plugins, only Apple's AU format.

    There used to be a VST wrapper


    There still is!

    but that was early on, have no idea if it's Snow Leopard compatible.


    It is!

    http://www.kvraudio.com/get/4187.html
    EsMac Core2 Quad 2.5 GHz, Mac OS X (10.6.4), Logic 912 Nikon D70

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.