Skip navigation

2011 MacBook Pro slow to reconnect WiFi after waking from sleep.

15521 Views 17 Replies Latest reply: Feb 28, 2012 7:03 PM by DVT70 RSS
1 2 Previous Next
negativzero Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 5, 2011 6:21 AM
I got the 15" MacBook Pro and recently, the MacBook takes ages to connect to the internet. When I wake it from sleep, it connects to my WiFi network in seconds, however, I can't surf the internet unless I wait for a min or so after connecting to WiFi. Is this normal behaviour on the MacBooks?
MacBook Pro 2011 15" 2.2GHz, Mac OS X (10.6.7)
  • Erik Norgaard Level 1 Level 1 (0 points)
    It shouldn't take more time than if you turn off airport then turn it on.

    To see what's going on, go to System Preferences -> Network. There you can see as the network status changes:

    Off -> On -> Authenticating -> Obtaining network configuration/No IP -> Connected

    If it is slow receiving the network configuration it may auto-configure and set ip to 169.254.x.x. If that happens you won't have internet connection until it retries.

    OSX automatically renew the network configuration after a certain period, but you can force it either by turning off/on the airport or by going to System Preferences -> Network -> Advanced -> TCP/IP and click renew DHCP lease.
    Mac Book Pro, Mac OS X (10.6.7)
  • Erik Norgaard Level 1 Level 1 (0 points)
    You need to provide more information to help us help you. From your first post I understand that the MBP eventually connects. It seems to me that your computer doesn't get

    Do the following steps and pay attention to the details:

    Enter System Preferences -> Network and click on Airport.

    Step 1: Turn airport off, then on. Under the on/off button you can see the current status, pay close attention as it changes when you turn on the airport. It may choke at any of the following points:

    - looking for available networks
    - authenticating
    - obtaining network configuration

    If it chokes on any of the above this may cause time outs and failure to connect and configure correctly. Once you have status "connected", paste the status line here, it should be something like "AirPort is connected to YOURWIFISSID and has the IP address x.x.x.x"

    Step 2: Check the IP address, if it is 169.254.x.x your airport has autoconfigured and won't be able to access the internet. This indicates a dhcp timeout. When this happens, OSX tries to obtain a new lease after some time. Click advanced then the TCP/IP pane. There you can click the button "renew DHCP lease", you may have to click a few times.

    Step 3: Check the network configuration, in the TCP/IP pane you can see the current network address, mask and default gateway. If you have an IP correctly assigned, you should be able to access other computers on your local network. Check that this is the case.

    Step 4: If you have access to other computers on your network, local networking is OK. Check that the gateway is set and correct. Failure to set the default gateway correctly means that you won't be able to connect to the internet.

    Step 5: Click on the DNS pane, and check that the DNS configuration is correct. You should have at least one IP address listed in the DNS servers box. If not, you may actually be able to connect to the internet but can't visit webpages like apple.com.

    Step 6: If all of the above is OK and you still cannot access the web, possibly you have a problem with DNS caches, you can use dscacheutil to flush the cache.

    However, from what you write I suspect you fall into Step 2. I can't say whether it's the dchp server (likely your router) or client that's got it wrong.

    Please reply to each of the above steps in your next post.

    Hope this helps, Erik
    Mac Book, Mac OS X (10.5.8)
  • telefonique Level 1 Level 1 (25 points)
    I only just began noticing this happening with my 13" i7. The remedy that seems to work for me is clicking the airport icon and then re-selecting the network that it already says I'm connected to. After that Safari and Mail are online again and I'm in business.

    Not ideal, but not a major problem either. Probably will be fixed with an update sometime down the road.
    Mac OS X (10.6.7)
  • telefonique Level 1 Level 1 (25 points)
    I have concluded that in my case, this is a problem with specific networks / routers, or even just the way they are setup. It happens when I'm at my g/f's place using the wifi from her dlink router, but not at my place using the wifi from my airport extreme. As such, I don't see it being an Apple hardware or software issue with my MBP itself. I also can't be bothered to trouble shoot it further or mess around with the dlink settings at her place.
    Mac OS X (10.6.7)
  • RippoNippo Level 1 Level 1 (0 points)

    The below worked for me after major slow/non responses from websites where youtube videos just do not load and speed test indicated 1mb per second response.

     

    - Change WPA to AES instead of TKIP worked for a MBP 13 inch 2011 and I see a quicker response on the iPhone4 with wifi connection which may be a coincidence or so.

  • thebrakshow Level 1 Level 1 (0 points)

    I'm having the same problem. I got a 2011 MBP 15" in August with snow leopard. I upgraded to Lion and thats when this problem began. So this is what happens, when i put my computer to sleep ( shut the lid) and turn it back on it connects to the internet with a unique IP however, Safari doesnt work nor does Chrome for atleast 4-5 min. I know im connected because as soon as Airport shows that im connected, I can use Lynx in terminal and it connects to the internet fine ( while Safari and Chrome still dont work). Same with pianobar, it works to stream music through terminal while safari and Chrome dont work. I would do what negativzero did but i am using diff connections all the time between school, work, and home. This is seriously starting to drive me insane. My old 2006 macbook's (plastic body) airport works 2387412934 times better than this brand new $2800 computer!!

     

    Computer Specs:

    Macbook Pro 2011 15"

    2.3GHz Intel Quad-Core i7

    8GB 1333MHz DDR3

    OSX 10.7.1

  • Brossardois Level 1 Level 1 (0 points)

    I spent 45 minutes with the Apple advisor trying all sorts of things like setting a new location, bump up Wifi in the list of ports, turning off iChat at login, etc...She finally gave up and told me to go to an Apple Store.  Right after that I hang up the phone, I did a software update on my June 2011 13" MBP.  It said "firmware" update so it sounds more serious than the other times.  Reboot...It fixed the problem.  Now I have Software  Mac OS X Lion 10.7.1 (11B26).  Hope this helps.

  • OneDeafGeek Level 1 Level 1 (0 points)

    Interestingly enough that I am expericing the same thing you're expericing now with my new MacBook Pro running the latest Lion OS. 

     

    Here's my network setup:

     

    1. Verizon FIOS -> Airport Extreme on 2nd floor on east side of the building.

    2. Ethernet from Airport Extreme -> 1st floor on west side of the building -> Airport Express

    3. Airport Express using ethernet, connected to Airport Extreme, in bridge mode.

     

    Airport Extreme is using channel 1 while Express is using Channel 11 to keep each other apart but using the same SSID and WPA 2 password.

     

    When I open my MacBook Pro, it was able to obtain WiFi signal and connected using DHCP instantly. But I was unable to surf internet for another min or two.  I even hard coded the DNS ip address like one of poster suggested, but it didn't do the trick. 

     

    Any idea? Did I overlook anything that causing this issue?

  • OneDeafGeek Level 1 Level 1 (0 points)

    Disregard this as the issue has been resolved after EFI firmware update.  I thought I already did the EFI upgrade but apparently it didn't so I had to do it again. With that being done, the issue of connectivty to the internet via WiFi is now fixed.

  • jaroslavmoravec Level 1 Level 1 (10 points)

    And now it occurs on my computer as well. Any new ideas what to do?

  • NNikzad Level 1 Level 1 (0 points)

    This issue started for me after a firmware update last week. Based on OneDeafGeek's suggestion, I manually cheked for system updates earlier today and found a new EFI Firmware update available. I have just installed it and my issue seems to have gone away. Try that out!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.