Previous 1 2 3 Next 76 Replies Latest reply: Jan 23, 2016 8:04 AM by Chrislaptop
worth1090 Level 1 (0 points)
When ever I start my computer I get the white screen and rather than the apple logo appearing, I get a grey folder with a question mark in the center of screen. My computer will not start up, it will sit at the white screen and flash the question mark folder. My computer is a 2008 white mac book. Please help!

Message was edited by: worth1090

Mac book
  • mberardinelli Level 1 (45 points)
    Hello there,

    When your Mac starts up to the blinking question mark, that means that it cannot find the system files/software required to start up. This can happen for a number of reasons, mainly because of directory corruption.

    Did this happen after an update or after you installed a certain piece of software? Or did it just happen randomly?

    Here are a couple of things to try:

    1. Try starting up using a Safe Boot. To do so, press the power button to turn on your MacBook and hold down the Shift key on the keyboard. This will automatically run a disk check so it may take some time before it reaches a login screen. If it boots into safe mode, try rebooting into normal mode again.

    2. Reset the PRAM. To do so, press the power button to turn on your Macbook and simultaneous hold down Option + Command + P + R. Keep these held down until you hear the startup chime at least 2 or 3 times, then release them and let the machine boot.

    3. Startup from your Mac OS X install disc and use Disk Utility to verify/repair the disk. Reboot and let the machine boot normally.

    Let me know if any of this helps.

  • worth1090 Level 1 (0 points)
    It just happened randomly. It happened once before but it fixed itself some how and so this is the second time but I dont know how to fix it or prevent it.
  • mberardinelli Level 1 (45 points)
    You can really "prevent" it so to speak. Try out those things I suggested in my last post and let me know if any of them help out.
  • Carl Aspler Level 1 (105 points)
    Hi mberardinelli.

    I have the same problem - folder icon with question mark. Just happened randomly. I tried all the things you suggested to another person. Safe book didn't work, same for resetting the PRAM. When I ran disk utility to verify permissions form the startup disk, I got a message - First Aid valid packages.

    Any additional suggestions? Is this the beginning of the end??

  • mberardinelli Level 1 (45 points)
    Is that all the error message from Disk Utility said? Did you just try to repair permissions or did you also try Repair Disk?

    Sounds like you might have some directory corruption on your hands. If Disk Utility can't fix it, you might be looking at a reinstall of Mac OS X (unfortunately). You can try to use software like Disk Warrior to rebuild the directory enough to where you can recover any data you have lost.
  • Carl Aspler Level 1 (105 points)
    Yes, that's all the message said. The option of repairing permissions was dimmed, and the message of the of the failure came up almost immediately.

    I don't mind reinstalling Mac OSX. I basically use this computer as a "cheap and cheerful" replacement of my regular computer when I am traveling to do emails, check internet, and do other basic work.

  • Willie88 Level 1 (0 points)
    Hey I have the same type of problem, unfortunately this is resulting from a spill on the computer. When the computer was on, but closed, a friend spilled a drink on the left side of the closed computer. They immediately picked it up and got the water off the computer, however when I tried to turn it on a few hours later the screen blacked out. I waited for a day or so and tried to reboot the computer, the screen turned on and gave me the white screen with the ? mark in the folder. What is concerning about this is that I have just replaced the interal HD with a 500gb HD less than 2 months ago and there was no water damage on the harddrive when i had taken it out. Also, the battery is new and the computer will only boot/power when it is plugged into the charger, so it's basically saying the battery is dead which should not be true bc it also is less than 2 months old. When i booted the comp through snow leopard and proceeded to the screen which asked which drive to put the program on, it would not recognize the HD. Any clue to what is going on, pleeeeease help
  • Carl Aspler Level 1 (105 points)
    Sorry, I can't help. I also tried to do a software reinstall, but it when it asked me where to put the program, there were no choices..

    Is the hard drive Missing in Action?

  • MilkyJoe Level 1 (0 points)
    I have this exact same problem..
  • Carl Aspler Level 1 (105 points)
    Hi Matt.
    I tried everything, no luck. When I tried to reinstall OS X there was no place to install, so I couldn't go any further.

    Is there anything else I can try?

  • mberardinelli Level 1 (45 points)

    Hi Carl,


    Unfortunately it sounds like your hard drive might be toast. If your machine is out of warranty, you could by a decent harddrive on Newegg for pretty cheap and try swapping it out (or, if your machine is still under warranty, you could just bring it into an Apple store). It is pretty easy to swap the hard drive in a Macbook:


    1. Remove the battery

    2. Loosen the three screws to remove the RAM cover (the screws will not come out of the metal cover).

    3. You will see the hard drive on the left side of the battery bay. Pull the white plastic tab to slide it out of the Macbook.

    4. Use a Torx screwdriver to remove the hard drive casing (so that you can put that handy pull-tab on your new hard drive)

    5. Put the case onto your new hard drive and replace.


    After that, try booting to your install disc again and format the disk with Mac OS Extended Journaled format and install Snow Leopard.

  • mberardinelli Level 1 (45 points)

    The water spill sounds like it may have fried your logic board, which is why the hard drive is not being detected (even if the drive itself was not damaged) and your display as acting strangely. Since the left side of the Macbook is where all the ports are, the water could have easily gotten into them and damaged the logic board. Unfortunately that's not covered under AppleCare so you could be looking at either paying for a logic board replacement or a new Macbook altogether.

  • dennis619 Level 1 (0 points)

    Solution number 2 helped me get my system back up. Hallelujah!  Thank you!

  • JeffreyJizzle Level 1 (0 points)

    Anyone else there: The three proposed solutions didn't work for me, but I held down "option" during startup and chose my harddrive and worked fine from there. Really strange, but aweseom!

Previous 1 2 3 Next