10 Replies Latest reply: Jan 4, 2013 2:41 AM by marcoooo
Parham Level 1 (90 points)
Hi,

I have two Macs:
1- iMac 25'' (older) with all software updated, including the latest version of GarageBand.
2- MacBook Pro (very recently purchased), with all software updated as well, although GarageBand 11 came pre-installed on this one.

I have Logic Studio with all components installed on both.

I have a problem: When I downloaded the extra loops (around 1.5 GB I think) on the MacBook Pro through Garage Band, everything went smoothly; meaning by double-clicking on one of the extra loops, a window opened asking me if I wanted to download the extra loops now or later, and when I clicked on "now", the software update window opened, found the extra loops, and downloaded them in one package after asking.

When I try to do this on the iMac, double-clicking on one of the missing loops in GarageBand does open the window where I'm asked if I want to download the package now or later; but when I click on now, the software update window opens and it does NOT find the missing loops to download, tells me my software is up to date, and then quits after asking! In addition, when I double-click on one of the missing loops again, a window opens telling me that the said loop is being downloaded and installed, which is not the case! Double-clicking on any other missing loop gives me the same result, of course.

Anyone had this problem before? What is the solution?

Message was edited by: Parham

iMac 25'', Mac OS X (10.6.7)
  • a brody Level 9 (65,765 points)
    See if you can find the loops through http://www.apple.com/download/

    Software update can get clogged up sometimes. Sometimes repairing permissions fixes it. Sometimes making sure the hard drive isn't too full fixes it. Sometimes checking on your internet connection fixes it.
  • Parham Level 1 (90 points)
    Thanks for the advice, but unfortunately, the loops are not on the site. Any other suggestions?
  • a brody Level 9 (65,765 points)
    Is your data backed up at least twice?
    How big is your hard drive?
    How full is it?
    Are you using any system optimizing or maintenance utilities that might affect caches? These can cause problems for updates.
  • realradius Level 1 (0 points)

    I have the exact same problem with a brand new 13" MBP with the absolute newest configuration. Purchased March 2011.

     

    -ey

  • Parham Level 1 (90 points)

    Yes, my data is backed-up.

    Hard Drive: 500 GB

    Full: Around 300 GB

    I'm not using any utilities that affect caches. At least not before attempting to download the loops.

    Anymore suggestions?

  • dagon Level 1 (0 points)

    I just ran into this and managed to solve it, but it was a pain.  Here's my situation:

     

    • New iMac 27 inch
    • Used Migration Assistant to transfer all user accounts, user files, and applications off of an older (late 2006) iMac that had been upgraded to Snow Leopard and iLife '09

    When trying to install the full set of Apple Loops and Software Instruments, I got the infamous "run Software Update but nothing ever downloads" problem.  After doing a lot of looking on these boards and elsewhere, I decided to uninstall GarageBand '11 and reinstall.  Uninstalling GarageBand '11 is a pain too; here's what I did:

    • Deleted GarageBand from the Applications folder
    • Deleted the /Library/Application Support/GarageBand folder
    • Deleted the /Library/Audio/Apple Loops/Apple/Apple Loops for GarageBand folder
    • Deleted anything related to GarageBand in /Library/Receipts
    • And everything in ~/Library/Application Support/GarageBand (this is optional I think)

     

    I then reinstalled GarageBand from the second install disk that came with my new computer, fired up GarageBand, and downloaded the recommended update.  Finally, I opened up a new Loops project; in the Loops Browser, selected one of the missing loops; got the "run Software Update now or later" dialog, and said "Later"; quit GarageBand.  Finally, I opened Software Update, and lo and behold! the near-mythical GarageBand Loops and SW Instruments update was there, all 1.2 GB of it!

     

    I wish that Apple would come out with a patch for this, but in the meantime, if you're situation is similar to mine (upgraded GarageBand '11), you might try the deinstall / reinstall route and see if it works...

  • Parham Level 1 (90 points)

    Hello and thanks for your feedback.

    Actually, my problem has been solved (although I'm not sure how!), but now I have another problem: I have all the mssing loops twice! I also have the app showing me that it's still missing them, meaning I have three lines for each loop, one showing they're not there and two underneath showing they're there, twice! Would you happen to know how to solve that now?

    How do I delete all the extra loops and the lines showing they're not there?

  • Parham Level 1 (90 points)

    Okay, problem solved.
    This is what I did:

    - I uninstalled Garage Band completely with the aid of an app-remover.
    - I re-installed through the app store.

    - I clicked on one of the missing loops. The software update engine identified correctly that it's mssing the loops and is currently downloading them.

    Voilà!

  • rafaelalvesgb Level 1 (0 points)

    This works for me. Thank you.

  • marcoooo Level 1 (0 points)

    thanks man, this has been a huge help