Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Possible MP3 Import Bug - Track and Album Title Tags Ignored/Lost

Hi, I've run into a problem where MP3 tags for track, and album title, written and re-readable using Windows Explorer in Windows 7 are being ignored when ITunes 10.1.1.4 imports the files.

Symptom after import is empty track data, and "unknown album". I've identified the problem only occurs with files having the tag "Encoded By : iTunes 9.2.1.4", to the extent that if I remove this tag, importing works as normal with Album Title and Track data being correctly populated, though Comments shows signs of corruption.

I also tried rewriting title and album tags while retaining the Encoded-by tag in-case the file tags were corrupt - but the problem continued. In both failure and success cases tags were identified correctly as IDv2.3 encoded.

This problem happens both through user interface and the COM automation interface in code. I'd consider it either an undocumented side-effect or bug - feels like the latter to me. Sample files available on request.

Message was edited by: stephbu

Message was edited by: stephbu

Windows 7, ITunes 10.1.1.4

Posted on

Reply

Page content loaded

Nov 17, 2011 9:12 PM in response to stephbu In response to stephbu

For what it's worth, I can report the same issues as stephbu with iTunes 10.5.0.142 (Windows 7 with all system updates) when importing MP3s. In my case the problem ones are tagged with Encoded by: "iTunes 9.0.1.8".


When I remove the Encoded by: iTunes 9.0.1.8 tag using windows explorer the files all import correctly and successfully.

Nov 17, 2011 9:12 PM

Reply Helpful

Nov 17, 2011 9:45 PM in response to gregsly In response to gregsly

A bit more data: I encountered the same problem when the tag was iTunes 8.x.x.x. I tried editing instead of removing the tag...by replacing the periods with underscores and that fixed the problem, but only in some cases. For others it seems that completely removing the Encoded By tag is required.


This really seems to be a bug in iTunes.


Message was edited by: gregsly

Nov 17, 2011 9:45 PM

Reply Helpful
User profile for user: stephbu

Question: Possible MP3 Import Bug - Track and Album Title Tags Ignored/Lost