Previous 1 22 23 24 25 26 Next 449 Replies Latest reply: Mar 18, 2015 9:44 AM by UKBrian Go to original post Branched to a new discussion.
  • CP10934 Level 1 Level 1

    Thank you Frans


    Works perfectly.  My frustrations have been resolved.


    I hope Apple picks up on Frans' solutioon and fixes the bug in their next release of iTunes


    Thanks again Frans

  • azdaren Level 1 Level 1

    I wonder if this will work for Windows machines. I am having the same problem.

  • VapinJethro Level 1 Level 1

    Possible fix to eliminate the ATV3 dropping homeshare connection . . . only 36 hours working so far.  Have had so many problems with homeshare disconnecting that I consider recent success temporary until it works for a week or so without problem.  At that point, I will edit post and remove the word "possible".  For now, I am calling this "possible" and put it out here for others to try.  This is a very frustrating problem, and if I can help anyone avoid the headaches we have all had with this, I gladly do so.  But I am not too confident about this, since it has only worked for a short while, and because I am an amateur in these types of things.  I am an absolute amateur when it comes to computers, networking, and many other things, so I apologize in advance for perhaps being long-winded or overly thorough, i.e., redundant, but I want to make sure what I've done is clear to see in case it will actually help someone. 


    Here, briefly I will give symptoms of my problems of ATV3 dropping or disconnecting or not seeing it's homesharing connection.  Have only had the ATV3 for three months or so.  At first everything I tried to do with it worked, so I got a good taste of what the ATV3 experience could and should be like.  Then after a few weeks, I would get messages such as "you need to enable homesharing on the computer using such and such specified itunes account.  I would then check the Windows7 machine I was using to manage my library (which resides on a Time Capsule, for more network layout info see next paragraph).  After reading through posts on several forums, I would simply turn off home-sharing, then turn in back on by signing in "enabling" homesharing which was earlier already enabled.  This fix worked for awhile.  Then this fix no longer worked or only worked sporadically.  Also, I was introduced to the infinite spinning circle of nothing happening . . . sometimes after letting the circle spin and forgetting about it doing other things around the house, it would on rare occasions start working "out of the blue."  Then later it quit working.  I had relatives over for the holidays and told them we could watch a few movies in the living room using the Apple TV.  I scrambled up and down the stairs since the ATV3 and Win7 were on different floors, restarting Itunes, signing out of and back into homesharing, all to no avail, nothing worked.  It was a bit embarrassing, not being able to get anything to work.  We just wanted to watch a movie, which I thought was never going to happen, even though weeks earlier it had been a very easy task. 


    (As an aside, if you just need to get a movie playing on your big screen TV connected to ATV3, such as if you have a little at home social event planned like a date or friends or family visiting, my wife was able to go into our library section, find the movie we wanted to watch, then play it locally on the Win7 machine for 30 seconds, and once displayed and playing on the Win7 machine, she would then click her mouse on the Airplay icon at the top of the screen which would result in a menu, asking where the Airplay should play, such as ATV3 or local computer.  She would then select ATV3, and we were then able to watch the movie with our friends and family visitors.  She is the not typically the technical type, but in this case, she did something very simple I doubt I ever would have thought of.  I thanked my wife immensely, since she saved the day.  I never would have thought of trying to get the movie to play from the upstairs Win7 computer and then switch it to the ATV3 using the Airplay icon within Itunes on the Win7 machine.  Long story short, this is a one shot wonder.  It gets the movie you want to play on your bigscreen TV up and running and most of the time it gets you through an entire movie, however, once a movie simply paused with infinite spinning circle of doing nothing, and I could not get the movie to resume but we were able to restart from beginning and fast-forward to where we were.  Also, this work-around does not let you play another movie from the ATV3, unless you repeat the whole procedure, since often when you try to play another movie directly from the ATV3 you will get the infinite spinning wheel of doing nothing or the notice to turn on home sharing on such and such account which is still on, but you go ahead and turn off homesharing, then turn it back in order to watch the next movie.  BUT THIS PROCEDURE DOES NOT SOLVE THE PROBLEM OF THE ATV3 AND ITUNES DROPPING THE HOMESHARING CONNECTION, IT SIMPLY LETS YOU WATCH ONE MOVIE AT A TIME . . . my solution to this main problem is below, but it has only been working for 36 hours. 


    I give my setup info in case it matters or helps anyone with similarly equipped hardware and network layout.  Here is my setup: 


    Itunes library on Time Capsule.  All connections for the purpose of this problem are hard-wired/ethernet.  I will use terms hard-wired and connected via ethernet interchangeably.  MY SETUP/SOLUTION INVOLVES NO WIRELESS PROBLEMS OR SOLUTIONS.  I am using a Windows 7 64-bit i7 machine running the latest Itunes (Ver11.0.1.12). Win7 machine is hardwired/using ethernet cable (FYI, all ethernet cables are Cat-6) to Time Capsule.  Time Capsule is in bridge mode.  ISP provided router is hard-wired (ethernet) to both Time Capsule and ATV3.  Time Capsule is hard-wired to router.  From the Time Capsule, I have hard-wired several devices such as a Roku box and two PS3's.  To get a further idea of the layouthardwired to ISP router in bedroom to 50" Panasonic Plasma using many nice Roku channels, but for purposes of this post, using mainly plex (ATV3 resides in living room hooked up to 58" Panasonic Plasma.


    After reading many, many posts in many different forums, I came across some info which I thought seemed easy enough to try and if it did not work, I could simply revert those settings to their previous configuration. Since I did a few things, I am not sure which one solved the problem, or if they were all needed to solve the problem, so I will simply tell you everything I did from the time of this problem becoming an ever-present nuisance, then becoming an absolute headache, to finally having the ATV3 work as I knew it could.


    One post explained that in their services list, accessed from control panel, then administrative tools, then services, that BonJour often was listed more than necessary, and that the Public vs Private (local network) checkboxes were checked as public.  It is strongly recommended to create a restore point for your computer prior to making any of these changes.  I am trying to find that post (within Apple community support, but at present cannot find it again, or perhaps I am thinking of the link to the post below).  I had three entries, as I recall two were checked as public, and one was marked as private, or something to that effect.  I deleted the two public instances of BonJour services, and left alone the one marked as private.  See this last post in the following link:



    The above link also references port 3689 suggested to be excluded (allowed) in anti-virus software.  This had me thinking about ports in both the windows firewall and any anti-virus firewall, which lead me to the next info-gram sent to us from Apple:



    After reading these posts and re-reading them and thinking that I could revert these firewall port exclusions in both Win7 and anti-virus software (I happen to use Avast) if this action did not solve the problem of homeshare dropping reported by ATV3.  Based on what little info I had, I allowed all local network traffic on the following ports:  123, 5353, 3689 . . . in both Win7 firewall and the Anti-virus firewall. In making the firewall port exclusions, the menu structure makes you select either TCP or UDP.  It would not let me choose both.  As I recall I made an exclusion rule one at a time, first one for TCP, then went through the process again, this time selecting UDP when creating the second port exclusion rule.


    I then re-booted only the Win7 machine.  Since then, my homeshare has remained connected, and ATV3 has not asked me to start homesharing when it is already started/running/connected.  Now when I start up the ATV3 everytime, a submenu is on the screen, offering two choices: computer or settings.  I choose computer, then immediately the ATV3 connects to the library on the network, and then two more choices are offered (in my case, as I only have photos and movies in my library).  I can choose either and both work, but finally having my movie library available again is like finding your lost wallet or car keys.  After so much frustration, it is really nice to have this work like it always should have.  Also, when you choose a library category such as movies or photos, thumbnailed folders or files immediately begin to appear.  Also, when select a particular movie for instance, the spinning wheel spins for a reasonable, but more importantly finite amount of time (10-40 seconds), which fades away pretty quickly as the beginning of your movie begins to triumphantly play.  I have turned the ATV3 off, switched between movies, paused movies then started others, allowed ATV3 to sleep, then awake, I have tried to trip it up every way I can think of, but the homesharing connection remains strongly connected.  I will let you know if it continues to work throughout the week,

  • Kennu Level 1 Level 1

    My homesharing to ATV2 keeps dropping out (and i have been using days/weeks trying to find out what causes this) my music streaming/home sharing and i discovered by fluke that when this happened the airplay icon on my iPhone disapeared. I didnt even use airplay to stream music to the ATV so why would this happen and how could this iPhone problem affect connection between itunes and ATV!?

    I did a fix for lost airplay icon on my phone ( htm) and on return of the airplay icon on the iPhone i could continue to play music on ATV through itunes homesharing.

    This problem with lost connection and parallell loss of airplay icon on iPhone seems to be conected somehow although i have not found permanent solution for....yet.

    At least i could have found some sort of possible problem and/or conflict between airplay and homesharing.

    Does any of you find the same problem/conflict/symptoms on your systems?

  • VapinJethro Level 1 Level 1

    azdaren, did you read my post right below yours?  Or anyone else, I am approaching 36-48 hours with my ATV3 homeshare symptoms/problems never re-appearing.  I am starting to think the steps I took, using information from several posts has solved the problem for me.  I would encourage anyone else out there to try it and see if they can get the problem to resurface.  I am using a Windows7 machine to simply control and run Itunes, while my media library resides on my Time Capsule.  It would help the community if some people could try and get my proposed solution to fail.  And if you can get it to fail, let me know how, since I can no longer get it to fail.  My homeshare connection is now stubborn and peristent.  After a few more days, at least for my configuration/hardware, I will have to consider my cobbled together solution from other posts to have solved the problem of ATV losing or dropping homeshare connection.  I would love to see what other people's experience with my proposed solution.  I do not mind if it succeeds or fails, I would simply like others to try the steps in my prior post and report back their results.  The more experiments we conduct, the more information we will have to lead us to a fix, if we do not already have one.  Again, I am using a Win7 machine so perhaps my solution only works for Win7 users, however, the slight configuration adjustments I made to me seem to be platform agnostic; in other words, we are evaluating and modifying incorrect "services" settings and making port exception rules for firewalls, in my case, the Win7 firewall and the Anti-Virus firewall.  I think I am on to something, but would like community evaluation/feedback.



  • Kennu Level 1 Level 1

    I have done your fixes VapinJethro and many more with no luck unfortunately, but thanks for sharing your ideas.


    Although i previously have tried setting static IP on ATV (with no luck) i repeated it ,and in addition this time i went into the routers setup also and set the static adress same there for the ATV.

    This seems to do the trick and i have no drop outs after this so far....fingers crossed

  • ArithonUK Level 1 Level 1

    Okay I am posting this on all four threads that describe this issue.




    • This is not a DHCP issue. Changing your router, network, DNS settings, re-installing iTunes, wearing a foil hat etc. won't fix it.
    • Repeated reboots of the ATV unit are a temporary fix, but the issue returns - usuallly after being on standby - because most of the proposed "fixes" involve a reboot at some stage, this gives the impression they've worked, but they have not.
    • Using a wired network connection removes the problem, so it is primarily a WiFi issue.
    • The last two firmware updates have made the problem worse. I have four ATV 3's and can confirm this, since they are all using the same iTunes and network but have three different firmware versions between them. Although the iOS "remote" App finds all the ATV's faster and more consistently since the last iTunes update (
    • All four Apple TV's are now all but unusable on WiFi.
    • The problem occurs in the first 60 seconds of playback. If you get past that point, in all but a few cases, the film or TV show then plays to the end.


    If this isn't a memory leak or similar bug in the network stack, then it is most likely a timeout issue with ATV DRM verify to iTunes. So WHY Apple haven't you admitted the problem and FIXED it?

  • Winston Churchill Level 10 Level 10
    Mac OS X

    Would you kindly explain why I am unable to replicate this problem on any of my Apple TV's.

  • claytona965 Level 1 Level 1

    Seriously.....Apple / Mac people...Geniuses....whatever, you need to sort this out. This dropping of network connection between iTunes and ATV needs to be address. this has been going on for at least a year and no its not a matter of latest software installed, nor distance from the wifi network, or file size being streamed.....its down to your shoddy software. If i could roll back the clock i'd have bought a different product, absolutly disgraceful in this technology day andf age!!!!!

  • old_town83 Level 1 Level 1

    Can I ask...


    Is it just "homesharing" or any form of streaming that is dropping out in your case.  mine developed streaming issues after about 2 weeks of operation (music and movies).  I methodically ruled everything else on my network out, by using other devices rather than the ATV3.  The ATV3 was the only one that had an issue with streaming - it was constantly stopping to buffer (memory leak???).  Only since I have unplugged the ATV3 for 30 sec. has it begun to work normally again.  It seems ATV3 needed to reboot in my case.

  • Sandancer Level 1 Level 1

    My homesharing started dropping out after i installed iTunes 11. I can stream from netflix and all other apps on my ATv2, but sream from my Mac no way. I can stream one song, then when the song is finished homesharing drops out and I have to reset the ATv2 again. this has to be repeated after every song takes ages to listen to an album. I Also have to reset ATv2 every time after waking from sleep mode. I can see all media files in the menus but when I try to stream I get a dialogue box which tells me there is a fault try again later.  

  • CP10934 Level 1 Level 1



    I had the same problem and went to Energy Saver under Preferences and updated my setting to the following.  It solved the problem but not sure it is what Apple would recommend.



  • CP10934 Level 1 Level 1

    Whoops.   Looks like my screenshot didn't take.


    Move the Computer Sleep all the way to the right and check Wake for Network Access.

  • Apple604 Level 1 Level 1

    My set up is a Dlink 825 router (hardware version B1), Win 7(64) and ATV Gen2.  All are hardwired, and software up to date.  I've had the ATV for about a year, and no problems - very happy.  During the past weekend though, I noted ATV was able to see network and computer (it displayed pictures from the computer as the ATV screensaver) but I could not access my music library.  Computer could Airplay to ATV; computer and ATV could be seen in the router list of LAN Computers.  After being frustrated by this subject and reading through this thread (and many others), I tried rolling back iTunes to 10.7 from 11; I rebooted everything many times, turned homeshare off/on on all devices, rebooted and reset ATV.  The best I was able to achieve with all these machinations was that ATV could start seeing the music library, but it would crap out after playing one song.  I then explored a hint provided a few pages back in this thread about ATV using multicast packets (IGMP).  I had recently upgraded the firmware on my router, and wondered if something might be up in that regard.  I checked the router settings, which had IPV6 Multicast Streams enabled, but not IPV4.  I enabled IPV4 Multicast Streams (in addition to IPV6) and that fixed the problem.  I'm a happy ATV owner once again.  Hopefully this helps someone.

  • bsherden Level 1 Level 1

    I too am so displeased with this situation and the apparent lack of concern by Apple to fix this  The device right now is almost useless.  I have been trying to work work not all that successfully with a Sr. Apple Support Advisior to restore back to 5.0,2.  Has anyone else done this sucessfully?

Previous 1 22 23 24 25 26 Next