Previous 1 25 26 27 28 29 30 Next 449 Replies Latest reply: Mar 18, 2015 9:44 AM by UKBrian Go to original post Branched to a new discussion.
  • siamless Level 1 (0 points)

    Actually the Mac should not disconnect any data stream when  "Wake for network access" is checked under Preferences->Energy Saver; if the Mac is asleep it should wake.

    This function does not seem work under 10.8.2.; there should be a fix in v. 8.3. - thanx to all guys like you who spent hours to do Apple's job.

    I am with you, Jerry.



  • ClarkDV Level 2 (175 points)

    When I first bought mine I just plugged it in and it worked, for 7 months. Your assertion that some of us lack common sense is BS. This is Apple, it IS supposed to "just work", and mine did, for 7 months. That proves that none of the extensive setup that you did to get yours working was needed, at least initially. So something changed along the way.


    BTW, I followed your suggestions and mine began to work perfectly. For 3 whole days. Now it's right back to where it was, disconnecting occasionally, requiring a restart of iTunes to make it work again.


    Your post to Siamless up there is dripping with condescension and sarcasm and even though he was too polite to call you on it, I'm not. Screw you. We all come here for help, and most people here gladly give that help, it's why we come back and monitor these discusions, even after we solve our problems, we return to help others. Why do you return? Just so you can feel superior to others who are still struggling with issues that you no longer have?


    Apple TV and Home Sharing is still broken for many of us and Apple needs to fix it.

  • spma3 Level 1 (20 points)

    Dripping with sarasm? Me?


    Sure...It's not "Maybe you'd be kind enough to share those settings with the rest of us seeing as how you've got it all figured out?"....or

    "Quite a "solution", I wonder why no one else thought of it...."


    Despite both your smart remarks, the response I gave WAS in a helpful manner. I was merely pointing out that there are people with IT knowledge and those that do not. Wow...I actually got a screw you. I'm hurt. You're right, there is no need to come here as you clearly stated, I have it figured out.

  • bvidc Level 1 (0 points)

    Exactly. The entire Apple MO is 'ease of use'

    My ATV is useless the second I leave home.

    My wife doesn't have the time to tech the ATV every half hour.

    It worked for six months and now it doesn't.

    My dad has a Roku that has never even glitched in TWO YEARS.

  • ClarkDV Level 2 (175 points)

    Your "It amazes me that people still post "me too" comments." preceded and elicited my sarcastic reply.


    Of course you could have been implying that it amazes you that Apple still hasn't resolved this issue. But after reading your subsequent posts about some of us not having common sense, etc., I surmised that you were, in fact, being sarcastic and superior. All the technical knowledge in the world is useless if you present it with attitude. It helps no one.

  • philfromsakai Level 1 (0 points)

    It's frustrating for some of us who have been monitoring this thread via email for more than six months, in the hope of some kind of salvation, to see the the same solutions proposed again and again after they have been shown not to work. Things like ensuring the computer doesn't sleep, or that "home sharing" is checked in iTunes were one of the first things to be tested.


    The core issue here is that many of us enjoyed months of trouble-free use before the connection problems arose. This suggests that the problem does not in face lie in network connections, router settings etc. To me this points to a firmware bug that has apparently affected only some ATV users.


    The soure of my own frustration is that Apple has not acknowledged that IDENTICAL problems exists with multiple users, experienced at the same time (after a firmware update), and has not done anything to help.


    Furthermore, it has the temerity to charge for customer support, then, to rub salt in the wounds, markets itself as a manufacturer of products that "just work".


    I read all the comments posted in this thread waiting in vain for that announcement "the new firmware update has fixed the problem".


    I find Apple arrogance astounding. If you didn't laugh, you'd cry.

  • ClarkDV Level 2 (175 points)

    I agree and understand. The only pass I can give to Apple on this is that they still refer to Apple TV as a "hobby". However, when they take my money for one it moves from a hobby to a product, and they should support it accordingly. If it truly IS just a hobby to Apple, then they should give them away instead of charging $99!


    Now, for my latest "hey this is working for me maybe it's a fix!" update.


    I remembered yesterday that I had an old Time Capsule in the back of my shop that a client brought in as dead a year ago. I pulled it out of the junk heap and repaired the dead power supply in it, removed the dead hard drive, and got it working just as a router again.


    I connected it to my network last night as a replacement router for my Netgear DIR-655. It's way too early for these results to be valid but for 3 hours last night, and again when I checked it this morning, it's all working perfectly. Last night I went and changed back all the settings that others have suggested as fixes here.


    On Apple TV I turned the screen saver back on, I set it to go to sleep after 15 minutes, and I set Network to Automatic (DHCP). I have my ATV connected via ethernet.


    On my Mac I set the hard drives to go to sleep in Energy Saver and left Wake for Ethernet network access set to "On".


    Again, it's way too soon to draw any conclusions, but I wanted any readers of these posts to know that I'm testing whether an Apple router will fix this.


    I'll report back in a day or two my findings. Fingers crossed!

  • Mini-Mac Level 3 (805 points)

    I've had a Apple TC connected from day one.  That's not the problem.


    I believe that the ATV and iTunes simply quit communicating after a given time.....I'm retired and have lots of time to test different ideas.  I've have all three ATV's (ATV 1, 2, and 3) and have been testing this theory in so many different ways for so long.


    The only theory that worked the best in my testing is to NEVER let the ATV or Mac sleep.....even this eventually requires to restart iTunes.


    So I gave up.  Period.  Apple TV is NOT a reliable player to watch your movies without constant monitoring and that's a FACT.



    My new solution is below....Simply because Apple refuses to address the issues that everyone is having and probably never will.  Why?  Because they don't CARE!



    1.  Purchased a Synology Disk Station DS112 $199.00

    2.  Purchased a 2TB Western Digital Green HDD. $119.00

    2.  Installed Video Station FREE from Synology

    3.  AirPlay using my iPad4 using Video Station App  FREE from Synology


    The only dray back is no Dolby Digital


    Works 100% of the time and video quality is the same as streaming from iTunes, and you can still use you ATV or iDevice remote to control (pause, FF, RR, etc.) the ATV.  Currently my video library is nearly 700 movies, home movies and funny videos saved over the years.....

  • ClarkDV Level 2 (175 points)

    Well that's disappointing to hear. I'll leave mine connected until it fails and report back my findings.


    If this configuration does fail my next attempt at a solution is to take an older Intel iMac home and use it to serve up my iTunes library to the Apple TV. It's still running OS X 10.6.8 and iTunes 10.


    I wish I knew what to look for in Console to see when communication drops between iTunes and Apple TV. That could shed some light on the issue.


    Is anyone here a Console log guru? I'd be willing to collect data if I knew what to collect.

  • pstrickland Level 1 (0 points)

    I have Airport Extreme, iMac, iPad, iPhone - EVERYTHING is Apple.


    I received my ATV for Christmas in 2010.   I absolutely loved it and used it for hours every day.   It worked perfectly without a hitch until that iTunes/ATV update at the end of 2011.


    Sometime last year (2012) there was an ATV update that fxed it.   But a few months later another update broke it and it hasn't worked since.


    I have tried all the suggestions in this forum that I understand how to do.  Many of them for for techies, and I am not one.  I am glad they work for many people but for whatever reason, but they don't work for everyone. 


    There is no question in my mind that it is an ATV firmware problem so I don't plan to waste any more time on it. It should not be necessary to be a techie to get it to work.  Maybe Apple thinks that most of their customers are techies, so let them figure it out.


    So at some point I will replace the ATC, possibly with a Roku, when I feel I have $199 to throw around.  I sure won't buy another ATV unless Apple annouces they are going to give it full support!!!  

  • ClarkDV Level 2 (175 points)

    If you make the jump to Roku you can get their top of the line model for $99, their lesser models go as low as $49.


    Then you can jump into Plex for media library server, it works pretty well.


    I have both an Apple TV 3 and a Roku 2 XS and I run Plex Media Server on my Mac and point it at the same folders that iTunes uses for my movies and TV shows.


    So when ATV is on the blink I switch to the Roku and use that.

  • ClarkDV Level 2 (175 points)

    Well that didn't last long. My switching out the Netgear router for an Apple Time Capsule worked well for 36 hours, but now it's back to not connecting to Home Sharing again, requiring a quit and relaunch of iTunes to get it back.


    Next I'll birng home the old Intel iMac with Snow Leopard and iTunes 10 and see how it works with the Apple TV.


    I'll post back when that test has been done.

  • Jerry Pank Level 1 (0 points)

    Just a thought Apple, but if any of these problems are related to networking/router/device set-up then it's an awful shame that the on-board network test does not spot them.

  • sanford_may Level 2 (395 points)

    This might not fix it but it did for me and don't jump off the roof in astonishment at yourself if it works -- you're not alone.  You have to turn Home Sharing on.  But it is on, you say.  Well, maybe.


    For the concise edition, just skip down and read the part in all caps.  Otherwise, read on.


    Problem: You only occassionally use Home Sharing on your Apple TV (ATV) but when you use Home Sharing it works a trick until one day you go to use it and it doesn't work.  Variables (things you did between the last time you used Home Sharing and it worked and now when it doesn't work): Upgraded your Mac or PC, reinstalling iTunes or restoring your system from a Time Machine backup (Mac) or other type of backup (Mac or PC); otherwise restored some or all of your system from backups; updated iTunes via Software Update or by manually downloading the new version and installing it; did something else you have no idea what it was and I don't know either.  UI inconsistency: iTunes 11 (and maybe 10, as well) Home Sharing preferences don't clearly and obviously reflect that Home Sharing is really TWO services -- a local network service you turn on in iTunes 11 in preferences in the Sharing section and an iTunes Store service authorized by your Apple ID that you must enable in iTunes 11 under the File menu at the Home Sharing item.


    If you're like me, you have Home Sharing turned on in iTunes preferences.  Prefs are set to share the whole library, no password, and status shows "on, no users connected."  So it's on, right?  Sort of.  The local iTunes network service is on but you still have to enable Home Sharing via the iTunes 11 File menu item (in previous version of iTunes that supported Home Sharing I think Home Sharing authorization was instead located in the Advanced settings in iTunes preferences or under the Store menu, possibly both places in different older versions of iTunes).


    I bought a 15-inch Retina MB Pro and restored my files from a Time Machine backup.  All my iTunes prefs came over, though I'm pretty sure I had to log back into the iTunes Store to authorize the new computer to my Apple ID.  If you just restore to your old computer and it's already authorized you probably SHOULD have to do that but you might not have do that, further complicating your impression of your iTunes Store Home Sharing status.  Whatever the case, I was signed into the iTunes Store but I never reenabled the iTunes Home Sharing service in the File menu.


    MAKE SURE YOU HAVE ENABLED HOME SHARING FROM THE FILE MENU IN ITUNES 11.  TURNING IT ON IN PREFERENCES IS NOT ENOUGH EVEN THOUGH PREFERENCES REPORTS IT'S ON.  "On" in prefs means your local library is shared from iTunes, it doesn't mean the iTunes Store authorized service is enabled for that iTunes library on that computer.  No, it's no very clear, but that's the way it is.


    A special note for MacBook users and any Mac users who regularly sleep their Macs on an all-Apple wifi network.  If you want your ATV -- or an iPhone or iPad or another Mac or PC, for that matter -- to be able to access your shared iTunes library even when your Mac is asleep, remember to turn on "Wake For Wi-Fi Network Access" on the Energy Saver panel in System Preferences.  Any Home Sharing device trying to hit your library will wake up your Mac so it can serve the iTunes library.  (This works in a wifi environment that fully supports Bonjour.  That's all recent Apple wifi gear and some 3rd party gear but I've no idea what 3rd party gear in particular nor do I know how to configure Bonjour-compatible 3rd party gear.  In an Apple-only wifi environment it works by default.)


    This feature is very handy and wonderfully Apple-ish convenient but it freaks out some MacBook users.  The lid's closed!  It'll fry!  Yeah, well, no it won't unless there's some other serious hardware failure going on too.  My 15-inch Retina MB Pro stays stone cold all the time, although some older MacBooks do get pretty hot sometimes for no apparent reason.  But, for starters, Apple has long time supported using MacBooks in "clamshell mode" while driving an external display.  That means fully powered AND driving some often whopping external displays, which takes a lot of graphics oomph.  For merely Home Sharing your iTunes library, it doesn't even turn the screen on -- not even if the lid is open in sleep mode -- and I doubt it powers the graphics card.  My external USB backup HDD spins up but spins right back down; it's only responding to the USB ports powering on.  Serving up an iTunes library over wifi off HDD or flash storage is a pretty low-power deal.  Remember, it's not PLAYING music or video on your MacBook; it's just streaming the files from your MacBook.  Sleeping, lid-closed MacBooks in enterprise environments constantly get hit in the middle of the night over wifi for system maintenance and updates.  Those can take 2 minutes or 2 hours and they're often a lot more processor-intensive than streaming an iTunes library.


    Oh and remember you can stream photos to your ATV the same way, but that's managed via iTunes, too, likewise in the File menu -- not in iPhoto where you may be looking for it.

  • whtsoxfn1 Level 1 (0 points)

    I had posted a while back regarding ATV3 losing its connection to the Home Share on a Win7 machine. To sum, at the time of my original post, I had noticed that if I go onto the Win7 machine and restart Bonjour Service in "Services", I am able to stream (even with the spinning wheel on screen). This all started after updating to v5.1.


    Update: I failed to mention in my original post that my ATV3 was connected to my network via WiFi. After contacting Apple Care without a successful resolution, I went ahead and connected the ATV3 via Ethernet (I have a Sonos player that has a built-in router/hub nearby). Since it has been connected via Ethernet, it has been working nearly flawlessly. When I mentioned this to the level 2 tech I was assigned to, he had mentioned that he had heard of changing the connection resolving the issue, and he'd get back to me with a solution to get it to work via WiFi. Several months later, I have not heard from Apple.


    After the latest updates (ATV & iTunes), I thought I'd play around with the WiFi connection. I still experience the same Home Share issues when connected via WiFi. I wish Apple would determine what change in code caused the issue and revert it back!