Previous 1 26 27 28 29 30 Next 449 Replies Latest reply: Mar 18, 2015 9:44 AM by UKBrian Go to original post Branched to a new discussion.
  • Mini-Mac Level 3 Level 3

    ClarkDV.......Are you using a NAS like Synology DS (which I currently have, and its fantastic) with your Roku?  What model Roku do you recommend?


    Thanks in advance!

  • VapinJethro Level 1 Level 1

    This probably ain't solving anything.  But yesterday I was wondering how the Apple TV or Itunes knows which instance of Itunes (and library) to use if you have multiple computers running Itunes each separate libraries, or at least its own library . . . I happen to have all my computers pointing to the same Itunes library which resides on a Time Capsule.  I had previously been using a Win7/64bit machine with Itunes, specifically, to interface with the ATV(3). I have a MBP w/Retina and thought which by the way has always had home sharing turned on in preferences and in the Itunes file menu.  But I thought let me use my laptop and see if the ATV could connect to it.  I gave the library on my MBP a goofy name to make sure I knew if the ATV was connecting to that library, and sure enough it did.  I did this since many people running pure Apple ecosystems keep talking about set your energy saver preferences to never sleep (stay awake), keep disks awake (SSD anyway), also I set wake up for network activity or whatever.  So I wanted these solutions even though they seem to kind of work or partially or temporarily work. But if anything helps to reduce the frequency of these headaches, I wanted to give it a try.  Of course, things are working this way temporarily, also if I close the cover to my laptop the movie stops and apparently the connection drops out also, but if I open the MBP cover the connection is immediately restored, but I have to dive into the library find the movie, and at least I can choose to resume it where it stopped.  Also, I tried playing the movie on the MBP itself within Itunes, which worked fine, then I clicked Airplay icon for mirroring, and the movie played fine that way as well. 


    My real question to you guys, I'm sure someone knows, is if there are multiple instances of machines running with home sharing on and operational, how does the ATV know which one to use?  My next test will be to get the Win7 machine connecting (however temporarily that may be) then open my MBP, then turn on the ATV.  Will it simply see two library's and let me pick one?  So far, I've only seen it show the Win7 library or the MBP library.  It is just something I was not sure of, and maybe this is an issue, maybe not.  I'm sure there are many of you who do have multiple instances of Itunes running simultaneously on different machines, and know how the ATV handles it. Just thought I'd drop another note into the void.  I will keep testing the MBP connection and wait for it to fail, experience has taught it likely will. 


    In the meantime, Roku, PS3s are working well with Plex, so this is just academic for me, but I'm perplexed why Apple would not look into this issue.  There are too many people having problems with this, to consider this a "It just works" product.  We should not need to keep running back to machines and turn on homesharing which is already on by turning it off then back on.  Even though Apple calls this a hobby, or something they are just dabbling with, it is still an embarrassment when they charged prices similar to or more than a roku box, "which actually just works."  I think they should send out $50 Itunes cards for these headaches we've had from this.  I could then accept that this is a hobby at half-price.  Further compounding, highlighting, and defining this product as being inferior and problematic is our wonderful experiences we have with all other Apple products.  If they were an average company, this box would be an average box, hobby or not, but what adds salt to the wound, is we all know what Apple is capable of, and they have fallen way short of that mark here.  It is an embarrassment which should be taken off the shelves or fixed, if they can fix it, because although maybe they can't fix it, they should definitely not ignore it.  I would prefer they just make a press release saying ATV products have a flaw which can not be fixed.  I would respect that more than them just wasting our time while we try and fix their problem.  There are many nice touches to the product, but when a fundamental issue does not work reliably, they should just tell us that. 


    There should be a response from Apple on this.  This experience is contrary to all my other experience with Apple.  I don't understand their approach to it, and from the silence already existing, maybe we never will.

  • ClarkDV Level 2 Level 2

    No, I just have a 1TB drive in my Mac and I point Plex Media Server at it. Works great AND plays MKV in addition to MP4/M4V, won't do AVI, though, I have to re-encode those, but AVIs are not that common anymore so that's good.


    I really like the new Roku 3 but the cheaper ones are fine too. I'd probably hold off, though, because the Roku 3 is faster than the other current models, so I bet the entire line is getting a refresh soon.

  • KB22 Level 1 Level 1

    I have found that my homesharing works when I use the apple tv on wifi but does not work at all over a wired connection.  Not really helpful for you, but maybe others will find it helpful. 


    Personally I'd love to get itunes match for movies (meaning movies I own on DVD) then I wouldn't need homesharing at all.  Movie studios will never go for that though, but one can dream. 

  • kevinterrono Level 1 Level 1

    i was able to fix this a month ago for my issues.  i currently have ethernet behind my tv in the living room and my cable modem in the basement.  i had an airport extreme upstairs with the apple tv plugged into the ae.  i had to perform daily reboots to fix airplay and seeing content on my computers downstairs.  I figured the problem was with the ae.  I moved the ae to the basement and put a simple dlink unmanaged switch for the living room and everything has worked perfectly since.  no more airplay drop outs and i can see my itunes content 100% of the time.  i have taken the ae out of the loop for the apple tv, so i assumed the problem was with the ae, not the apple tv software.

  • HuftonR Level 1 Level 1

    Well it's now been a week and a bit since I updated my router to an Airport Express and the ATV is working as it should. So for me this was the fix (to failed connections, can't find the library, resets/reboots etc).


    The only thing I can't get to work is automatcially waking the iMac (where my iTunes library is) from sleep (despite checking the wake on LAN), not a major issue as I've disabled auto sleep and just blank the screen after 5 mins.


    Anybody want to buy an Asus RT-N56U router (great bit of kit but just doesn't play nicely with Apple - or vice versa)?

  • Sandancer Level 1 Level 1

    I have have almost The same problem, with my ATV2. There has been a problem with homesharing since I updated to iTunes 11. Everything has been tried by the  Apple technicians communicating with me over the telephone. After over 20 hours  They eventually said that my network was too complicated, although everything else works DNLA streaming to television using my Synology Diskstation and a software server programme (Playback), AirPlay from iPad and iPhone ( AirPlay keeps dropping out and connecting again since I upgraded IOS 2 days ago) on all my devices. Netflix and YouTube stream perfect.

    I made my network as simple as possible Cisco modem from cable company connected directly to an AirPort Extreme with LAN cable. Ethernet cable from extreme to ATV2 and iMac. Simple system but when used with homesharing plays only one song then freezes

    Now Apple say it is maybe an incompatibility with my modem and router. I told them a hundred times before that the problem started with iTunes 11. I have now told them that I do not wish to continue with the fault finding, because everything seems to point to iTunes server.

    By the way my  ATV2 is 2 years old. I had the same problem when I upgraded to iTunes 10 in November 2011. I used my ATV2 as an expensive paperweight until iTunes 10.5 came along in February 2012 and homesharing worked again, and worked flawlessly until iTunes 11.

    King regards

  • benji01 Level 1 Level 1

    I have just had this same problem with my new ATV3.

    After trying all the usual and suggested trouble-shooting solutions I simply reset my PRAM on my iMac, everything is working perfectly again.


    How to reset your NVRAM / PRAM :


    I hope this helps someone, it's such a widespread issue!

  • newbiecyk Level 1 Level 1

    i'm using buffalo router and my iphone/ipad/itune always can't find the appletv unless i restart my router.


    today i tried to randomly change the setting of the router...and found that after i changed the following my iphone/ipad/itune can find the appletv without restart -


    Internet/LAN -> PPPoE -> Advanced Setting ->


    Connection Type: Continuous Connections

    Automatic Disconnection -> Disconnection time: 0 Minutes



    Security -> Firewall -> untick all the "enable"






    I tested it for a few times....disconnecting and try to connect again, it works


    but after i posted this doesn't work again .........................../_\

  • samk3nny Level 1 Level 1

    I think I have finally figured this out - at least for my situation.


    My network on the ATV was configured with a manual IP.  Setting this to automatic fixed the issue.  Will report back.

  • biancapaws Level 1 Level 1

    What worked for us is to configure our antivirus network intrusion settings to allow traffic from the static IP address assigned to the AppleTV!  YAY, 5 hrs later and a phone call with Apple Support!

  • scott.hitchman Level 1 Level 1

    Well, I am a little late to the Apple party.


    My recently acquired ATV3 plugged in and worked....for the playing of one song or one play of a movie. If I paused the movie and tried to resume play I simply got the spinning wheel of utter frustration.


    I've spent about two days reading through millions(! ...alright hundreds) of threads and posts, trying everything from IPv6 to bonjour service etc etc. ...until I found the infamous spma3's post about port forwarding (here).


    "What have I got to lose?" I thought, so dived right in and made the necessary changes, and so far so good (*touches wood*).


    The ATV3 has been to sleep and woken up to continue where we left off.


    It seems that Apple have added/changed some code requiring certain ports to be open in the latest updates that broke this for everyone.


    Heres my reply to spma3 with all my setup and a couple of pics for those with a similar router setup.

  • Loud Steve Level 1 Level 1



    I had many issues with my Apple TV not playing any more movies or tv after watching one. Apple TV would simply not play another show. I tried switching off firewalls and even ethernet cable all the way, no joy. Only restarting iTunes or Apple TV seemed to work.


    I think I fixed it, in iTunes I switched off "Sync playback information across devices" under Preferences - Store. After switching this off, Apple TV started working fine. Hope this helps someone, it helped me.

  • skidamarink Level 1 Level 1

    THANK YOU Loud Steve so very much for your post

    If not for your post we probably would still be scratching our heads or maybe even returning the device.

    Thanks for taking time to write it.

  • thaleb Level 1 Level 1

    I dont know whether this helps anyone - i am in spain with 3 ATV3s connected to a standalone Acer running Windows 7 64 bit and Itunes  All Itunes data is on a 4tb WDC drive and there are 24000 photos, 25000 tracks and 2900 films ranging from 1 minute to 4 hours (Dances with Wolves - yawn)


    I have no landline in this flat (it's Spain!) so i use a very nice Huwaei E589 MIFI with the fastest sim chip provider in the country (Tuenti).


    I recently changed the password on the mifi to stop guests logging on and preventing my totally 10 devices connecting (max allowed)  The problems of dropping the connection to Itunes happened straight after that.  Before that i never had them.  Obviously one would think the changing of a password on a mifi has nothing to do with this.  I diligently changed all the other devices passwords, ensured they all reconnected properly, turned EVERYTHING off and rebooted the whole lot.


    Everything works - eprinter, 5 Laptops, 3 ATV3s and connects to the internet fine


    But the ATV3s started to drop the connection and i got the usual bollux "Please turn on Home sharing etc" which always necessitated x-ing itunes and restarting.


    Here is what i tried without going into deep tech as suggested on very many of these helpful posts (DHCP, , Static IPs, PRAM and all that stuff - not my bag and i have no time)


    1) Itunes - turn home sharing off then on again and reboot the whole system to "refresh" everything

    2) Edit Preferences Sharing - uncheck "share my library overy my local network"

    3) Edit Preferences Store - uncheck "Sync playback information across devices"

    4) Control Panel - WIndows Firewall - turn it OFF - to **** with the consequences (after 26 years of messing with PCs i have never had anything but problems with Firewalls and tbh i dont see the point.  Oh and noone's hacked me either - 26 years.....

    5) Mifi - turn the firewall off - dunno what this does - but "like for like" in my mind

    6) Mifi - set channel to 1 NOT Auto.

    7) ATV3 - set time to sleep to NEVER

    8) ATV3 - dont send info to APPLE - why to bother if they do naff all with it?


    That's it - the thing has been up and running for 3 days solid with 3 films all being played on repeat on 3 ATV3s in diff rooms - we shall see after a week and i will report back with pos or neg result.


    Note - my other set up is in Switzerland and there i have NEVER had this problem with 3 ATV3s either. All the same kit and the same set up (WIN7, Acer, Itunes, 4TB drive with exact same media files) The modem there however is a Swisscom cable modem for TV, Phone and Internet (yes Switz does have telephone lines) and all i can suggest as to what went wrong is:-


    1) Firmware updates - Apple did not heed those old adages "If it aint broken dont fix it", and "Bullet proof everything before you go live and take our 100 bucks" (i made that up)

    2) Dodgy signals in wifi modems being interfered with by other kit close by... bit vague sorry but i could not be bothered to test the positioning of the Huwaei around the flat

    3) Itunes updates - do we go back to 10 or stick with 11 and beyond? Who knows? certainly not apple



    In truth i was ready to take 5 "paperweights" back without receipts or original boxes AND their relative HDMI cables for a 600 buck refund but i cant be bothered if it works on and off.  When i grow up and have more money, i am going to go Roku - sod Apple


    Thanks for listening.