7 Replies Latest reply: Jun 30, 2012 2:04 PM by mixx80
omunique2u Level 1 (0 points)
I've been receiving e-mails with few to no problems since I got my phone 2 years ago. Suddenly, I keep getting the error "The user name or password for 'apple.imap.mail.yahoo.com' is incorrect." I've tried deleting the account and re-entering the credentials, reset my phone, powered off the phone, cleared cookies, cache, etc. from Safari, even changed my passwords. I've read the forums and the responses there-in, but there doesn't seem to be a true solution to this problem. Anyone have a clue how to get around this?

iPhone 3GS, iOS 4
  • Freddtheman Level 1 (0 points)
    I have no solution, but the same problem with my exchange smb server where I've put up some Imap accounts for a couple of people to share.

    My leads this far is that this situation comes up when you have to many people/clients at the same time to one Imap account. If it happens, the account is broken as you describe and I can't get it to work again.

    This far I've had to create new accounts as a workaround, donnow if its the server och Mac Mail that causing this problem.
  • Jbuck49 Level 1 (0 points)

    I have the same problom but on my ipod touch. Did you ever find a solution? If so would you please share.

  • jacktoke295 Level 1 (0 points)

    I have the same problem on my mac pro

  • ED3K Level 4 (1,765 points)

    Go to <Settings, <Mail and then retype your e-mail and password in CAREFULLY and make sure its all correct. Alot of the times its a matter of turning the phone off and on again.

     

    If that doesn't work completely delete the yahoo email account from the mail settings and re-add it.

  • JaxBuckeye Level 1 (0 points)

    I have the EXACT same problem as Omunique2u - 2 years no problems, now all a sudden I get the same error message.  I've tried deleting the account, resetting it, turning the phone off, restoring to factory settings.  I had feeling it's a Yahoo issue, so I contacted them and they had me input a new Outgoing SMTP (smtp.mail.yahoo.com) mail server as an alternate.  It fixed the problem last night, now today it doesn't work.  Just a few minutes ago it started working.   Has anyone else found a solution? 

  • mixx80 Level 1 (0 points)

    Today I went Yahoo's site from my iphone browser clicked on mail and I was able to log on and retrieve my mail.Then I went out to the mail icon to see if I could get on there and boom... It all came back ! I don't know if that was the fix or not and we will see how long that this last . Hope this helps .

  • mixx80 Level 1 (0 points)

    I went Yahoo's site from my iphone browser clicked on mail and I was able to log on and retrieve my mail.Then I went out to the mail icon to see if I could get on there and boom... It all came back ! I don't know if that was the fix or not and we will see how long that this last . Hope this helps .