7 Replies Latest reply: Apr 9, 2011 4:40 PM by Greg Shehan
Greg Shehan Level 1 Level 1 (15 points)
I did some searching and didn't see the exact problem I'm having with my Spotlight. I click on Spotlight, I start typing what I'm searching for and everything from the bluetooth icon to the spotlight icon disappears for a few seconds. I am unable to access the dock for a few seconds after this occurs also. When I click Spotlight again, it is just waiting for me to type in a search again, like I never started a search at all.

I have rebuilt the spotlight index and I still get the same result. I've also tried each of the options on this link: http://osxdaily.com/2007/02/15/spotlight-wont-work-fix-a-broken-spotlight-menu-w ith-these-troubleshooting-tips/

Does anybody have any other suggestions?

Macbook 6.1, Mac OS X (10.6.7)
  • Pete Corelio Level 1 Level 1 (105 points)
    Doesn't sound a problem with spotlight exactly, but the UI in the menubar. Try a reboot in safe mode to run background maintenance tasks: Restart and hold the Shift key right after the startup chime and release it after you see a gray progress bar. After a long startup, try again (in safe mode,) then restart again normally to get out of safe mode.
  • Greg Shehan Level 1 Level 1 (15 points)
    Thanks for your reply Pete,

    I just tried the long boot in safe mode like you suggested. I tried spotlight once that was done. It did not act the same as it had been, but it was still not acting right. It didn't seem to be searching for what I was typing. Then I rebooted the normal way and tried again and it was acting as it had been. Still not working.
  • leroydouglas Level 6 Level 6 (14,805 points)
    Could be a corrupt plist. Try moving to the desktop the com.apple.systemuiserver.plist found here user/Library/Preferences/com.apple.systemuiserver.plist

    Restart and see if this solves your problem or use terminal and copy and paste

    killall SystemUIServer


    This rebuilds plist, if resolved you can trash the plist on desktop or return if no difference.
  • Greg Shehan Level 1 Level 1 (15 points)
    thanks leroydouglas,

    I looked for that plist file and found many other plist files for other apps, but did not see the systemuiserver.plist one. I tried to do the terminal command to kill it then restarted. I'm still having the issue.

    Your reply makes me wonder if my lack of systemuiserver.plist in that path could be my issue?
  • Pete Corelio Level 1 Level 1 (105 points)
    The plist should get recreated automatically. Create a new user account and see if the problem exists there.
  • Greg Shehan Level 1 Level 1 (15 points)
    I may just attempt a clean install. I just bought this macbook last week off Craigslist. The guy did wipe the hard drive, but didn't do a clean install. So, I'll do that and report back. Thanks for your help all!
  • Greg Shehan Level 1 Level 1 (15 points)
    that seems to have solved my problem. I'm glad I did it. Nothing like a fresh mac.