1 2 Previous Next 15 Replies Latest reply: Jul 18, 2013 3:35 PM by Jack E. Tilley
Joseph Grcar Level 1 Level 1 (0 points)
I am running 10.5.8 on a Mac mini and I want to connect to the parallel port of my old Laserwriter select 360. There seem to be a multitude of USB to parallel port cables. Which one, if any, should work?

Mac mini, Mac OS X (10.5.8)
  • 1. Re: USB to Parallel Cable for LW Select 360?
    myaka Level 4 Level 4 (2,450 points)
    Asante and Farallon made serial to ethernet adapters that will work with this printer. You'd have to find one on eBay, likely. So long as you can make Appletalk active in Network prefs (which means, I believe, that you can't move beyond 10.5.8), such a device should work.
  • 2. Re: USB to Parallel Cable for LW Select 360?
    Appaloosa mac man Level 5 Level 5 (4,325 points)
    Joseph,

    Have you checked out other threads like these to see how other users have adapted the Select to OS X?

    http://discussions.apple.com/click.jspa?searchID=-1&messageID=13324110

    http://discussions.apple.com/thread.jspa?messageID=12060195

    Be sure and follow the links to get the full story on adapters and software.

    Jim~
  • 3. Re: USB to Parallel Cable for LW Select 360?
    Joseph Grcar Level 1 Level 1 (0 points)
    Dear myaka, Thank you for your comments. I had been running the LWS360 off an Assante bridge for some time, but the connection eventually failed. The printer writes pages that are blank except for a pattern of vertical and horizontal grey lines spaced about 1 inch apart. So I thought to try a different port.
  • 4. Re: USB to Parallel Cable for LW Select 360?
    John Galt Level 8 Level 8 (36,380 points)
    This cable will work. No need to peruse eBay.

    No need for AppleTalk either, so it ought to work with Leopard / SL. I just tried it with my 10.4.11 iMac. The printer shows up as "ATEN UC-1284B Printer Cable". Select LaserWriter Select 360 as its driver and you're done.

    You can even connect it to an AirPort Express and thus share the printer "wirelessly".

    Enjoy
  • 5. Re: USB to Parallel Cable for LW Select 360?
    John Galt Level 8 Level 8 (36,380 points)
    Joseph Grcar wrote:
    ... I had been running the LWS360 off an Assante bridge for some time, but the connection eventually failed. The printer writes pages that are blank except for a pattern of vertical and horizontal grey lines spaced about 1 inch apart. So I thought to try a different port.


    I wouldn't think the Asante would be the cause of that. It sounds like a printer problem. Unfortunately there's no way to be certain without trying something else - either an Appletalk printer known to operate, an AsanteTalk bridge known to operate, or the USB adapter I described.

    Are you familiar with Terminal? What happens when you type "atlookup" (without the quotes of course)?

    You can also look for a print server with a parallel port, but one of them is likely to be harder to find and more expensive than the IOGear.
  • 6. Re: USB to Parallel Cable for LW Select 360?
    nancyfromdanville Level 1 Level 1 (0 points)

    Hello, I have LW 360 I want to use with my xp enabled hp pavillion but have never found the correct cables.  It seems to me your answer was directed at someone using a mac and I have a pc.  could you or someone else tell me what to use?  Thanks.  I have been un able to use pm LW for 6 years and dont want to toss it.  It is better than the garbage they have today.

  • 7. Re: USB to Parallel Cable for LW Select 360?
    Appaloosa mac man Level 5 Level 5 (4,325 points)

    Nancy,

     

    Please post your question as a new topic so it will get more attention.

     

    Jim

  • 8. Re: USB to Parallel Cable for LW Select 360?
    Loroi Level 1 Level 1 (0 points)

    Can you please clarify the settings you used?  I've gone through just about every permutation and I'm not getting proper communication (I think the problem is between the Airport Express and the printer).  Did you set up as an IPP or LPD and did you need to monkey with the switch on the back of the printer itself?

     

    Thanks in advance,

     

    Lori

  • 9. Re: USB to Parallel Cable for LW Select 360?
    John Galt Level 8 Level 8 (36,380 points)

    Lori, as I recall it simply worked. I didn't do anything special. The printer appeared in Print & Scan as "ATEN UC-1284B Printer Cable". I do not believe it was necessary to select LPD or Internet Printing Protocol; Print & Scan just configured it automatically. I selected the proper driver and that was that. I confirmed it worked with both Tiger and Snow Leopard.

     

    I can check this again but it will be a couple of days since I'm away from that computer. Until then would you please confirm

     

    • you are using a LaserWriter Select 360
    • you are using the IOGear USB to parallel cable in the link above
    • you are using an Express running the latest firmware (7.6.1)
    • your model computer and the OS it's running

     

    Thanks.

  • 10. Re: USB to Parallel Cable for LW Select 360?
    Loroi Level 1 Level 1 (0 points)

    John,

     

    It works exactly as you describe if I directly connect the printer to the iMac (21.5 inch, Mid 2011, Lion 10.7.3), but  that doesn't give me a network printer.  When I reconfigure via the USB port on the Express (yes, latest firmware update as of 2/9/12), I cannot set it up via the Printers button in Airport utility (it says no printers are connected), and for obvious reasons, it says the existing printer I setup in the direct connect scenario is "not connected" and thus not available.

     

    Curiously, when I set up via direct connect, I got TWO printers added, one with the word "Cable" and one without.

     

    I also played around with trying this from a 10.4 G5 tower, since the Printer button in the Lion version of Airport Utility is gone.

     

    I suppose there is a possiblity that the USB port on the Express is not functional.  I do have other Airports I can test against and will attempt to eliminate that variable.

  • 11. Re: USB to Parallel Cable for LW Select 360?
    John Galt Level 8 Level 8 (36,380 points)

    OK, in that case I hope the firmware upgrade didn't break things!

     

    I will verify my settings but it will be at least a couple of days before I have the time. Just to be clear, the IOGear / Express connection worked with three different parallel printers (Apple, Epson, and HP) but I am nearly certain it will not work with an "all-in-one" or multifunction printer.

     

    In the meantime if you upgraded AirPort Utility to 6.0 be sure to download version 5.6 as well:

     

    http://support.apple.com/kb/DL1482

     

    AU 6.0 looks pretty but omits a lot of features. 5.6 is a more appropriate "upgrade" to its predecessor 5.5.3.

  • 12. Re: USB to Parallel Cable for LW Select 360?
    John Galt Level 8 Level 8 (36,380 points)

    OK loroi, I set up the printer again to make sure I didn't leave anything out. To summarize, everything works except with the LaserWriter Pro 360 connected to the Express.

     


     

    First here is what I saw after connecting the IOGear cable to the Express, and a similar vintage HP printer. In short, AirPort Utility found it and filled in everything on its own:

     

    Iogear Airport Express.png

     

    The above is running OS X 10.4.11 and AirPort Utility 5.4.2 but the picture is similar with Lion and 5.5.3 respectively:

     

    Screen Shot 2012-02-13 at 5.36.27 PM.png

     

    Adding the printer in Print & Fax (what later OS X versions call Print & Scan) looks like this:

     

    Screen Shot 2012-02-13 at 4.43.54 PM.png

     

    It simply shows up as the correct printer. No sweat.

     

    Next I tried this with Lion, this time directly connecting the LaserWriter to the iMac. It shows up as "ATEN UC-1248B Printer Cable" which of course you can rename anything you like. The only caveat was that I had to select the LaserWriter Select Pro 360 driver next to "Print Using" as it did not automatically identify the printer:

    Screen Shot 2012-02-13 at 5.10.28 PM.png

    Again, no sweat and it works just fine. I printed a test page and everything is OK.

     

    Next, I tried the above but with the LaserWriter connected with the IOGear cable going to the Express. Using AirPort Utility 5.5.3. No matter what I did I could not make the LaserWriter appear. This may be related to the fact that I had to manually select the driver in the "Add Printer - Print Using" dialog box above, whereas it filled in the HP LaserJet 4MP driver automatically.

     

    It's odd that the HP shows up so effortlessly any way I connect it, but I can only get the LaserWriter Pro 360 to install on the iMac if it's directly connected to it. If I try Express / IOGear USB adapter - connected wireless route, it does not appear in AirPort Utility.

     

    So, I'm stumped. I can't think of anything else to do. The good news is that your Express is probably OK.

     

    Don't despair, since I know you can use a parallel print server and it works with Tiger, Snow Leopard and Lion. A print server will make your LaserWriter Select available on your network - that is what I'm using these days. There are many parallel print servers available, wired and wireless, cheap and abundant on eBay.

  • 13. Re: USB to Parallel Cable for LW Select 360?
    Loroi Level 1 Level 1 (0 points)

    John,

     

    Thanks for taking the time to troubleshoot this problem.  On the one hand, I'm gratified to know I'm not a complete idiot for not being able to make this work!  On the other, I wish I had overlooked something obvious that you would uncover.  My results are the same as yours, except that I didn't manage to get my 10.4.11 machine to see it via the Express, either.  I did rest against another AE unit and that didn't work, either, so I'm pretty sure that there's nothing wrong with the USB port.  I had even thought ofconnecting a hard drive to it as a final test to see if the AE unit would set up a network drive properly, but that's kind of a moot point now.

     

    I've been using this 360 on my network via an EtherPrint adapter for many, many years and that worked just fine until support for Appletalk was dropped.  So, what I have going now is a print server on my G5 machine running 10.4.11.  This works great except when the machine goes to sleep after x idle minutes and "wake on network request" doesn't work in 10.4.x.  While it's not a problem for me personally, my husband can't wrap his head around having to not only turn the printer on, but also go wake up the machine.  He's not a computer kind of person, so none of this makes any sense to him.

     

    Do you happen to know at what OS revision "wake on network request" was fixed?  If it works in Leopard, I'd be happy to upgrade this G5.  I seems to be functional in Lion - I can attach from my iMac to another one that is sleeping and get files, share the screen, etc.  The same cannot be said for attemtping to get a response from a 10.3 or 10.4 machine.  So, somewhere inbetween 10.4 and 10.7, engineering did something about the RADAR ticket I opened for my developer back in 2003 (I used to work in developer relations; left in 2004).

     

    Lori

  • 14. Re: USB to Parallel Cable for LW Select 360?
    John Galt Level 8 Level 8 (36,380 points)

    Hi Lori,

     

    Appletalk's demise caused me some anguish as well. I manage to cope by using dedicated print servers, something like this one: TRENDnet 1-Port Parallel Print Server TE100-P1P. That is not the one I have - I bought D-Link but the Trendnet ought to work. It's fairly inexpensive. They make a wireless version but it costs twice as much. The D-Link models are discontinued but there are plenty of other options.

     

    A print server like that will free your computer from having to act as one, and your perfectly good LaserWriter will be available on your network all the time. Without Appletalk, you will lose minor features like having the printer tell you when it's out of paper, and you won't be able to access its internal settings, but those are small inconveniences for having it work without your husband having to turn on a computer when he needs to print. I can't blame him.

     

    "Wake on network access" never worked at all with Tiger. It was completely worthless. Fortunately it works perfectly with Lion. Unfortunately I don't have any Leopard machines any more, but I will test it in Snow Leopard and let you know.

     

    Glad to help, sorry I wasn't able to get the Express / LaserWriter solution working though. Strange that Express / HP works, and Express / Apple doesn't.

1 2 Previous Next