Previous 1 2 3 Next 33 Replies Latest reply: Sep 8, 2015 11:17 PM by hsn10 Go to original post
  • Kirby Krieger Level 6 (12,510 points)
    I agree with all you've said. But we've narrowed down the source of the problem.

    What camera?
    What settings?

    Is the firmware up-to-date?

    Does this happen to all JPGs from this camera? What is different about these JPGs? (Are they part of JPG+RAW pair? Do they include any unusual in-camera processing? Etc.?)
  • macorin Level 1 (30 points)

    There is nothing special going on here. The firmware is up to date, and if it weren't, then all of the images would be showing the problem. They are not part of RAW/JPEG pairs. They are only JPEGs. No unusual in-camera processing is going on here. Again, if it were then all of the images would be showing the issue.

    The images in question were shot with a Canon Rebel XSi and also with a Sony DSC-T50. I am not noticing cross differences, meaning that I do not have images from both cameras in the same project where only one or the other is showing the problem. The questioned images are each part of a group that was shot with only one of the cameras, and only some of those images are not showing the previews.

    Nothing was done to the images as I recall (aside from simple edits, i.e. crops, white balance, brushes, etc). The images were shot in 2007 and 2008, so we aren't talking about newly imported images here. Certainly, a corruption to the thumbnail preview could have taken place at some point along the way (I'm just not sure where nor how).

    The question now is: Can I fix it? Can I somehow get those previews to show without doing what you last suggested? I really don't see why they wouldn't and/or shouldn't show. You don't think regenerating the Preview or Generating Thumbnail in Aperture would do anything? I mean, I tried it and it doesn't do anything.

    Obviously the preview image is there. It does show in the Preview column. It just doesn't show in the column before that (or in icon, list or cover flow).

  • Kirby Krieger Level 6 (12,510 points)
    Mac -- I'm getting confused (again) reading your response. As far as I know -- and Frank has stated the same thing -- Finder and Aperture (totally different applications) don't share any privileged information. The Finder preview, shown in the Info pane and in some Finder browser views, has nothing at all to do with the Previews in Aperture. Your problem is +"JPEG previews not showing in Finder".+

    I'm sorry that we seem to be talking past each other. Sometimes the limitations of typing to communicate become too apparent.

    Aside from all that, there is also the question of why seeing Finder thumbnails of images already imported into Aperture is important to you. Obviously it is -- but if you have the enormously better image management tools of Aperture available, why worry about the clunky tools Finder provides (or doesn't)?
  • Kirby Krieger Level 6 (12,510 points)
    OK -- one other thing to try occurred to me. You might move/delete/rename the hidden file ".DS_Store" from the folders where you are having problems. You can show hidden files using Finder's search and adding the "File Visibility" filter. Then reboot, or Force Quit Finder.

    I don't know what additional repercussions this might have, so proceed at your own risk. (I don't think there is any -- but no guaranties.)

    Message was edited by: Kirby Krieger
  • macorin Level 1 (30 points)

    For now I am just going to wait and see. I posted to another forum in the hopes of gaining some good information. I will post back when (if) I hear.

    In the meantime, I am not going to lose any sleep over this slight (yet annoying) anomaly. As you mentioned, the images are viewable in Aperture. This are my Master images in their relocated location. I really don't ever need to view them in the finder. There are times when I will export image versions and view those in the Finder, but I don't seem to have the issue with an exported version of the Master, so no worries there.

    Still, when something isn't right (and not being able to view the preview isn't right), I like to get to the bottom of it, no matter how inconsequential. It seems to me that some corruption took place at some point, so it might be impossible to pinpoint, or even fix. As I mentioned, if it can be fixed I will seek out that solution just for my own knowledge and peace of mind. If it can't, so be it.

  • Neatboy Level 1 (0 points)

    I have had this problem before, so annoying.


    I just opened Terminal and then typed:


    killall Finder


    After you press return it shuts down Finder and then you just restart it. Should work?...

  • jaydobro Level 1 (0 points)

    I had a very similiar issue, but my problem was that many .eps files did not generate previews instead of your issue with .jpg images.  I tried all of the above solutions and nothing worked.  I even opened the files in Illustrator and resaved while ensuring the generate thumbnail option was checked.  This did not work either.  After some additional research, I found a reference to a Quicklook folder (library > Quicklook) where there is a list of Quicklook plugins.  In this folder I only found a plug in for iWork files.  This seems odd since preview seems to work for just about every file type except .eps, but the only program specific plug in listed was iWork.  So I looked for a plug in for QL that would preview eps files.  I found "EPSQuickLookPlugIn".  I installed the plug in which sort of worked.  It generated a preview, but the image would show up in the bottom left hand corner of a preview with a lot of extra white space.  Looked like an image in the bottom 2" corner of an 8.5"x11" document.  This wasn't really ideal either, so I deleted the plugin from the Quicklook folder.  And POOF! All .eps files were generating previews again and in the correct dimentions with no extra white space.  I don't know what installing and deleting the QL plug in did, but it worked like a charm. 

  • trentfromsa Level 1 (0 points)

    My thumbnails on all files were not showing a preview in thumbnail form.

    I used disk utility and verified permissions and repaired permissions on my HD.

    Once done I restarted and boom, fixed the issue.


    I was also having performance issues with finder running slow and taking it's time showing files etc.

    Seems to have fixed this too.



  • kabana0 Level 1 (0 points)

    I've had this happen and relaunched Finder. Not sure you have the same problem, but all my thumbnails returned. Easy to try.. Press command/Option/esc keys to open the Force Quit Applications window. Highlight Finder and hit relaunch.

  • ziggy1903 Level 1 (0 points)


    I see this is a problem from 2012 and for Aperture, but I was searching about how thumbails in my folders for my JPEG images have turned generic... I am on an iMac 27" 2.7GHz Intel Core I5 = 12GB RAM = Lion 10.7.5

    The problem was after I did some editing with Adobe Bridge CS6 - speficially when I did a batch rename of the images.

    The thumbnail and preview still show up fine in the Bridge program, but when I open the folder in the Finder, they show as generic. What is worse, is that not every file was affected. If it was a consistant issue, I am sure it would be easier to fix. So only some of the files have the generic icon now. All of the fixes above do not work...

    As for opening images and saving them again, a huge HUGE frustration with the new OS is that they took away the 'save as' feature in Preview... so I have to first duplicate the file, then hit save, which then will not save back to the original folder... so unless I make up some Automater script, that will be a huge pain.



  • ladyruth54 Level 1 (0 points)

    I'm not a technical person so I don't even know what some of the responses you got already mean.  However, I had the same problem you had and I was able to fix it.  Luckily, it was only three or four pictures.  I opened them up in preview, clicked on File, Duplicate, and then renamed the photo and changed the setting to "Best."  I then moved the original photo to the trash can and all of my pictures now show a thumbnail picture.  But seeing as how this thread is more than two years old, hopefully you found a solution already.

  • McHartsa Level 1 (0 points)



    I had also the same problem, "anomaly" that about half of the thumbnails in Finder were missing. There were standard JPG icons instead. As Kirby mentioned, the hidden ".DS_Store" file could cause the problem. So I checked the folder and found that the "anomaly" folder did not had the ".DS_Store" file at all, while other folders had this file. But then I copied the whole folder to my Desktop and voila, all the thumbnails of the copied folder were there. Then I replaced the original folder with the copied folder and problem was solved. But still the ".DS_Store" file was missing from this newly created copy folder.


    It seems the problem is related how you copy the files to the folder. I copied the files from several separate folders. So when I added new pictures to the folder, the thumbnails of added files were not created automatically. But when copying the whole folder to the Desktop, all the thumbnails were created to the new folder. Hopefully this is helpful.




  • FlyBajan Level 1 (0 points)

    Why is this so hard to figure solve? First off, a good suggestion when trying to describe a problem like this would be to include a screenshot as I did here. This will save a lot of back and forth. I have been having this problem on and off for more than a decade! It is super frustrating and should not occur. This can really put a halt to productivity. For instance, just this morning I was trying to sort though my different exposures of an HDR shoot. But how can I do this if I can't even see some of the images??!!! (see screenshot) Stop ******* around and lets find out why this is happening.thumbnails not showing.jpg

  • TooFastTim Level 1 (0 points)

    The solution is quite simple, though Mac's tend to not leave any hints on what exactly you are supposed to do. Simply open the image that you are trying to make the icon in Preview. Then drag a box around the image. Hit command C. Then open the file in which you are trying to change the icon in Finder. Hit command I or click "get info". Click the icon in the top left corner, and then press command V. Simple as that.

  • FlyBajan Level 1 (0 points)

    Sorry, your post has nothing to do with the problem here. Thanks anyway. When you open a folder with 237 or so images, and you can't see the thumbnails (and by this I mean you cannot identify the images) this is a big problem. Your suggestion is good for the one off task of changing the appearance of a folder. Do you see the screenshot I posted above? This is a daily occurrence. Many times, not even one image thumbnail will show. My only solution is to open every image, resize, and save a copy as a JPG. I use a Photoshop action that I made. This could take over an hour depending on the amount. I then place these JPGs in the same folder. Now these thumbnails will show. This has been a huge pain in the *** for a long time now.

          Someone....   Help.