Previous 1 2 Next 15 Replies Latest reply: Apr 12, 2011 2:45 PM by Ralph Johns (UK)
David the Canadian Level 1 Level 1 (20 points)
Okay in iChat and Facetime with my internal mic selected as sound input I have no sound input in chats. While in garageband, system preferences, skype and google talk I do have audio input. Can someone please help solve this problem with iChat?

Message was edited by: David the Canadian

24 Inch iMac, Mac OS X (10.4.8)
  • Ralph Johns (UK) Level 9 Level 9 (69,420 points)
    Hi,

    Can I check you have these settings ?

    1) System Preferences > Sound > Input tab
    The Mic should be the selected item
    The Volume slider should be far enough to the right to get the Blue bar to about 3/4s when you talk.
    If it gets all the way to the right the OS software will "cut" the audio to "Protect" the audio side of things.

    2) iChat > Preferences > Audio/Video section
    This should have the same Mic Selected in the Microphone Drop Down.
    If System Preferences only had one item you will not get the drop down (those with Line In only such as Mac Minis)

    3) In the Menu to the right of the Buddies one.
    This is normally called Video but can be called Audio (it changes if you don't have a camera Plugged in on some models)
    This should have the Microphone Enabled item ticked.
    Selecting the Item toggles the tick and the Mic On or Off depending on current setting.

    NOTE:
    Input is the sound that your Buddy gets to hear
    Output is the result of what your Buddy sends you.
    iChat does not do Play-through so that you hear your own Input/voice.



    9:55 PM Monday; April 11, 2011

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • David the Canadian Level 1 Level 1 (20 points)
    Yep that all checks out. I've tested video chat with another mac, so I know the mic doesn't work.
  • Ralph Johns (UK) Level 9 Level 9 (69,420 points)
    Hi,

    So in System Preferences you can see the blue bar move and the corresponding Green Bar in the iChat Video Preferences also moves ?

    Does the Buddy (If using iChat) show any incoming Audio Signal from you ?
    They will need to go to the Connection Doctor (Video Menu) and look that the Stats tab.

    Ideally this should be green and at 100%

    Is it different in Audio Only chats ?

    In iChat > Preferences > Alerts
    Change the top drop down to Video Invitation
    Is the AppleScript option now ticked ?
    If it is, is there any Apple Script List and does that do anything to the Volume ?
    (I have one but it increase the Master volume (output) which I normally keep low)

    Any Further replies from me will be delayed by sleep and other things (about 16 hours or so - it does not mean I have forgotten you)



    10:39 PM Monday; April 11, 2011

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • David the Canadian Level 1 Level 1 (20 points)
    Hey sorry I had some problems with AppleIDs (I had two with one email), anyways this is my new account.

    There's no activity in the volume indicator in the iChat system preferences or during audio only chats. Connection doctor shows 100% and a green bar for both machines. I know the one receiving computer works because I have received audio and video successfully from other people in iChat. There are no AppleScripts selected on both machines.
  • Ralph Johns (UK) Level 9 Level 9 (69,420 points)
    Hi,

    I am not sure we are on the same page

    I am not sure if you cannot hear your Buddy or if they cannot hear you.

    If this Green bar pointed to by the Orange Arrow in this pic mean you are getting nothing from System Preferences > Sound > Input tab or the Mic Is Off.
    Audio/Video

    You will not hear this at your end during a chat (Or in fact visiting this Preview)

    Your Buddy's incoming Audio and Video is seen in these two green bars
    Picture 5
    It is this that you will hear from iChat (IF the Output drop down (if it shows) matches System Preferences > Sound > Output tab choice.) if your Buddy is talking. (Green bar means Audio In getting to you. It does not mean there is anything in the Audio as they may have Mute On)

    If it is you that is not hearing things check the following:-
    1) System Preferences > Sound > Output and iChat > Preferences > Video Section > Output Drop down has the same Output sound devices selected.

    2) If you can not see the Green bar move at the Orange Arrow point (first Pic) then you need to check your settings again.

    3) If 1) checks out and you are not getting a green bar in the Connection Doctor for Audio the problem is at the other end.



    7:27 PM Tuesday; April 12, 2011

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • David the Canadian Level 1 Level 1 (20 points)
    Hi,
    Okay essentially my mic work works for everything but iChat.

    In System Preferences I have input from the mic
    http://dl.dropbox.com/u/443565/ichat1.JPG

    In Skype I have input from the mic:
    http://dl.dropbox.com/u/443565/ichat3.JPG

    So we know the mic works, Skype, Garageband and Google Talk work flawless.

    iChat on the other hand doesn't here's in iChat's preference pane:
    http://dl.dropbox.com/u/443565/ichat2.JPG
    No input at all

    But when I look in connection doctor we see bars, its the same on the other machine, I'm on LAN.
    http://dl.dropbox.com/u/443565/ichat.JPG

    I double checked what you recommended and it all is configured correctly without any result.
    If you have no idea what the problem is, I'll fill out a bug report in apple feedback and hope it gets fixed in 10.7.

    Message was edited by: David Drahos
  • Ralph Johns (UK) Level 9 Level 9 (69,420 points)
    Ok,

    In that case we are talking about your end.

    First of All go to the Video Menu and double Check the Microphone Enabled item is ticked.
    If Speech is moving the System Preferences > Sound > Input bar but not the iChat one then this may be the cause.

    Then try a Video Chat and click the Mute On and Off (Leave a few seconds in between to get that data written to the .plist) Technically when you end a chat the Mute should be ON again at the Next chat (it will not get set to Off between chats)

    If those to things do not help...
    With that info you probably need to delete com.apple.ichat.plist as this .plist hold the volume settings for iChat. (This is despite not being able to adjust it in iChat's own settings)

    This .plist is found in your Home Folder/Library/Preferences and should be Dragged to the Trash.
    iChat then needs to be restarted.

    Restarting iChat will make the .plist get re-written from defaults held in the app itself.

    IMPORTNT NOTE
    Deleting this particular .plist deletes all the settings you may have changed in iChat's Preferences with the exception of the Accounts pane (this is read back from the Keychain)

    That will be:-
    Font
    Any Colour you chose for the Font.
    The Colour of the IM itself (Balloon colour normally)
    Whether you Save Transcripts, and any Sub options in iChat 4 and 5
    Anything in the general section.
    Anything in the Alerts section.

    These will need to be re-set.



    8:16 PM Tuesday; April 12, 2011

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • David the Canadian Level 1 Level 1 (20 points)
    Tried both of those with no luck although I did identify what the issue is.
    Garageband and Skype which both work, in their plist files identify the microphone as:
    "Built-In Microphone" or some variation
    Facetime and iChat (both don't work) identifies the mic by the driver:
    "Source:1768778083AppleHDAEngineInput:8,0,1,0:1"

    It would seem that this number isn't correct (it's the same when I reload the plist). I tried editing it with the value from garageband but it didn't work, I didn't think it would work.
  • Ralph Johns (UK) Level 9 Level 9 (69,420 points)
    Hi,

    Mine is Identified as
    VCDefaultMic > AppleUSBAudioEngine:Sonix Technology Co., Ltd.:USB 2.0 Camera:52100000:3

    It appears the same whether I use Property List Editor or Quick Look to study the .plist

    Mine is the Mic in my USB 2.0 UVC compliant camera (at present).

    Facetime and iChat both use an item called vcencoder when producing Video and Audio chats.

    Does this appear to be running in the Activity Monitor when you try Video in either App ?



    9:33 PM Tuesday; April 12, 2011

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • David the Canadian Level 1 Level 1 (20 points)
    I don't have vcencoder running on either of my machines. :/

    Here's some variations:
    Soundflower: SoundflowerEngine:0 <- This source does work, it allows me to feed output sound as my input, eg. play iTunes through iChat

    Internal Mic (as before):Source:1768778083AppleHDAEngineInput:8,0,1,0:1

    Line-In: Source:1818848869AppleHDAEngineInput:8,0,1,1:2 <-- I don't have a mic but when I plug in something in the jack the volume meter moves, so I assume it's active.

    Internal Mic (Other Mac): Source:1768778083AppleHDAEngineInput:1B,0,1,0:1
  • Ralph Johns (UK) Level 9 Level 9 (69,420 points)
    Hi,

    I was trying to ignore the Soundflower issue as it has not come up for a Long time.

    There have been times in iChat's past when the version of Soundflower has not always worked with the latest update.

    Is your Soundflower up-to-Date ?

    Their front page only lists up to 10.5 http://cycling74.com/products/soundflower/
    A very quick scan of their Forums did not show me anything with iChat or Face Time in the title (not that those would be all that were about those two).
    I am also not sure the Forums deal with SoundFlower.

    Edit.
    It looks like th latest version is here http://code.google.com/p/soundflower/downloads/list



    10:02 PM Tuesday; April 12, 2011

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

    Message was edited by: Ralph Johns (UK)
  • David the Canadian Level 1 Level 1 (20 points)
    It's up to date and the problem existed before. I was trying to see if I could route the internal mic through soundflower as a work around.
  • Ralph Johns (UK) Level 9 Level 9 (69,420 points)
    Ok,

    Next Step.
    Open the Audio MIDI setup thing in the Applications/Utilities folder
    Check that the Sound Input device there is also the Internal Mic.
    Next check that the sample rate is 44100

    I am not sure about the Channels as it was such a long time ago this used to pop up.
    I think it should be two channels even though iChat is Mono.



    10:25 PM Tuesday; April 12, 2011

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • David the Canadian Level 1 Level 1 (20 points)
    Ya those settings are correct. 44100.0 Hz and 2ch-24bit
Previous 1 2 Next